Bug 448425 - add snd-pcsp to blacklist
add snd-pcsp to blacklist
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hwdata (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-26 14:50 EDT by Stas Sergeev
Modified: 2008-06-02 08:33 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-02 08:33:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
add snd-pcsp to blacklist (204 bytes, patch)
2008-05-26 14:50 EDT, Stas Sergeev
no flags Details | Diff

  None (edit)
Description Stas Sergeev 2008-05-26 14:50:47 EDT
+++ This bug was initially created as a clone of Bug #447039 +++

Description of problem:
After upgrading to kernel 2.6.26-0.13.rc2.git5.fc10.x86_64, system
sounds are gone. Instead, one can hear corresponding clicks emanating
from the PC speaker. dmesg reveals a backtrace which appears to be
related to this issue.

Version-Release number of selected component (if applicable):
kernel-2.6.26-0.13.rc2.git5.fc10.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Upgrade to kernel-2.6.26-0.13.rc2.git5.fc10.x86_64
2. Reboot system.
3. Start GNOME session.
  
Actual results:
Click sounds from the PC speaker accompany system events.

Expected results:
GNOME sounds are played by the sound system.

Additional info:
- gnome-volume-control shows that the current audio device is pcsp.
- PulseAudio version is 0.9.10-1.fc9.
- ALSA version is 1.0.16-3.fc10.


-- Additional comment from davej@redhat.com on 2008-05-17 12:49 EST --
hmm, probably the addition of an ALSA driver for the PC speaker. This seems kind
of pointless, so I'll just turn it off.

Please check again with a build equal to or higher than
2.6.26-0.14.rc2.git5.fc10 when that appears.

Thanks.

-- Additional comment from jfrieben@hotmail.com on 2008-05-17 13:08 EST --
PC speaker support actually sounds nice. Shouldn't this issue be dealt
with upstream then? I don't mind opening a new bug report over there.

-- Additional comment from davej@redhat.com on 2008-05-17 13:27 EST --
Is this really useful ? From the Kconfig..

          If you don't have a sound card in your computer, you can include a
          driver for the PC speaker which allows it to act like a primitive
          sound card.

It's hard to imagine a machine without a sound card these days, given they
typically come onboard.  Hmm, though I suppose it's useful if you have a speaker
in your PC, and no external speakers.  The one concern I have is that adding
this driver will mean that everyone typically gets two ALSA output sources, and
which one gets picked by default is probably down to which driver gets loaded
first.  For a lot of people, that would be annoying if suddenly their music
comes out of their PC instead of their speakers.  Adding Lennart to the Cc,
perhaps he has some ideas on how to avoid that situation.

Another annoyance, is that this driver is unlikely to work well during some
periods of fedora development due to this..

#ifdef CONFIG_DEBUG_PAGEALLOC
        /* Well, CONFIG_DEBUG_PAGEALLOC makes the sound horrible. Lets alert */
        printk(KERN_WARNING "PCSP: CONFIG_DEBUG_PAGEALLOC is enabled, "
               "which may make the sound noisy.\n");
#endif

(We enable that option from time to time, though the build you tried didn't have
it turned back on yet).

I'll forward the backtrace upstream.

-- Additional comment from jfrieben@hotmail.com on 2008-05-18 06:20 EST --
Bug filed upstream at http://bugzilla.kernel.org/show_bug.cgi?id=10701

-- Additional comment from jfrieben@hotmail.com on 2008-05-18 10:57 EST --
Both audio devices register correctly on my system:

  card0/  cards   devices  oss/  pcsp@  timers
  card1/  CK804@  modules  pcm   seq/   version

It is furthermore possible to choose the default device by means of
gnome-sound-properties. So far, so good. It is definitely worthwile
to have some simple audio capability in case no external speakers
are available. Notebooks are of cause exempted herefrom, but in
general, this appears to be a compelling feature.
The clicks that I have describe seem to be due to some deficiency of
the NForce chipset of my Tyan K8E mainboard. In general, you expect
at least system sounds to be reproduced in a reasonable manner.
Comment 1 Stas Sergeev 2008-05-26 14:50:48 EDT
Created attachment 306697 [details]
add snd-pcsp to blacklist
Comment 2 Stas Sergeev 2008-05-26 14:53:54 EDT
Hi guys.

I second an opinion that having snd-pcsp
might be nice.
I've been suggested to just put it into
a blacklist rather than to disable completely,
so here's the patch.
Does such a solution look reasonable?
Comment 3 Karsten Hopp 2008-06-02 08:33:58 EDT
I've built hwdata-0.219 in rawhide with snd-pcsp blacklisted

Note You need to log in before you can comment on or make changes to this bug.