Bug 448513 - PackageKit crashes in fastestmirror plugin
PackageKit crashes in fastestmirror plugin
Status: CLOSED DUPLICATE of bug 448062
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-27 08:11 EDT by Matěj Cepl
Modified: 2008-05-27 11:24 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-27 11:24:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2008-05-27 08:11:16 EDT
Description of problem:
When running any PK-related command (pkcon, gpk-update-viewer, gpk-application)
I get this stacktrace:

[matej@viklef ~]$ pkcon get updates

    [......===.................................................]                

    [..........................................===.............]                

Error: internal-error : Error Type: <type 'exceptions.AttributeError'>

Error Value: 'NoneType' object has no attribute 'cacheonly'

  File : /usr/share/PackageKit/helpers/yum/get-updates.py , line 19, in <module>

    backend.get_updates(filter)

  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 1205, in get_updates

    ygl = self.yumbase.doPackageLists(pkgnarrow='updates')

  File : /usr/lib/python2.5/site-packages/yum/__init__.py , line 1372, in
doPackageLists

    for (n,a,e,v,r) in self.up.getUpdatesList():

  File : /usr/lib/python2.5/site-packages/yum/__init__.py , line 591, in <lambda>

    up = property(fget=lambda self: self._getUpdates(),

  File : /usr/lib/python2.5/site-packages/yum/__init__.py , line 476, in _getUpdates

    self._up = rpmUtils.updates.Updates(self.rpmdb.simplePkgList(),
self.pkgSack.simplePkgList())

  File : /usr/lib/python2.5/site-packages/yum/__init__.py , line 578, in <lambda>

    pkgSack = property(fget=lambda self: self._getSacks(),

  File : /usr/lib/python2.5/site-packages/yum/__init__.py , line 421, in _getSacks

    self.repos.populateSack(which=repos)

  File : /usr/lib/python2.5/site-packages/yum/repos.py , line 217, in populateSack

    self.doSetup()

  File : /usr/lib/python2.5/site-packages/yum/repos.py , line 67, in doSetup

    self.ayum.plugins.run('postreposetup')

  File : /usr/lib/python2.5/site-packages/yum/plugins.py , line 175, in run

    func(conduitcls(self, self.base, conf, **kwargs))

  File : /usr/lib/yum-plugins/fastestmirror.py , line 133, in postreposetup_hook

    if opts.cacheonly:



get-updates runtime was 54.5 seconds                                            

[matej@viklef ~]$ 


When running yum clean all (thought that I may have some junk in metadata) I got
this error message "Configuration file
/etc/yum/pluginconf.d/fastestmirror-asyncore.conf not found" (which doesn't make
much sense, because /usr/lib/yum-plugins/fastestmirror-asyncore.py speaks only
about /etc/yum/pluginconf.d/fastestmirror.conf).

When changing enabled=1 to enabled=0 in /etc/yum/pluginconf.d/fastestmirror.conf
PK-related packages work. Without it, they don't

Version-Release number of selected component (if applicable):
yum-utils-1.1.14-1.fc9.noarch
PackageKit-0.1.12-12.20080520.fc9.i386

How reproducible:
100%

Steps to Reproduce:
1.make sure fastestmirror is enabled
2.pkcon get updates
3.
  
Actual results:
collect stacktrace

Expected results:
get a list of available updates

Additional info:
yum itself with all its commands works correctly.
Comment 1 Luke Macken 2008-05-27 11:24:43 EDT

*** This bug has been marked as a duplicate of 448062 ***

Note You need to log in before you can comment on or make changes to this bug.