Bug 448760 - NetworkManager does not start sys-wide net. configuration, but ifup does
NetworkManager does not start sys-wide net. configuration, but ifup does
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
10
powerpc Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-05-28 13:04 EDT by W. Michael Petullo
Modified: 2009-09-13 20:48 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-13 20:48:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/sysconfig/network-scripts/ifcfg-wlan0 (226 bytes, text/plain)
2008-05-28 13:06 EDT, W. Michael Petullo
no flags Details
/etc/sysconfig/network (53 bytes, text/plain)
2008-05-28 13:07 EDT, W. Michael Petullo
no flags Details
/etc/sysconfig/wpa_supplicant (379 bytes, text/plain)
2008-05-28 13:07 EDT, W. Michael Petullo
no flags Details
/etc/wpa_supplicant/wpa_supplicant.conf (140 bytes, text/plain)
2008-05-28 13:08 EDT, W. Michael Petullo
no flags Details
Log of a NetworkManager service restart (wlan0 up fails) (14.27 KB, text/plain)
2008-05-28 13:13 EDT, W. Michael Petullo
no flags Details
Fragment of the output from iwlist (844 bytes, text/plain)
2008-05-28 15:23 EDT, W. Michael Petullo
no flags Details
Log of a failed NetworkManager service start (4.05 KB, text/plain)
2008-12-08 21:31 EST, W. Michael Petullo
no flags Details
Dmesg during a failed NetworkManager start (1.63 KB, text/plain)
2008-12-08 21:32 EST, W. Michael Petullo
no flags Details
Log of a successful ifup (3.24 KB, text/plain)
2008-12-08 21:33 EST, W. Michael Petullo
no flags Details
Dmesg during a successful ifup (796 bytes, text/plain)
2008-12-08 21:35 EST, W. Michael Petullo
no flags Details

  None (edit)
Description W. Michael Petullo 2008-05-28 13:04:26 EDT
Description of problem:
I have a system-wide wireless network configuration (i.e., /etc/sysconfig/network-scripts/ifcfg-
wlan0). I need to use a system-wide configuration because I use LDAP and Kerberos. Therefore, the 
network must be available before I log in.

NetworkManager will not bring my network up. Running "ifup wlan0" works fine.

Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-0.9.3.svn3623.fc9.ppc

How reproducible:
Every time

Steps to Reproduce:
1. Configure system to use LDAP for NSS and Kerberos for system authentication.
2. Configure the network using the files I have attached.
3. Reboot the system.
  
Actual results:
NetworkManager does not bring up the wireless link. The boot script prints "Waiting for network... 
[failed].

However, once the system is done booting, manually running "ifup wlan0" does bring the link up.

Expected results:
NetworkManager should bring the link up.

Additional info:
I am using the b43 drivers on an Apple iBook G3.

My network uses a hidden SSID. Any relation to bug #448437?

I've tried restarting the NetworkManager process after disabling SELinux, but the network initialization 
still fails.
Comment 1 W. Michael Petullo 2008-05-28 13:06:38 EDT
Created attachment 306952 [details]
/etc/sysconfig/network-scripts/ifcfg-wlan0
Comment 2 W. Michael Petullo 2008-05-28 13:07:08 EDT
Created attachment 306953 [details]
/etc/sysconfig/network
Comment 3 W. Michael Petullo 2008-05-28 13:07:35 EDT
Created attachment 306954 [details]
/etc/sysconfig/wpa_supplicant
Comment 4 W. Michael Petullo 2008-05-28 13:08:04 EDT
Created attachment 306955 [details]
/etc/wpa_supplicant/wpa_supplicant.conf
Comment 5 W. Michael Petullo 2008-05-28 13:13:54 EDT
Created attachment 306956 [details]
Log of a NetworkManager service restart (wlan0 up fails)
Comment 6 Dan Williams 2008-05-28 14:06:10 EDT
Could you update to:

https://admin.fedoraproject.org/updates/F9/pending/NetworkManager-0.7.0-0.9.3.svn3675.fc9

and retest?

Also, does an 'iwlist wlan0 scan' show your AP?
Comment 7 W. Michael Petullo 2008-05-28 15:23:18 EDT
Created attachment 306978 [details]
Fragment of the output from iwlist

I tried the new NetworkManager version suggested in the previous comment, but
it still did not connect.

I have attached the iwlist output corresponding to my wireless network.
Comment 8 Joshua Jensen 2008-05-30 00:05:39 EDT
I don't want to confuse this bug... but let me second this finding.  If the old
/etc/init.d/network isn't going to be running by default, and NM is... NM needs
to work :-)

Could it be as simple as "anaconda only sets NM_CONTROLLED= rather than
NM_CONTROLLED=yes as well" ?  This is from comment #6 of BZ #441886... but I've
noticed this myself on all my F9 machines.

I'm wondering why anaconda and NM aren't leaving us with a network that comes up
automatically... even for simple 100 Mbps eth0 connections.  Shouldn't have to
do an "ifup" manually to get a network connection.
Comment 9 W. Michael Petullo 2008-06-14 17:23:17 EDT
I am  now using NetworkManager-0.7.0-0.9.4.svn3675.fc9.ppc but my problem remains.

When I stop the NetworkManager service and run "nm-system-settings --debug --plugins=ifcfg-
fedora," the following is printed:

[...]
** Message ifcfg-fedora: parsing /etc/sysconfig/network-scripts/ifcfg-wlan0 ...
** Message ifcfg-fedora:   read connection 'System FlynComputing (wlan0)' ...
** Message ifcfg-fedora: parsing /etc/sysconfig/network-scripts/ifcfg-eth0 ...
** Message ifcfg-fedora:   read connection 'System eth0' ...
** Message ifcfg-fedora: parsing /etc/sysconfig/network-scripts/ifcfg-lo ...
** Message ifcfg-fedora:   read connection 'System lo' ...

But, if I bring the NetworkManager service up, wlan0 is still not brought up.
Comment 10 W. Michael Petullo 2008-09-06 11:05:22 EDT
This is still an issue with NetworkManager-0.7.0-0.11.svn4022.1.fc10.ppc.
Comment 11 John Poelstra 2008-10-15 17:45:31 EDT
This bug has been triaged
Comment 12 Bug Zapper 2008-11-25 21:21:02 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Charles R. Anderson 2008-11-29 16:22:37 EST
In my experience, wireless networks are never brought up until after logging in.
Comment 14 W. Michael Petullo 2008-11-30 12:30:20 EST
(In reply to comment #13)
> In my experience, wireless networks are never brought up until after logging
> in.

Please read the original report. Many people have valid requirements for a wireless network before logging in.
Comment 15 Charles R. Anderson 2008-11-30 12:36:24 EST
(In reply to comment #14)
> (In reply to comment #13)
> > In my experience, wireless networks are never brought up until after logging
> > in.
> 
> Please read the original report. Many people have valid requirements for a
> wireless network before logging in.

I agree.
Comment 16 Dan Williams 2008-12-01 12:12:01 EST
NM will bring up ifcfg wifi connections before login if they are set ONBOOT=yes and NM_CONTROLLED=yes.
Comment 17 W. Michael Petullo 2008-12-01 19:15:46 EST
(In reply to comment #16)
> NM will bring up ifcfg wifi connections before login if they are set ONBOOT=yes
> and NM_CONTROLLED=yes.

Yes. I am using these two lines. Please see this bug's first attachment.
Comment 18 W. Michael Petullo 2008-12-08 21:31:01 EST
Created attachment 326251 [details]
Log of a failed NetworkManager service start
Comment 19 W. Michael Petullo 2008-12-08 21:32:08 EST
Created attachment 326252 [details]
Dmesg during a failed NetworkManager start
Comment 20 W. Michael Petullo 2008-12-08 21:33:49 EST
Created attachment 326253 [details]
Log of a successful ifup
Comment 21 W. Michael Petullo 2008-12-08 21:35:09 EST
Created attachment 326254 [details]
Dmesg during a successful ifup
Comment 22 Dan Williams 2009-02-14 15:44:15 EST
Which kernel was this with?  Is this issue better with 2.6.27.12 kernels from updates?  It looks like perhaps the wifi AP wasn't seen from a scan, which could indicate driver issues.  When this happens, can you run 'nm-tool' and see if NM has found your AP?
Comment 23 W. Michael Petullo 2009-02-15 17:11:03 EST
Kernel is 2.6.27.12-170.2.5.fc10.ppc.

I just noticed something funny in my dmesg output (Comment #19). The dmesg says "wlan0: authenticate with AP 00:1c:f0:ea:14:87" But, this is not the MAC of my access point. nm-tool says my access point's MAC is 00:11:50:75:94:FA.

As you can see in Comment #1, the interface's ESSID is set to FlynComputing, which nm-tool confirms is 00:11:50:75:94:FA. Why is it trying to associate with the wrong access point?
Comment 24 W. Michael Petullo 2009-09-13 18:21:48 EDT
This really ought to be fixed by [1]. I am presently reviewing Fedora 12 Alpha and will provide feedback.

[1] https://fedoraproject.org/wiki/Features/NetworkManagerSystemConnections
Comment 25 W. Michael Petullo 2009-09-13 20:48:40 EDT
Confirmed fixed in Fedora 12 Alpha. Not concerned about Fedora 10.

Note You need to log in before you can comment on or make changes to this bug.