Bug 448802 - libdhcp6client-1.0.so.2 drops symbol dadlist, breaking nash yet again
libdhcp6client-1.0.so.2 drops symbol dadlist, breaking nash yet again
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dhcpv6 (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-28 16:39 EDT by Gilles Detillieux
Modified: 2008-05-28 17:00 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-28 17:00:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gilles Detillieux 2008-05-28 16:39:57 EDT
Description of problem:
The dhcpv6-1.0.17-1.fc10.src.rpm package, or more specifically subpackage
libdhcp6client-1.0.17-1.fc10.i386.rpm, breaks nash, and therefore mkinitrd,
because it drops the symbol dadlist which nash needs.  (nash is from
mkinitrd-6.0.52-2.fc9.src.rpm)

Version-Release number of selected component (if applicable):
1.0.17-1.fc10

How reproducible:
Always

Steps to Reproduce:
1. run "yum update" on a rawhide system to load up
libdhcp6client-1.0.17-1.fc10.i386.rpm.
2. run "/sbin/mkinitrd --allow-missing -f
/boot/initrd-2.6.26-0.37.rc4.fc10.i686.img 2.6.26-0.37.rc4.fc10.i686" or just
try upgrading a kernel through yum or rpm.
3. ls -l /boot/initrd-2.6.26-0.37.rc4.fc10.i686.img
  
Actual results:
/sbin/nash: symbol lookup error: /usr/lib/libdhcp6client-1.0.so.2: undefined
symbol: dadlist
(repeated 37 times)
and /boot/initrd-2.6.26-0.37.rc4.fc10.i686.img is only 50 bytes.

Expected results:
mkinitrd runs silently and makes an initrd of ~2.8 MB.

Additional info:
This is remarkably similar to bug 435636 from March 2, where
libdhcp6client-1.0.12 dropped the dhcpv6_client symbol.  Is someone a bit
overzealous in purging out "obsolete" parts from this library?  nash/mkinitrd
was updated only 3 weeks ago, so it's not exactly old cruft.
Comment 1 David Cantrell 2008-05-28 17:00:11 EDT
Just fixed in rawhide.

Yes, I am actively trying to get rid of this library (libdhcp6client) because it's horrible.  Over the weekend I 
removed the homegrown netlink code and have it using libnl instead.  I moved the dadlist variable by 
mistake, apologies.

Note You need to log in before you can comment on or make changes to this bug.