Bug 448851 - yum dependency failures upgrading from 5.1 to 5.2 via Satellite
yum dependency failures upgrading from 5.1 to 5.2 via Satellite
Status: CLOSED DUPLICATE of bug 444878
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Client (Show other bugs)
502
All Linux
low Severity high
: ---
: ---
Assigned To: Pradeep Kilambi
Brandon Perkins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-28 22:30 EDT by Ray Van Dolson
Modified: 2008-12-23 12:01 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-23 12:01:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum -v -d 8 update (168.14 KB, text/plain)
2008-05-28 22:31 EDT, Ray Van Dolson
no flags Details
yum update (19.86 KB, text/plain)
2008-05-28 22:31 EDT, Ray Van Dolson
no flags Details

  None (edit)
Description Ray Van Dolson 2008-05-28 22:30:58 EDT
!! Also see SR #1830866 !!

Description of problem:
Recently updated our Satellite Server from 5.0.1 to 5.0.2.  Now on some RHEL5.1
machines when an attempt to update them to 5.2 via yum (yum update) is done I
see strange dependency errors often times resulting in an endless loop.

Version-Release number of selected component (if applicable):
Satellite Server 5.0.2
yum-3.2.8-9.el5_2.1

How reproducible:
Most of the time?

Steps to Reproduce:
1. Run 'yum update' on RHEL 5.1 client attached to RHN Satellite Server
  
Actual results:
Dependency loop or failures.

Expected results:
Dependencies solved and successful update.

Additional info:
I see requirements such as "iptables = 1.3.5-0 for package: iptables-ipv6".

See these mailing list threads:

  https://www.redhat.com/archives/rhelv5-list/2008-May/msg00216.html
  https://www.redhat.com/archives/rhelv5-list/2008-May/msg00207.html

Could my Satellite be giving out bad metadata?

I will attach two yum logs (one verbose and one not).
Comment 1 Ray Van Dolson 2008-05-28 22:31:35 EDT
Created attachment 307007 [details]
yum -v -d 8 update
Comment 2 Ray Van Dolson 2008-05-28 22:31:50 EDT
Created attachment 307008 [details]
yum update
Comment 3 Pradeep Kilambi 2008-05-29 07:16:48 EDT
there were some metadata for few packages with deps in 5.0.2. It could possibly
be some outdated cache that might be causing this. Try the following and see if
it still happens:

on Sat Server:

* rm -rf /var/cache/rhn/repomd*

on Client:

* yum clean all

* yum update

This might timeout initially until the yum cache is regenerated on the server.
So watch for that as well.

Let me know if this helps.

Comment 4 Pradeep Kilambi 2008-05-29 07:27:09 EDT
Also want to mention, after "yum clean all" on the clients check your
/var/cache/yum/ and see if everything is cleaned up. If not nuke that stale data
with rm -rf /var/cache/yum/* . then run your yum update or rhn_check
Comment 5 Ray Van Dolson 2008-05-29 11:26:32 EDT
This seems to have worked.  After a yum clean all there was still data in the
local yum cache, but I cleared that out.  The update is now proceeding and there
were no loops or apparent issues with the metadata after it regenerated.

I'll pass this along to the other places I posted; might be a good kbase article
if it doesn't already exist.

Should the Satellite have wiped its own metadata during the 5.0.1 to 5.0.2
upgrade process?  Wonder how this happened.

Thanks!
Comment 7 Brandon Perkins 2008-12-23 12:01:11 EST
Unfortunately we did not document this well in the Release Notes.  But, the "yum clean all" should fix this situation.

*** This bug has been marked as a duplicate of bug 444878 ***

Note You need to log in before you can comment on or make changes to this bug.