Bug 448862 - GraphicsMagick-perl compiled against wrong version of perl
GraphicsMagick-perl compiled against wrong version of perl
Status: CLOSED DUPLICATE of bug 454087
Product: Fedora
Classification: Fedora
Component: GraphicsMagick (Show other bugs)
9
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Andreas Thienemann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-29 00:30 EDT by Dan Stahlke
Modified: 2009-04-08 01:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-08 01:34:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Stahlke 2008-05-29 00:30:22 EDT
Description of problem:
GraphicsMagick-perl installs modules for perl 5.8.8 and therefore won't run in
the perl that comes with Fedora 9 (perl version 5.10.0).

Version-Release number of selected component (if applicable):
Name       : GraphicsMagick-perl
Arch       : x86_64
Version    : 1.1.10
Release    : 3.fc9


How reproducible:
perl -MGraphics::Magick -e 1


Steps to Reproduce:
1. sudo yum install GraphicsMagick-perl
2. perl -MGraphics::Magick -e 1
3. find /usr/lib64/perl5 -name Magick.pm
  
Actual results:
$ perl -MGraphics::Magick -e 1
Can't locate Graphics/Magick.pm in @INC (@INC contains:
/usr/lib64/perl5/5.10.0/x86_64-linux-thread-multi /usr/lib/perl5/5.10.0
/usr/local/lib64/perl5/site_perl/5.10.0/x86_64-linux-thread-multi
/usr/local/lib/perl5/site_perl/5.10.0
/usr/lib64/perl5/vendor_perl/5.10.0/x86_64-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.10.0 /usr/lib/perl5/vendor_perl .).
BEGIN failed--compilation aborted.
$ find /usr/lib64/perl5 -name Magick.pm
/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/Graphics/Magick.pm


Expected results:
$ perl -MGraphics::Magick -e 1
(no error)
$ find /usr/lib64/perl5 -name Magick.pm
/usr/lib64/perl5/vendor_perl/5.10.0/x86_64-linux-thread-multi/Graphics/Magick.pm


Additional info:
Comment 1 Ask Bjørn Hansen 2009-04-08 01:34:28 EDT

*** This bug has been marked as a duplicate of bug 454087 ***

Note You need to log in before you can comment on or make changes to this bug.