Bug 448879 - Keyboard works for new users, but not the one migrated from F8
Keyboard works for new users, but not the one migrated from F8
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: atk (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-29 04:01 EDT by Greg Martyn
Modified: 2009-01-16 21:37 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-16 21:37:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (1.39 KB, text/plain)
2008-05-29 04:01 EDT, Greg Martyn
no flags Details
/var/log/Xorg.0.log (11.61 KB, text/plain)
2008-05-29 04:12 EDT, Greg Martyn
no flags Details

  None (edit)
Description Greg Martyn 2008-05-29 04:01:46 EDT
Description of problem:
I didn't destroy my /home when upgrading from F8 to F9. It contained my user
accound, /home/greg. When I logon as greg, the keyboard doesn't work. If I logon
as any other user, the keyboard works fine. It doesn't matter whether I run KDE
or Gnome.

Version-Release number of selected component (if applicable):
xorg-x11-drv-keyboard.x86_64             1.3.0-3.fc9            installed

How reproducible:
At every login

Steps to Reproduce:
1. Login as greg => keyboard doesn't work
2. Login as root => keyboard works
3. Login as test => keyboard works
  
Actual results:


Expected results:


Additional info:
Doesn't matter whether I'm using nvidia or nv X11 driver
Comment 1 Greg Martyn 2008-05-29 04:01:46 EDT
Created attachment 307023 [details]
xorg.conf
Comment 2 Greg Martyn 2008-05-29 04:12:05 EDT
Created attachment 307024 [details]
/var/log/Xorg.0.log
Comment 3 Peter Hutterer 2008-07-21 03:05:27 EDT
I can't see anything out of the ordinary in the log files.

The only thing I can think of that is remotely similar is X.Org bug 12186 [1],
but it's probably not it either. Have you resolved this issue yet?
Does the mouse work?
Does VT switching work?

[1] http://bugs.freedesktop.org/show_bug.cgi?id=12186
Comment 4 Greg Martyn 2008-07-21 17:19:37 EDT
Figured it out: Somehow the accessibility feature "slow keys" was turned on
without me knowing. I'm surprised that neither KDE nor Gnome have a notification
that the accessibility features are turned on. That would've saved me a lot of
time and frustration.
Comment 5 Peter Hutterer 2008-07-21 20:07:03 EDT
resolving as NOTABUG, caused by misconfiguration.
Comment 6 Matěj Cepl 2008-07-22 03:52:34 EDT
That's acutally not a bad idea. When we have to have accessibility on per
default (and I understand why), couldn't we have per default also some applet
showing that it is on?
Comment 7 Matthias Clasen 2009-01-16 21:37:50 EST
we have an a11y statusicon nowadays (in F10)

Note You need to log in before you can comment on or make changes to this bug.