Bug 448946 - NetworkManager-vpnc tries to use incorrect password
NetworkManager-vpnc tries to use incorrect password
Status: CLOSED DUPLICATE of bug 429287
Product: Fedora
Classification: Fedora
Component: NetworkManager-vpnc (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
: 459611 468852 (view as bug list)
Depends On:
Blocks: F10Target F10DesktopTarget
  Show dependency treegraph
 
Reported: 2008-05-29 12:34 EDT by Daniel Qarras
Modified: 2008-11-17 09:15 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-17 09:15:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Qarras 2008-05-29 12:34:20 EDT
Description of problem:
I've got NM/NM-vpnc/vpnc all installed and working well except when I'll try to
create a VPN connection and enter an incorrect password, next VPN connections
are also trying to use the incorrect password, i.e., NM does not ask for a
password (pw is not saved in keyring). After a reboot the password is queried
again and I can then use VPN.

Version-Release number of selected component (if applicable):
vpnc-0.5.1-5.fc9.i386
NetworkManager-vpnc-0.7.0-0.7.7.svn3627.fc9.i386


How reproducible:
Always.


Steps to Reproduce:
1. Create a VPN connection for NM, verify that it works with correct pw
2. Disconnect VPN, then initiate a new VPN connection with incorrect pw
3. Notice how all subsequent attempts fail with NM complaining "The VPN
connection 'MyVPN' failed because the VPN service stopped unexpectedly."

Actual results:
NM does not ask for password for VPN.

Expected results:
NM asks for VPN password.

Additional info:
In /var/log/messages I have:

May 29 19:33:07 localhost NetworkManager: <info>  Starting VPN service
'org.freedesktop.NetworkManager.vpnc'...
May 29 19:33:07 localhost NetworkManager: <info>  VPN service
'org.freedesktop.NetworkManager.vpnc' started
(org.freedesktop.NetworkManager.vpnc), PID 5142
May 29 19:33:07 localhost NetworkManager: <info>  VPN service
'org.freedesktop.NetworkManager.vpnc' just appeared, activating connections
May 29 19:33:07 localhost NetworkManager: <info>  VPN plugin state changed: 1
May 29 19:33:07 localhost NetworkManager: <info>  VPN plugin state changed: 3
May 29 19:33:07 localhost NetworkManager: <info>  VPN connection 'MyVPN'
(Connect) reply received.
May 29 19:33:07 localhost kernel: tun0: Disabled Privacy Extensions
May 29 19:33:07 localhost NetworkManager: <info>  VPN plugin state changed: 6
May 29 19:33:07 localhost NetworkManager: <WARN> 
connection_vpn_state_changed(): Could not process the request because no VPN
connection was active.
Comment 1 Matthew Booth 2008-06-29 17:25:01 EDT
+1. This is pretty bad.
Comment 2 John Poelstra 2008-10-15 19:38:56 EDT
This bug has been triaged
Comment 3 Dan Williams 2008-10-16 11:17:00 EDT
Is this still an issue with latest SVN versions (svn4022 and later)?
Comment 4 Daniel Qarras 2008-10-17 12:01:35 EDT
Unfortunately, it is still a problem. I'm now using NetworkManager-vpnc-0.7.0-0.11.svn4175.fc10.i386 and reproduced as follows:

1) Boot & login
2) Connect to your local network
3) Create the VPN connection with valid password, see how it works
4) Tear down VPN
5) Try to create the VPN connection with invalid password, see how it fails
6) Try to create the VPN connection, no password asked, and connection fails
Comment 5 Jeremy Fitzhardinge 2008-10-21 17:06:22 EDT
I'm seeing this as well.  If the VPN connection fails to start, then it remembers the password for the retry, even though it may not be valid any more; subsequent attempts will also fail.

If the connection succeeds, then it forgets the password and re-asks for it on the next connection as it is supposed to.
Comment 6 Nick Brown 2008-10-22 05:44:23 EDT
Probably a dupe of bug #429287 ?
Comment 7 Jeremy Fitzhardinge 2008-10-22 10:13:12 EDT
Perhaps; it looks similar.  I don't have a problem with it remembering passwords once a connection has been made and disconnected, only if the connection is never made in the first place.  But it could be a slightly different manifestation of the same bug.
Comment 8 Bill Nottingham 2008-10-30 16:51:17 EDT
*** Bug 468852 has been marked as a duplicate of this bug. ***
Comment 9 Dan Williams 2008-11-17 09:12:41 EST
*** Bug 459611 has been marked as a duplicate of this bug. ***
Comment 10 Dan Williams 2008-11-17 09:15:42 EST

*** This bug has been marked as a duplicate of bug 429287 ***

Note You need to log in before you can comment on or make changes to this bug.