Bug 448976 - Update to libc-client breaks php-imap
Update to libc-client breaks php-imap
Status: CLOSED DUPLICATE of bug 447184
Product: Fedora
Classification: Fedora
Component: libc-client (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-29 14:59 EDT by Jonathan S. Shapiro
Modified: 2008-05-29 15:24 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-29 15:24:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan S. Shapiro 2008-05-29 14:59:16 EDT
It appears that there is a package update problem. php-imap wants
libc-client2006, which provides libc-client.so.2006. If libc-client2006 is
present, yum update attempts to replace it with libc-client, which does NOT
provide libc-client.so.2006. I had not observed a problem with this prior to
php-imap 5.2.4-3, so it may conceivably be a problem with that package, but this
smells like a case where yum update is incorrectly analyzing package replacement
rules.

I have marked this "high" because it breaks updates in general and because
php-imap is widely used.

You ought to be able to repeat this by:

  rpm -e libc-client2006 php-imap
  yum install php-imap # pulls in libc-client2006
  yum update # tries to update to libc-client
Comment 1 Rex Dieter 2008-05-29 15:24:16 EDT

*** This bug has been marked as a duplicate of 447184 ***

Note You need to log in before you can comment on or make changes to this bug.