Bug 449072 - Spelling does not work
Spelling does not work
Status: CLOSED DUPLICATE of bug 443297
Product: Fedora
Classification: Fedora
Component: hunspell-bg (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-30 05:00 EDT by Peter Janakiev
Modified: 2008-09-08 12:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-08 12:28:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Janakiev 2008-05-30 05:00:47 EDT
Description of problem:
After the last night upgrade the software which was working with spelling
stopped doing so. Example software:
Gedit
LogJam
In Gedit there is a window where one can set the spelling language - setting it
to Bulgarian renders all words to be considered as misspelled (even though I am
sure it is not as this is my native language) 
In log jam in preferences one can also set the spelling language - again this
was set and working before the upgrade of enchant and enchant-aspell. 
May 30 00:28:06 Updated: 1:enchant-1.4.2-1.fc9.i386
May 30 00:30:58 Updated: 1:enchant-aspell-1.4.2-1.fc9.i386
The spell chck is not working for other apps even before that like Pidgin. 

Version-Release number of selected component (if applicable):
aspell-bg-4.1-2.fc9.i386
hunspell-bg-4.1-1.fc9.noarch
gtkspell-2.0.11-8.fc9.i386
gnome-spell-1.0.8-5.fc9.i386
enchant-aspell-1.4.2-1.fc9.i386


How reproducible:
Always


Steps to Reproduce:
1. Use gedit and set the spell check to automatic and language to Bulgarian 
2. Type "тест" - this is a correctly spelled word and still it is underlined as
misspelled. 
3.
  
Actual results:
Word considered as misspelled 

Expected results:
Recognize the dictionaries installed on the system 

Additional info:
I am not really sure which packet is doing this because oll the new stuff in
spelling infrastructure. 
Also I am using an account created in fedora 8 (kept /home when upgrading) so it
might be related.
Comment 1 Peter Janakiev 2008-06-18 18:46:50 EDT
I have made some more testing on this and it seem that the problem is not in
spelling as a whole but in the Bulgarian spelling, as Russian for example works
and again it uses ciyrlic characters. 
I think this should be changed as hunspell-bg bug.

Thanks
Comment 2 Caolan McNamara 2008-09-08 12:28:48 EDT

*** This bug has been marked as a duplicate of bug 443297 ***

Note You need to log in before you can comment on or make changes to this bug.