Bug 449217 - Rhythmbox is unable to play any sound files
Rhythmbox is unable to play any sound files
Status: CLOSED DUPLICATE of bug 449268
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
9
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-31 09:03 EDT by Markku Korkeala
Modified: 2008-06-02 14:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-02 14:41:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Pulseaudio output 1 from /var/log/message (1.32 KB, text/plain)
2008-06-02 11:58 EDT, Markku Korkeala
no flags Details
Pulseaudio output 2 from /var/log/message (1.05 KB, text/plain)
2008-06-02 11:59 EDT, Markku Korkeala
no flags Details

  None (edit)
Description Markku Korkeala 2008-05-31 09:03:59 EDT
Description of problem:
Rhythmbox is unable to play any sound files.

How reproducible:
Always on my computer

Steps to Reproduce:
1. Start rhythmbox
2. Press play button
  
Actual results:
Rhythmbox selects the song, fetches the album cover. But there is no sound and 
track position indicator stays at 0.00. GUI still works, if I select other song
there comes a red error mark on the first song, it says:
Playback Error
Internal data flow error.

If I try to quit, the gui freezes, otherwise I'm still able to use rhythmbox GUI.

Expected results:
Rhythmbox selects a song and starts playing it. Track position indicator would
advance and there would be sound.

Additional info:
At first when I installed Fedora 9 rhythmbox worked fine and played every file
that was supported. But after one day when I watched a DVD using xine rhythmbox
refuses to play any files. 

I've had this similar behaviour sometimes on Fedora 8, if I watched
some youtube videos with sound on using flash, that time reboot usually helped
(I think the pulseaudio was to blame). Now reboot doesn't help and I don't have
flash even installed. Also Totem doesn't play any sounds. Xine and xine based
players (for examble amarok) are able to play video and music files just fine.
Also fedora system sound seems to work.

Version-Release number of selected component (if applicable):
rhythmbox-0.11.5-12.fc9.i386
pulseaudio-0.9.10-1.fc9.i386
amarok-1.4.9.1-3.fc9.i386
Comment 1 Bastien Nocera 2008-06-02 05:14:40 EDT
What's the output of "rpm -qa flash-plugin libflashsupport" ?
Comment 2 Bastien Nocera 2008-06-02 05:26:10 EDT
And could you please try running gstreamer-properties, and setting the default
output to "autodetect".
Comment 3 Markku Korkeala 2008-06-02 11:58:47 EDT
Created attachment 307381 [details]
Pulseaudio output 1 from /var/log/message
Comment 4 Markku Korkeala 2008-06-02 11:59:38 EDT
Created attachment 307382 [details]
Pulseaudio output 2 from /var/log/message
Comment 5 Markku Korkeala 2008-06-02 12:00:02 EDT
There is no output from "rpm -qa flash-plugin libflashsupport", so they are not
installed:
[~]$ rpm -qa flash-plugin libflashsupport
[~]$ 

Changing the output from gstreamer-properties from the default "Custom" to
"Autodetect" didn't change anything, still no sound from rhythmbox and the track
progress indicator stays at 0.00. Though when I pressed "Test"-button from
gstreamer-properties I can hear the beep but it also outputs errors to terminal:
*** PULSEAUDIO: Unable to connect: Connection refused
*** Is your sound server running?
*** See: http://www.pulseaudio.org/wiki/Troubleshooting

And the testing: paplay /usr/share/sounds/generic.wav
showed that for some reasong pulseaudio-server isn't running when I log in. I
checked the /var/log/messages (see attachment 1 [details]), added myself to pulse-rt
group, logged out and logged back in. There are still errors in
/var/log/messages (see attachment 2 [details]), but now at least the pulseaudio server is
started when I log in:

[ ~]$ ps -ef | grep pulse
user	  5745  5742  0 18:28 ?        00:00:06 /usr/bin/pulseaudio --log-target=syslog
user      5749  5745  0 18:28 ?        00:00:00 /usr/libexec/pulse/gconf-helper
[~]$ 

And I can here the sound when running command:
paplay /usr/share/sounds/generic.wav
But still no sound in rhythmbox and track indicator stays at. And the GUI
freezes when trying to quit.
Comment 6 Bastien Nocera 2008-06-02 12:08:34 EDT
Did you stop the console kit daemon by any chance?
Comment 7 Bastien Nocera 2008-06-02 12:49:33 EDT
And you actually need to change the output to "Autodetect" in the
gnome-sound-properties (System->Preferences->Hardware->Sound). My apologies,
wrong tool...
Comment 8 Markku Korkeala 2008-06-02 13:50:56 EDT
Haven't touched console kit daemon in anyway myself, but changing output to
"Autodetect" in gnome-sound-properties fixed the problem, thank you very much!
Comment 9 Bastien Nocera 2008-06-02 14:41:59 EDT

*** This bug has been marked as a duplicate of 449268 ***

Note You need to log in before you can comment on or make changes to this bug.