Bug 449268 - No sound from totem / rythmbox
No sound from totem / rythmbox
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gstreamer-plugins-good (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
: 449203 449217 450585 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-01 08:01 EDT by markm
Modified: 2008-06-10 22:44 EDT (History)
12 users (show)

See Also:
Fixed In Version: 0.10.8-5.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-09 23:16:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Pulse audio plays flash audio, but not rythmbox audio. (194.89 KB, image/png)
2008-06-01 08:02 EDT, markm
no flags Details

  None (edit)
Description markm 2008-06-01 08:01:02 EDT
Description of problem:

I can hear gnome sounds, I can hear flash sounds, but when I try to play
anything in totem or rythmbox, I can hear only silence.

Version-Release number of selected component (if applicable):

latest from Fedora 9.

How reproducible:

always

Steps to Reproduce:
1. open a browser, type youtube.com, play any flash video with audio
2. open totem / rythmbox and select anything to play
3. open pulse audio volume control  

Actual results:

I can hear audio from flash video (and it's visible on the pulse audio volume
control), but I rythmbox plays music silently - it does not even appear on the
pulse audio volume control. I can even open Sounds applet and test sounds from
here (can hear the sound).

Expected results:

Rythmbox and Totem to play audio :)

Additional info:

See screenshot attached.
Comment 1 markm 2008-06-01 08:02:17 EDT
Created attachment 307305 [details]
Pulse audio plays flash audio, but not rythmbox audio.
Comment 2 Trond Danielsen 2008-06-02 02:34:24 EDT
I can confirm that this bug exist on x86_64 too. Sound work just fine if a use
"gst-launch filesrc location=someflacfile.flac ! flacdec ! pulsesink", and GNOME
system sounds  work just fine too.

If I open Rhythmbox (or Totem) and start playing, everything appear to be ok,
but the application does not show up in the Pulseaudio Volume Control and no
sound is coming out of the speaker.
Comment 3 Trond Danielsen 2008-06-02 02:35:17 EDT
*** Bug 449203 has been marked as a duplicate of this bug. ***
Comment 4 Bastien Nocera 2008-06-02 05:26:42 EDT
Could you please try running gstreamer-properties, and setting the default
output to "autodetect"?
Comment 5 Remy Maucherat 2008-06-02 07:34:52 EDT
I got hit by this issue when I updated. Going into gnome-sound-properties and
putting back the output to "Autodetect" fixed the issue (some were set to
"custom", for some reason). gstreamer-properties did nothing for me, for some
reason.
Comment 6 Trond Danielsen 2008-06-02 08:48:56 EDT
I can confirm that #5 work. I tried gstreamer-properties, but non of the
available options worked.
Comment 7 Martin Jürgens 2008-06-02 10:01:10 EDT
the bug is assigned to pulseaudio, but no new pulseaudio flew in lately. maybe
it is a bug in gstreamer? or gstreamer plugins deployed by livna? does playing
ogg work?
Comment 8 Fedora Update System 2008-06-02 12:46:55 EDT
gstreamer-plugins-good-0.10.8-3.fc9 has been submitted as an update for Fedora 9
Comment 9 David Mansfield 2008-06-02 13:30:47 EDT
gstreamer-plugins-good-10.8-3.fc9 doesn't seem to fix the problem for me. 
downgrading to 10.7 works fine.

fyi: upstream bug:

http://bugzilla.gnome.org/show_bug.cgi?id=532295
Comment 10 Bastien Nocera 2008-06-02 13:43:26 EDT
(In reply to comment #9)
> gstreamer-plugins-good-10.8-3.fc9 doesn't seem to fix the problem for me. 
> downgrading to 10.7 works fine.

Should do, I applied the work around, and verified that the output of the
configure scripts was correct:
http://koji.fedoraproject.org/koji/getfile?taskID=640384&name=build.log

configure: Using autoaudiosink as default audio sink
configure: Using alsasrc as default audio source
configure: Using autovideosink as default video sink
configure: Using v4lsrc as default video source
configure: Using goom as default visualizer
Comment 11 David Mansfield 2008-06-02 14:22:08 EDT
i can repeat the failure at will.  if you tell me what to do (ie. is there a way
to turn on debugging in rhythmbox with some env. var?) i can produce any logs
you want.

Comment 12 markm 2008-06-02 14:28:08 EDT
Suggestion #4 didn't work, but #5 did work, now I can play music using Totem and
Rhythmbox, thanks guys!
Comment 13 Bastien Nocera 2008-06-02 14:42:00 EDT
*** Bug 449217 has been marked as a duplicate of this bug. ***
Comment 14 Bastien Nocera 2008-06-02 14:44:42 EDT
As Remy mentioned, and Marek confirmed, the right tool to use is
gnome-sound-properties, not gstreamer-properties.
Comment 15 David Mansfield 2008-06-02 20:52:59 EDT
are you all saying that any user that ran against the buggy version once upon a
time (and now have the new version from testing) now needs to run
gnome-sound-properties, or that using it is a workaround while keeping the buggy
version installed, but that it should be unnecessary on the newer fixed version
10.8-3?
Comment 16 Fedora Update System 2008-06-03 03:31:19 EDT
gstreamer-plugins-good-0.10.8-3.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gstreamer-plugins-good'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-4867
Comment 17 Tim Wegener 2008-06-03 11:07:50 EDT
(In reply to comment #15)
> are you all saying that any user that ran against the buggy version once upon a
> time (and now have the new version from testing) now needs to run
> gnome-sound-properties, or that using it is a workaround while keeping the buggy
> version installed, but that it should be unnecessary on the newer fixed version
> 10.8-3?

The update didn't solve the problem for me until I changed the Sound Playback
settings to Autodetect in gnome-sound-properties. Now sound plays fine for me in
both rhythmbox (original reporter: please take care with spelling for the sake
of search) and totem. 

Comment 18 David Mansfield 2008-06-03 12:31:29 EDT
(In reply to comment #17)
> (In reply to comment #15)
> > are you all saying that any user that ran against the buggy version once upon a
> > time (and now have the new version from testing) now needs to run
> > gnome-sound-properties, or that using it is a workaround while keeping the buggy
> > version installed, but that it should be unnecessary on the newer fixed version
> > 10.8-3?
> 
> The update didn't solve the problem for me until I changed the Sound Playback
> settings to Autodetect in gnome-sound-properties. Now sound plays fine for me in
> both rhythmbox (original reporter: please take care with spelling for the sake
> of search) and totem. 
> 

having to do gnome-sound-properties is a workaround only, and cannot be
considered a fix.  what is the real fix for this bug?  what is the real cause?
for me, simply downgrading to 10.7 fixes the problem without the workaround. 
what else has changed between 10.7 and 10.8

Comment 19 Bastien Nocera 2008-06-03 13:58:07 EDT
(In reply to comment #18)
<snip>
> having to do gnome-sound-properties is a workaround only, and cannot be
> considered a fix.  what is the real fix for this bug?  what is the real cause?
> for me, simply downgrading to 10.7 fixes the problem without the workaround. 
> what else has changed between 10.7 and 10.8

Bleh, you're right, the new version is still busted, because the work-around
mentioned upstream doesn't work.
Comment 20 Bastien Nocera 2008-06-03 15:02:55 EDT
Fixed in -5:
http://koji.fedoraproject.org/koji/taskinfo?taskID=643626

Enjoy
Comment 21 David Mansfield 2008-06-03 15:28:03 EDT
works for me.  thanks.  by the way, the 'updates' page (bodhi) which used to
point to 10.8-3 now points to 10.8-5, and it inherited the comments and karma of
that old broken release.  that's a bit buggered, but at least gstreamer works!
Comment 22 Fedora Update System 2008-06-06 03:44:00 EDT
gstreamer-plugins-good-0.10.8-5.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gstreamer-plugins-good'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-4867
Comment 23 Bastien Nocera 2008-06-09 17:50:25 EDT
*** Bug 450585 has been marked as a duplicate of this bug. ***
Comment 24 Fedora Update System 2008-06-09 23:16:27 EDT
gstreamer-plugins-good-0.10.8-5.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 25 Roberto Bechtlufft 2008-06-10 22:44:32 EDT
The update did the trick here, thanks!

Note You need to log in before you can comment on or make changes to this bug.