Bug 449262 - Custom DNS settings
Custom DNS settings
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
9
i386 Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
: 451686 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-01 04:59 EDT by markm
Modified: 2008-11-02 17:13 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-02 17:10:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description markm 2008-06-01 04:59:39 EDT
Description of problem:

NetworkManager gives a facility to enter custom dns now - which is great, but it
actually uses dns given by dhcp server (don't know why).

Version-Release number of selected component (if applicable):

latest from Fedora 9 updates

How reproducible:

always

Steps to Reproduce:
1. create a new wifi profile
2. set static IP, ie. 192.168.0.100, netmask 255.255.255.0, gate 192.168.0.250
3. set custom dns to 208.67.222.222, 208.67.220.220
4. connect to the network
5. check connection information
  
Actual results:

Static IP - fine, works (finally!)
Custom DNS - primary is set to 192.168.0.250 (!), secondary is set to
208.67.222.222 - why??

Expected results:

DNS should be set to my custom dns.
Comment 1 Dan Williams 2008-06-02 17:10:24 EDT
The current behavior is to append your custom servers to the list the DHCP
server returns; already in upstream SVN there's an option to ignore what the
DHCP server returns and only use the specified values.  That should hit F9 in an
update quite soon.
Comment 2 Andrea Dell'Amico 2008-06-12 18:31:20 EDT
Something more: networkmanager appends the custom information of *all* the known
connections. It's true for the nameservers list and for the 'search domain' list.
Comment 3 Dan Williams 2008-11-02 17:10:03 EST
Should be working in latest NM updates (svn4022 and later).  Please reopen if it's not.  Thanks!
Comment 4 Dan Williams 2008-11-02 17:13:20 EST
*** Bug 451686 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.