Bug 449271 - firstboot --reconfig fails to start
firstboot --reconfig fails to start
Status: CLOSED DUPLICATE of bug 446608
Product: Fedora
Classification: Fedora
Component: system-config-keyboard (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-01 10:27 EDT by Russell Harrison
Modified: 2008-06-28 08:18 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-28 08:18:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Harrison 2008-06-01 10:27:40 EDT
Description of problem:
If I use firstboot --reconfig in my kickstart file or touch /etc/reconfigSys and
reboot firstboot will not start.

Version-Release number of selected component (if applicable):
firstboot-1.97-1.fc9.i386

How reproducible:
every time

Steps to Reproduce:
1. touch /etc/reconfigSys
2. reboot
  
Actual results:
firstboot fails to start with the following exception:

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/firstboot/interface.py", line 274, in c
reateScreens
    module.createScreen()
  File "/usr/share/firstboot/modules/keyboard.py", line 148, in createScreen
    if not self.kbd.beenset:
AttributeError: 'NoneType' object has no attribute 'beenset'

Expected results:
firstboot starts in reconfig mode and allows the user to reconfigure the system.

Additional info:
Comment 1 Lubomir Rintel 2008-06-28 08:18:51 EDT

*** This bug has been marked as a duplicate of 446608 ***

Note You need to log in before you can comment on or make changes to this bug.