Bug 446608 - Traceback from firstboot module
Traceback from firstboot module
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-keyboard (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
: 447737 449271 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-15 06:53 EDT by Tim Waugh
Modified: 2008-06-28 08:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-22 07:48:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
system-config-keyboard-traceback.patch (617 bytes, patch)
2008-05-15 06:53 EDT, Tim Waugh
no flags Details | Diff

  None (edit)
Description Tim Waugh 2008-05-15 06:53:30 EDT
Description of problem:
While installing a Fedora 9 system with kickstart I saw this traceback:

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/firstboot/interface.py", line 274, in
createScreens
    module.createScreen()
  File "/usr/share/firstboot/modules/keyboard.py", line 148, in createScreen
    if not self.kbd.beenset:
AttributeError: 'NoneType' object has no attribute 'beenset'

Version-Release number of selected component (if applicable):
system-config-keyboard-1.2.15-2.fc9

How reproducible:
Not sure.

Patch attached.
Comment 1 Tim Waugh 2008-05-15 06:53:30 EDT
Created attachment 305465 [details]
system-config-keyboard-traceback.patch
Comment 2 Lubomir Rintel 2008-05-15 08:12:43 EDT
Thanks for the report and the patch, committed in upstream SVN.
I will fix this only for Rawhide, unless you have objections against that.
Comment 3 Tim Waugh 2008-05-15 09:21:48 EDT
No objections -- it's not really something that's useful post-release anyway. 
Anyone using 'firstboot --reconfig' in a kickstart can always do:

%post
patch <<"EOF"
+++ ...
--- ...
@@ ...
...
EOF

with the patch in comment #1, as it's very small.
Comment 4 Lubomir Rintel 2008-05-22 06:37:59 EDT
*** Bug 447737 has been marked as a duplicate of this bug. ***
Comment 5 Lubomir Rintel 2008-05-22 07:48:21 EDT
Fixed in rawhide now.
Comment 6 Lubomir Rintel 2008-06-28 08:18:51 EDT
*** Bug 449271 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.