Bug 449273 - mftrace aborts fatally on unsupported metafont output
mftrace aborts fatally on unsupported metafont output
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mftrace (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Quentin Spencer
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 434394
  Show dependency treegraph
 
Reported: 2008-06-01 10:53 EDT by Hans Ulrich Niedermann
Modified: 2008-07-08 00:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-08 00:37:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans Ulrich Niedermann 2008-06-01 10:53:20 EDT
Description of problem:

  /usr/bin/mftrace around line 927:

  m = re.search ("\n!", log)
  start = m.start (0)

  No match found in log, m is None, None.start gives exception.
  Root cause is unknown, but this prevents lilypond rebuilds in rawhide.

Version-Release number of selected component (if applicable):

  1.2.14-4.fc9

How reproducible:

  100%

Steps to Reproduce:
  1. cvs checkout lilypond
  2. cd lilypond/devel
  3. make mockbuild
  
Actual results:

MFINPUTS=. mftrace --encoding ./out/feta11.enc --no-afm -I . -I ./out/
--formats=pfa,pfb,svg feta11
mftrace 1.2.14
Font `feta11'...
Warning: no extra font information for this font.
Consider writing a XX_guess_font_info() routine.
Using encoding file: `/builddir/build/BUILD/lilypond-2.10.33/mf/out/feta11.enc'
Running Metafont...
warning: mf: command exited with value 32512 (ignored) 
Metafont failed.  Excerpt from the log file: 
*****
Traceback (most recent call last):
  File "/usr/bin/mftrace", line 1412, in <module>
    
main()
  File "/usr/bin/mftrace", line 1408, in main
    
do_file (filename)
  File "/usr/bin/mftrace", line 1382, in do_file
    
base = gen_pixel_font (basename, metric, options.magnification)
  File "/usr/bin/mftrace", line 928, in gen_pixel_font
    
start = m.start (0)
AttributeError
: 
'NoneType' object has no attribute 'start'

Expected results:

  No error.

Additional info:

  See also the lilypond FTBFS bug at
https://bugzilla.redhat.com/show_bug.cgi?id=434394#c3
Comment 1 Matt Domsch 2008-07-08 00:37:56 EDT
builds as of 2008-07-03, version 1.2.14-4.fc10.

Note You need to log in before you can comment on or make changes to this bug.