Bug 434394 - lilypond failed massrebuild attempt for GCC 4.3
lilypond failed massrebuild attempt for GCC 4.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lilypond (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jon Ciesla
Fedora Extras Quality Assurance
:
: 440826 (view as bug list)
Depends On: 449273
Blocks: gcc43errors
  Show dependency treegraph
 
Reported: 2008-02-22 11:08 EST by Jesse Keating
Modified: 2013-01-09 22:10 EST (History)
4 users (show)

See Also:
Fixed In Version: rawhide
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-08 14:39:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-02-22 11:08:25 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=443752
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 Jon Stanley 2008-03-01 15:13:44 EST
scratch build 482723
Comment 2 Jon Stanley 2008-03-01 16:33:44 EST
                 from file-name.cc:10:
./include/std-vector.hh:260: error: 'string' was not declared in this scope
./include/std-vector.hh:260: error: template argument 1 is invalid
./include/std-vector.hh:260: error: template argument 2 is invalid
./include/std-vector.hh:260: error: invalid type in declaration before '(' token
./include/std-vector.hh:260: error: 'string' was not declared in this scope
./include/std-vector.hh:260: error: expected primary-expression before 'char'
./include/std-vector.hh:260: error: initializer expression list treated as
compound expression
Comment 3 Christopher Aillon 2008-04-19 01:05:46 EDT
Above is fixed in CVS.  However, a new error:

http://koji.fedoraproject.org/koji/taskinfo?taskID=573260

MFINPUTS=. mftrace --encoding ./out/feta11.enc --no-afm -I . -I ./out/
--formats=pfa,pfb,svg feta11
mftrace 1.2.14
Font `feta11'...
Warning: no extra font information for this font.
Consider writing a XX_guess_font_info() routine.
Using encoding file: `/builddir/build/BUILD/lilypond-2.10.33/mf/out/feta11.enc'
Running Metafont...
warning: mf: command exited with value 32512 (ignored) 
Metafont failed.  Excerpt from the log file: 
*****
Traceback (most recent call last):
  File "/usr/bin/mftrace", line 1412, in <module>
    main()
  File "/usr/bin/mftrace", line 1408, in main
    do_file (filename)
  File "/usr/bin/mftrace", line 1382, in do_file
    base = gen_pixel_font (basename, metric, options.magnification)
  File "/usr/bin/mftrace", line 928, in gen_pixel_font
    start = m.start (0)
AttributeError: 'NoneType' object has no attribute 'start'
Comment 4 Bug Zapper 2008-05-14 01:31:44 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Hans Ulrich Niedermann 2008-06-01 10:54:28 EDT
This looks like a bug in metafont to me. I have filed it at
https://bugzilla.redhat.com/show_bug.cgi?id=449273
Comment 6 Jon Ciesla 2008-08-27 10:58:35 EDT
*** Bug 440826 has been marked as a duplicate of this bug. ***
Comment 7 FTBFS 2008-09-05 12:13:02 EDT
This package has Failed to Build From Source for many months.  Per
http://fedoraproject.org/wiki/FTBFS, this package is now proposed for
removal from the distribution.  Please address this FTBFS bug
immediately, or this package will be removed from the distribution
within the next few weeks.

Thank you for your continued contributions to Fedora, and your
commitment to ensuring Fedora packages remain buildable from source
code.
Comment 8 Jon Ciesla 2008-09-05 12:19:24 EDT
Requested assistance on fedora-devel.  I am working on this currently.
Comment 9 Jon Ciesla 2008-09-08 14:39:12 EDT
Fixed.
http://koji.fedoraproject.org/koji/buildinfo?buildID=62194

Note You need to log in before you can comment on or make changes to this bug.