Bug 449280 - DPMS does not work with automatically started screensaver
DPMS does not work with automatically started screensaver
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-01 12:49 EDT by John Horne
Modified: 2008-07-01 06:06 EDT (History)
5 users (show)

See Also:
Fixed In Version: kdelibs-4.0.5-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-01 06:06:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Horne 2008-06-01 12:49:20 EDT
Description of problem:
DPMS seems to become disabled if screensavers are configured to start
automatically (via "System settings=>Desktop=>Screensaver").

Version-Release number of selected component (if applicable):
kdeartwork-extras-4.0.4-1.fc9.x86_64
kdebase-workspace-4.0.4-4.fc9.x86_64

How reproducible:
Every time.

Steps to Reproduce:
1. Configure a screensaver (via the "System settings")
2. Set the "Start automatically" option (for testing I set a low value of 2 mins)
3. Leave desktop alone until screensaver kicks in, and then for another 30mins
or so. DPMS should have switch to standby or off by then.
  
Actual results:
Monitor stays on, and screensaver still shows. Monitor power light stays green.

Expected results:
Monitor should blank. On my monitor the power light goes orange in power saving
mode.

Additional info:
The point here is that if the "Start automatically" option is not set, then it
all works as expected. The monitor goes to powersaving mode after 10 mins.
I have tried this with the default "Blank screen" screensaver, with "Science",
and with "Bubbles3D" (an xscreensaver OpenGL screensaver).

The *only* changed required to make DPMS work is to unset the "Start
automatically" option.
Comment 1 Rex Dieter 2008-06-01 13:07:48 EDT
This looks like a good candidate to report upstream to bugs.kde.org
Comment 2 Steven M. Parrish 2008-06-27 12:27:15 EDT
As Rex suggested please report upstream at bugs.kde.org and add upstream info to
this report.  We will monitor upstream for resolution.
Comment 3 John Horne 2008-06-29 18:04:02 EDT
Sorry,thought I had done that.

Bug now reported at http://bugs.kde.org/show_bug.cgi?id=165368




John.
Comment 4 John Horne 2008-07-01 06:06:15 EDT
Okay, this seems to be fixed now. As reported to KDE, I upgraded kdelibs to
version kdelibs-4.0.5-4.fc9.x86_64 and have repeatedly retested the problem. It
works fine every time now.


Thanks,

John.

Note You need to log in before you can comment on or make changes to this bug.