Bug 449290 - KMIX cannot configure global shortcuts
KMIX cannot configure global shortcuts
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdemultimedia (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks: KDE41
  Show dependency treegraph
 
Reported: 2008-06-01 16:52 EDT by Aniket
Modified: 2008-07-17 16:13 EDT (History)
4 users (show)

See Also:
Fixed In Version: 4.0.98
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-17 16:13:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Configure shortcuts dialog in Kmix (104.20 KB, image/png)
2008-06-02 13:02 EDT, Aniket
no flags Details

  None (edit)
Description Aniket 2008-06-01 16:52:35 EDT
Description of problem:
I am running KDE 4.1 Beta 1 (kde 4.0.80) packages from rawhide on my fedora 9
install. 

Version-Release number of selected component (if applicable):
kdemultimedia-4.0.80-1.fc10.i386

How reproducible:
Start Kmix , go to Global Shortcuts configuration, the Global shortcuts cannot
be configured, its disabled. Also increase volume/decrease volume not listed in
the list of global shortcuts.


Steps to Reproduce:
1.Start KMIX
2.Open Mixer Window
3.Click configure shortcuts, there global shortcuts config is disabled and
increase/decrease volume not listed, only toggle mute is present
  
Actual results:
Cannot configure global shortcuts for KMIX

Expected results:
Should be able to configure global shortcuts fro KMIX

Additional info:
This functionality was working well in kde 4.0.3 wich came with fedora 9 default.
Comment 1 Rex Dieter 2008-06-01 21:18:35 EDT
This is an excellent candidate for reporting upstream to bugs.kde.org
Comment 2 Aniket 2008-06-02 13:02:51 EDT
Created attachment 307514 [details]
Configure shortcuts dialog in Kmix
Comment 3 Aniket 2008-06-02 13:04:22 EDT
I have attached a screenshot of KMIX shortcuts cinfiguration dialog, with the
problem area highlighted. Please tell me if any more info is needed. 
Comment 4 Kevin Kofler 2008-06-26 21:21:22 EDT
Is this still an issue with 4.0.83 (4.1 beta2)?
Comment 5 Aniket 2008-06-27 00:15:13 EDT
The problem is half fixed. The shortcuts can be configured from KDE system
settings,and they work fine too, but they are lost on next login. 
Comment 6 Kevin Kofler 2008-06-27 20:31:44 EDT
That sounds like a different bug. Do you get any KCrash dialogs when you're 
logging out?
Comment 7 Aniket 2008-06-27 21:14:07 EDT
I get Kcrash about Klipper sometimes. I will observe again and report back
Comment 8 Kevin Kofler 2008-07-01 12:23:06 EDT
Can you please report your current problem ("The shortcuts can be configured 
from KDE system settings,and they work fine too, but they are lost on next 
login.") as a KMix bug at http://bugs.kde.org/ ?
Comment 9 Aniket 2008-07-02 16:26:12 EDT
Ok , I confirmed the problem on  a fresh F9 install , with kde 4.0.84 packages. 
I will report at kde bugs. 
Comment 10 Steven M. Parrish 2008-07-17 15:51:14 EDT
Did you report upstream?  If so please add upstream info to this report.  Thanks
Comment 11 Aniket 2008-07-17 16:01:28 EDT
Hi 
I had reported this upstream , and yesterday I updated to the latest 4.0.98 and 
the bug is gone! yay!

But I have a problem with kopete , I will open a separate bug for that. 

Note You need to log in before you can comment on or make changes to this bug.