Bug 449362 - No Fedora 9 version of perl-Net-Netmask
No Fedora 9 version of perl-Net-Netmask
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: perl-Net-Netmask (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Warren Togami
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9_5.10_REBUILD
  Show dependency treegraph
 
Reported: 2008-06-02 08:34 EDT by Douglas E. Warner
Modified: 2008-07-07 06:31 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.9015-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-06 04:50:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Douglas E. Warner 2008-06-02 08:34:38 EDT
The version of perl-Net-Netmask that is in Fedora 9 is the Fedora 8 version;
built for the wrong version of perl:
perl-Net-Netmask-1.9015-1.fc8.noarch.rpm

Please rebuild for Fedora 9.
Comment 1 Fedora Update System 2008-06-05 15:11:40 EDT
perl-Net-Netmask-1.9015-2.fc9 has been submitted as an update for Fedora 9
Comment 2 Fedora Update System 2008-06-06 03:52:33 EDT
perl-Net-Netmask-1.9015-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 3 Paul Howarth 2008-06-30 10:24:12 EDT
It would be a good idea to add to this package:

Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))

Virtually all of the perl packages have this idiom, and it ensures that the
package will show up in broken dependency reports next time the perl version
changes.
Comment 4 Douglas E. Warner 2008-06-30 10:29:32 EDT
Re: comment#3

Paul, you may want to do this yourself if you're a Fedora maintainer; the ACLs
are open and the packager seems to be busy.
Comment 5 Paul Howarth 2008-06-30 11:32:14 EDT
Done (for devel):

Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=687429

Note You need to log in before you can comment on or make changes to this bug.