Bug 449370 - parted info pages need update
parted info pages need update
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: parted (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Joel Andres Granados
Alexander Todorov
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-02 10:00 EDT by Issue Tracker
Modified: 2010-10-22 21:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:09:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
possible patch for manpage and info page (2.91 KB, patch)
2008-06-02 10:03 EDT, Martin Poole
no flags Details | Diff

  None (edit)
Description Issue Tracker 2008-06-02 10:00:13 EDT
Escalated to Bugzilla from IssueTracker
Comment 1 Issue Tracker 2008-06-02 10:00:15 EDT
(parted) help mkpart                                                      
  mkpart PART-TYPE [FS-TYPE] START END     make a partition

        PART-TYPE is one of: primary, logical, extended
        FS-TYPE is one of: ext3, ext2, fat32, fat16, hfsx, hfs+, hfs, jfs,
        linux-swap, ntfs, reiserfs, hp-ufs, sun-ufs, xfs, apfs2, apfs1, asfs,
        amufs5, amufs4, amufs3, amufs2, amufs1, amufs0, amufs, affs7, affs6,
        affs5, affs4, affs3, affs2, affs1, affs0
        START and END are disk locations, such as 4GB or 10%.  Negative values
        count from the end of the disk.  For example, -1s specifies exactly the
        last sector.
        
        mkpart makes a partition without creating a new file system on the
        partition.  FS-TYPE may be specified to set an appropriate partition
        ID.

However, info parted fails to list ext3. Which has only been out -- what 5 years? Anyway, we should cross check the info pages and make sure that they accurately represent the program's current state because the man page is so weak and because the info pages are supposed to be the definitive reference.
This event sent from IssueTracker by mpoole  [Support Engineering Group]
 issue 181315
Comment 2 Martin Poole 2008-06-02 10:03:01 EDT
Created attachment 307366 [details]
possible patch for manpage and info page
Comment 3 RHEL Product and Program Management 2008-06-02 15:56:06 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Joel Andres Granados 2008-06-03 03:03:57 EDT

*** This bug has been marked as a duplicate of 429326 ***
Comment 5 Martin Poole 2008-06-23 04:15:40 EDT
re-opening as this is not resolved in the claimed duplicate.
Comment 6 Joel Andres Granados 2008-06-23 05:39:59 EDT
What was addressed in the duplicate was the parted documentation.  I added  to
the known issues section the fact the ext3 is not supported.  The patch that you
propose is directed to the man page, which has already been handled with a comment.

I will do the same thing in the texi documentation.  What appears in comment #0
is not in any way related to the texi or man page files.  It is hard coded in
parted.  This will also required a comment of some sort.

I prefer the comment as apposed to erasing the "ext3" string because parted
detects ext3 and it does not support it currently, but it will shortly.  I know
it came out a long time ago, but this will be done shortly.
Comment 7 Joel Andres Granados 2008-06-23 06:14:34 EDT
Are there any more commands besides `help mkpart` that show the ext3 fs?
Comment 9 Joel Andres Granados 2008-06-26 07:30:30 EDT
The resize command also had this issue.  I also changed that.
Comment 10 Joel Andres Granados 2008-06-26 07:48:35 EDT
This will be availabel in parted-1.8.1-19
Comment 12 Alexander Todorov 2008-10-23 03:41:55 EDT
parted.info:
Node: mkfs - doesn't list ext3
Node: mkpart - doesn't list ext3
Node: mkpartfs - doesn't list ext3
Node: resize - lists ext3 in supported filesystems

parted.8.gz:
mkfs partition fs-type - doesn't list ext3
mkpart part-type - doesn't list ext3

Joel,
can you clarify what is the current situation with parted? As I understand some operations doesn't work on ext3 file systems. Can you specify which do work and ext3 should be listed along side with the parted command and which not?
Comment 13 Joel Andres Granados 2008-10-23 05:03:15 EDT
Isn't there a message along the lines of :
"
 Currently parted does not support ext3 resizing, please use resize2fs instead
"
in the parted info pages, I mean.
Comment 16 errata-xmlrpc 2009-01-20 16:09:06 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0110.html

Note You need to log in before you can comment on or make changes to this bug.