Bug 449373 - newer libc-client package is incompatible with the older libc-client2006
newer libc-client package is incompatible with the older libc-client2006
Status: CLOSED DUPLICATE of bug 447184
Product: Fedora
Classification: Fedora
Component: libc-client (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-02 10:14 EDT by Steven Stern
Modified: 2008-06-02 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-02 12:48:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Stern 2008-06-02 10:14:50 EDT
After installing php-imap, yum update fails due to a dependency on
libc-client.so.2006


1) Install php-imap

[root@sdslx ~]# yum install php-imap
Installing:
 php-imap                i386       5.2.4-3          fedora  48 k
Installing for dependencies:
 libc-client2006         i386       2006k-0.1.0709171900.fc8  fedora          665 k

Installed: php-imap.i386 0:5.2.4-3
Dependency Installed: libc-client2006.i386 0:2006k-0.1.0709171900.fc8
Complete!

2) Look at PHP parts installed

[root@sdslx ~]# rpm -qa |grep php
php-5.2.4-3
php-pdo-5.2.4-3
php-ldap-5.2.4-3
php-mbstring-5.2.4-3
php-imap-5.2.4-3
php-eaccelerator-0.9.5.2-1.fc8
php-common-5.2.4-3
php-odbc-5.2.4-3
php-cli-5.2.4-3
php-mysql-5.2.4-3
php-gd-5.2.4-3

3) Try a general update

[root@sdslx ~]# yum update
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package libc-client.i386 0:2007a1-3.fc8 set to be updated
--> Processing Dependency: libc-client.so.2006 for package: php-imap
--> Finished Dependency Resolution
Error: Missing Dependency: libc-client.so.2006 is needed by package php-imap
Comment 1 Rex Dieter 2008-06-02 12:48:55 EDT

*** This bug has been marked as a duplicate of 447184 ***

Note You need to log in before you can comment on or make changes to this bug.