Bug 449376 - PackageKit can't install an i386 package which is already installed in x86_64
PackageKit can't install an i386 package which is already installed in x86_64
Status: CLOSED DUPLICATE of bug 447957
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-02 10:25 EDT by Edouard Bourguignon
Modified: 2008-06-03 09:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-03 09:29:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edouard Bourguignon 2008-06-02 10:25:30 EDT
Description of problem:
When you need to install the i386 version of a package which is already
installed for x86_64 PackageKit failed to install saying the package is already
installed. Maybe the PackageKit backend forget to pass the arch parameter to yum?

Version-Release number of selected component (if applicable):
PackageKit-0.1.12-13.20080522.fc9.x86_64

How reproducible:
Seems static.

Steps to Reproduce:
1. yum install libXp.x86_64
2. Now try to install libXp (i386) with PackageKit
3. PackageKit says package's already installed (similar to yum install libXp)
  
Actual results:
PackageKit can't install the i386 package if the x86_64 version is already
installed.

Expected results:
PackageKit should install the selected arch version of a package.

Additional info:
Or maybe it's specific to libXp? But same problem occurs when trying to install
libXtst.i386 after libXtst.x86_64.

Have to install this package with "yum install <package>.i386"
Comment 1 Richard Hughes 2008-06-03 09:29:28 EDT

*** This bug has been marked as a duplicate of 447957 ***

Note You need to log in before you can comment on or make changes to this bug.