Bug 449534 - FTBFS libapreq2-2.09-0.15.rc2.fc9
FTBFS libapreq2-2.09-0.15.rc2.fc9
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libapreq2 (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Bojan Smojver
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
:
Depends On:
Blocks: FTBFS
  Show dependency treegraph
 
Reported: 2008-06-02 16:25 EDT by FTBFS
Modified: 2008-06-04 21:09 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-04 21:09:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log.bz2 (3.17 KB, application/x-bzip2)
2008-06-02 16:26 EDT, FTBFS
no flags Details
build.log.bz2 (7.17 KB, application/x-bzip2)
2008-06-02 16:26 EDT, FTBFS
no flags Details
root.log.bz2 (12.63 KB, application/x-bzip2)
2008-06-02 16:26 EDT, FTBFS
no flags Details
build.log.bz2 (7.10 KB, application/x-bzip2)
2008-06-02 16:26 EDT, FTBFS
no flags Details
config.status (37.84 KB, text/plain)
2008-06-03 10:27 EDT, Matt Domsch
no flags Details

  None (edit)
Description FTBFS 2008-06-02 16:25:55 EDT
libapreq2-2.09-0.15.rc2.fc9.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
Comment 1 FTBFS 2008-06-02 16:26:20 EDT
Created attachment 307783 [details]
root.log.bz2

root.log for i386
Comment 2 FTBFS 2008-06-02 16:26:29 EDT
Created attachment 307784 [details]
build.log.bz2

build.log for i386
Comment 3 FTBFS 2008-06-02 16:26:39 EDT
Created attachment 307785 [details]
root.log.bz2

root.log for x86_64
Comment 4 FTBFS 2008-06-02 16:26:50 EDT
Created attachment 307786 [details]
build.log.bz2

build.log for x86_64
Comment 5 Bojan Smojver 2008-06-02 19:40:22 EDT
Looking at the build log:
-----------------------------------
/etc/profile: line 38: /bin/hostname: No such file or directory
sh: /usr/sbin/apxs: No such file or directory
cat: 
/.mmn
: No such file or directory
-----------------------------------

Without apxs, this build has zero chance of succeeding. The package spec file
correctly includes:
-----------------------------------
BuildRequires:  httpd-devel >= 2.0.48
-----------------------------------

Which in turn delivers /usr/sbin/apxs.

So, I don't know what's going on here. Maybe we don't have permission to look
into /usr/sbin or something in the build system?
Comment 6 Matt Domsch 2008-06-03 00:08:12 EDT
I don't think that's the problem.  It's something to do with glue:

Making all in glue
make[1]: Entering directory `/builddir/build/BUILD/libapreq2-2.09/glue'
cd perl; perl  Makefile.PL -apxs /usr/sbin/apxs INSTALLDIRS=vendor
Can't find apache include directory at Makefile.PL line 66.
make[1]: *** [perl/Makefile] Error 9
make[1]: Leaving directory `/builddir/build/BUILD/libapreq2-2.09/glue'
make: *** [all-recursive] Error 1


Comment 7 Bojan Smojver 2008-06-03 00:40:51 EDT
The "Can't find apache include directory at Makefile.PL line 66." is the result
of APACHE2_INCLUDES not being present in config.status:
----------------------------
    slurp my $config => "$base_dir/config.status";
    $config =~ /^s,\@APACHE2_INCLUDES\@,([^,]+)/m or
        die "Can't find apache include directory";
----------------------------

And this line of config.status is supposed to be written out by configure, using
this in acinclude.m4:
----------------------------
APACHE2_INCLUDES=-I`$APACHE2_APXS -q INCLUDEDIR`
[...]
AC_SUBST(APACHE2_INCLUDES)
----------------------------

I can see this in my config.status on my F9 machine. Can you attach the
config.status file from that run?
Comment 8 Matt Domsch 2008-06-03 10:27:07 EDT
Created attachment 308242 [details]
config.status
Comment 9 Bojan Smojver 2008-06-03 18:58:52 EDT
Thank Matt. Looks like the format of config.status changed:

new: S["APACHE2_INCLUDES"]="-I/usr/include/httpd"

old: s,@APACHE2_INCLUDES@,|#_!!_#|-I/home/groups/devel/run/apache/include,g

I'm guessing the version of autoconf delivered this change or something...
Comment 10 Bojan Smojver 2008-06-04 21:09:09 EDT
This has been fixed in 0.17.rc2. Fix for this has been committed upstream as well.

Note You need to log in before you can comment on or make changes to this bug.