Bug 449548 - FTBFS evolution-brutus-1.2.11-2.fc9
FTBFS evolution-brutus-1.2.11-2.fc9
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution-brutus (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
:
Depends On:
Blocks: FTBFS
  Show dependency treegraph
 
Reported: 2008-06-02 16:33 EDT by FTBFS
Modified: 2008-06-10 22:15 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.2.17-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-10 22:15:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log.bz2 (6.37 KB, application/x-bzip2)
2008-06-02 16:33 EDT, FTBFS
no flags Details
build.log.bz2 (1.92 KB, application/x-bzip2)
2008-06-02 16:34 EDT, FTBFS
no flags Details
root.log.bz2 (48.05 KB, application/x-bzip2)
2008-06-02 16:34 EDT, FTBFS
no flags Details
build.log.bz2 (1.90 KB, application/x-bzip2)
2008-06-02 16:34 EDT, FTBFS
no flags Details

  None (edit)
Description FTBFS 2008-06-02 16:33:22 EDT
evolution-brutus-1.2.11-2.fc9.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
Comment 1 FTBFS 2008-06-02 16:33:51 EDT
Created attachment 307819 [details]
root.log.bz2

root.log for i386
Comment 2 FTBFS 2008-06-02 16:34:33 EDT
Created attachment 307820 [details]
build.log.bz2

build.log for i386
Comment 3 FTBFS 2008-06-02 16:34:45 EDT
Created attachment 307821 [details]
root.log.bz2

root.log for x86_64
Comment 4 FTBFS 2008-06-02 16:34:57 EDT
Created attachment 307822 [details]
build.log.bz2

build.log for x86_64
Comment 5 Jules Colding 2008-06-03 12:05:02 EDT
Fixed in svn
Comment 6 Alex Lancaster 2008-06-10 06:49:08 EDT
(In reply to comment #5)
> Fixed in svn

That's great, but we really a new tarball, couldn't find any here:

http://www.42tools.com/sites/default/files/downloads/dist/evolution-brutus/Rawhide/SOURCES/

can you provide a new upstream tarball to make a new build from?  Thanks.  

(Packages that fail to build from source may be removed after F-10 Alpha is
released, so we don't want that ... ;-) ).
Comment 7 Alex Lancaster 2008-06-10 06:52:53 EDT
A simple bump-n-build didn't work:

http://koji.fedoraproject.org/koji/taskinfo?taskID=655243

presumably because it requires porting to the new evolution data server API or
somesuch?
Comment 8 Jules Colding 2008-06-10 07:44:36 EDT
Yes, the old one did but not the one in svn. I've made a new rawhide release here:

http://www.42tools.com/sites/default/files/downloads/dist/evolution-brutus/Rawhide/
Comment 9 Alex Lancaster 2008-06-10 08:23:06 EDT
Thanks.  Seems like some clock-skew with the tarball:

checking for a BSD-compatible install... 
/usr/bin/install -c
checking whether build environment is sane... 
configure: error: newly created file is older than distributed files!
Check your system clock
error: Bad exit status from /var/tmp/rpm-tmp.15546 (%build)
    Bad exit status from /var/tmp/rpm-tmp.15546 (%build)


I also noticed similar oddness when extracted the tarball to check inside:

tar zxvf evolution-brutus-1.2.16.tar.gz 
evolution-brutus-1.2.16/
evolution-brutus-1.2.16/acinclude.m4
evolution-brutus-1.2.16/Makefile.in
tar: evolution-brutus-1.2.16/Makefile.in: time stamp 2008-06-10 06:37:16 is
5098.89086422 s in the future
evolution-brutus-1.2.16/config.guess
tar: evolution-brutus-1.2.16/config.guess: time stamp 2008-06-10 06:37:16 is
5098.889698432 s in the future
evolution-brutus-1.2.16/install-sh
tar: evolution-brutus-1.2.16/install-sh: time stamp 2008-06-10 06:37:13 is
5095.889473487 s in the future


http://koji.fedoraproject.org/koji/getfile?taskID=655310&name=build.log
Comment 10 Jules Colding 2008-06-10 08:38:02 EDT
What can I do to fix the clock skew?
Comment 11 Alex Lancaster 2008-06-10 08:45:45 EDT
I'm not sure.  The time on the computer I'm untarring is

Tue Jun 10 05:44:32 MST 2008

which is the correct time here.  Does it untar correctly for you?
Comment 12 Jules Colding 2008-06-10 08:49:46 EDT
OK, I noticed that ntpd didn't run on my rawhide build box so the time was 2
hours off. I'll try with a new build - stay tuned...
Comment 13 Jules Colding 2008-06-10 09:04:53 EDT
OK, I can't get ntpd running. ntpdate says "no servers can be used, exiting".
Would waiting for two hours before attempting another build work for you?

Sorry,
  jules
Comment 14 Alex Lancaster 2008-06-10 09:15:07 EDT
You could try just setting your time manually.  I may have to go soon, will try
later.  
Comment 15 Jules Colding 2008-06-10 13:57:10 EDT
OK, I think the time problem is fixed. Please try x.n.17 from the usual place.
Comment 16 Alex Lancaster 2008-06-10 22:15:29 EDT
Thanks.  Fixed in evolution-brutus-1.2.17-1.fc10:

http://koji.fedoraproject.org/koji/buildinfo?buildID=52303

Closing.

Note You need to log in before you can comment on or make changes to this bug.