Bug 449637 - FTBFS ekg2-0.2-0.1.rc1.fc10
FTBFS ekg2-0.2-0.1.rc1.fc10
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ekg2 (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Dominik 'Rathann' Mierzejewski
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
:
Depends On:
Blocks: FTBFS
  Show dependency treegraph
 
Reported: 2008-06-02 18:04 EDT by FTBFS
Modified: 2008-07-12 09:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-12 09:39:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log.bz2 (4.49 KB, application/x-bzip2)
2008-06-02 18:05 EDT, FTBFS
no flags Details
build.log.bz2 (12.45 KB, application/x-bzip2)
2008-06-02 18:05 EDT, FTBFS
no flags Details
root.log.bz2 (25.99 KB, application/x-bzip2)
2008-06-02 18:05 EDT, FTBFS
no flags Details
build.log.bz2 (12.93 KB, application/x-bzip2)
2008-06-02 18:05 EDT, FTBFS
no flags Details

  None (edit)
Description FTBFS 2008-06-02 18:04:56 EDT
ekg2-0.2-0.1.rc1.fc10.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
Comment 1 FTBFS 2008-06-02 18:05:20 EDT
Created attachment 308070 [details]
root.log.bz2

root.log for i386
Comment 2 FTBFS 2008-06-02 18:05:32 EDT
Created attachment 308071 [details]
build.log.bz2

build.log for i386
Comment 3 FTBFS 2008-06-02 18:05:44 EDT
Created attachment 308072 [details]
root.log.bz2

root.log for x86_64
Comment 4 FTBFS 2008-06-02 18:05:52 EDT
Created attachment 308073 [details]
build.log.bz2

build.log for x86_64
Comment 5 Alex Lancaster 2008-07-11 07:55:26 EDT
Current rawhide ekg2-0.2-0.2.rc1.fc10 still doesn't build:

 gcc -DHAVE_CONFIG_H -I. -I../.. -DDATADIR=\"/usr/share/ekg2\"
-fvisibility=hidden -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include
-I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0
-I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/freetype2
-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m64 -mtune=generic -Wall -std=c99 -MT
gtk_la-maingui.lo -MD -MP -MF .deps/gtk_la-maingui.Tpo -c maingui.c  -fPIC -DPIC
-o .libs/gtk_la-maingui.o
In file included from maingui.c:77:
xtext.h:243: error: expected '=', ',', ';', 'asm' or '__attribute__' before
'gtk_xtext_get_type'
maingui.c:233:2:


see:

http://koji.fedoraproject.org/koji/taskinfo?taskID=709750

It's also causing broken deps in rawhide, due to the soname bump of gnutls:

Broken deps for i386
----------------------------------------------------------
	ekg2-jabber-0.2-0.1.rc1.fc10.i386 requires libgnutls.so.13(GNUTLS_1_3)
	ekg2-jabber-0.2-0.1.rc1.fc10.i386 requires libgnutls.so.13
Comment 6 Dominik 'Rathann' Mierzejewski 2008-07-12 09:39:13 EDT
Fixed.

http://koji.fedoraproject.org/koji/buildinfo?buildID=55802

Note You need to log in before you can comment on or make changes to this bug.