This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 449653 - FTBFS LabPlot-1.5.1.6-6.fc9
FTBFS LabPlot-1.5.1.6-6.fc9
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: LabPlot (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Chitlesh GOORAH
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
:
Depends On: 449910
Blocks: FTBFS
  Show dependency treegraph
 
Reported: 2008-06-02 18:18 EDT by FTBFS
Modified: 2008-06-10 16:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-10 16:28:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log.bz2 (5.46 KB, application/x-bzip2)
2008-06-02 18:18 EDT, FTBFS
no flags Details
build.log.bz2 (15.03 KB, application/x-bzip2)
2008-06-02 18:18 EDT, FTBFS
no flags Details
root.log.bz2 (34.53 KB, application/x-bzip2)
2008-06-02 18:19 EDT, FTBFS
no flags Details
build.log.bz2 (16.05 KB, application/x-bzip2)
2008-06-02 18:19 EDT, FTBFS
no flags Details

  None (edit)
Description FTBFS 2008-06-02 18:18:29 EDT
LabPlot-1.5.1.6-6.fc9.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
Comment 1 FTBFS 2008-06-02 18:18:50 EDT
Created attachment 308117 [details]
root.log.bz2

root.log for i386
Comment 2 FTBFS 2008-06-02 18:18:59 EDT
Created attachment 308118 [details]
build.log.bz2

build.log for i386
Comment 3 FTBFS 2008-06-02 18:19:12 EDT
Created attachment 308119 [details]
root.log.bz2

root.log for x86_64
Comment 4 FTBFS 2008-06-02 18:19:23 EDT
Created attachment 308120 [details]
build.log.bz2

build.log for x86_64
Comment 5 Alex Lancaster 2008-06-04 06:30:42 EDT
There's a newer LabPlot of 1.6.0 in CVS of rawhide.   

Trying to build now, as this is causing broken deps in rawhide for a week or so
and no recent maintainer activity.
Comment 6 Alex Lancaster 2008-06-04 08:21:52 EDT
Actually reverted back to the same spec/version on F-9 which has gcc4.3 fixes. 
This needs to be fixed now because of the ImageMagick soname bump, once this is
build, can work on updating the gcc 4.3 patch to the 1.6.0 version of lab plot.

Meantime even the 1.5.1.6 plot is failing due to problems with the current
coreutils on koji (bug #449910):

http://koji.fedoraproject.org/koji/getfile?taskID=645053&name=build.log

hopefully this will be fixed soon then rebuild can proceed.
Comment 7 Alex Lancaster 2008-06-06 06:01:44 EDT
Hmm, even with koji fixed now, this still fails to build for some other reason:

http://koji.fedoraproject.org/koji/taskinfo?taskID=646759

this is the bit that fails to compile:

/usr/include/liborigin/OPJFile.h:671: warning: conversion to 'int' from 'size_t'
may alter its value
ImportOPJ.cc: In member function 'int ImportOPJ::import()':
ImportOPJ.cc:40: error: 'class OPJFile' has no member named 'Data'
ImportOPJ.cc:49: error: 'class OPJFile' has no member named 'SData'
/usr/lib64/qt-3.3/include/qmemarray.h: In constructor
'QMemArray<type>::QMemArray(int) [with type = QPoint]':
/usr/lib64/qt-3.3/include/qpointarray.h:59:   instantiated from here
/usr/lib64/qt-3.3/include/qmemarray.h:62: warning: conversion to 'int' from
'long unsigned int' may alter its value
/usr/lib64/qt-3.3/include/qmemarray.h: In member function 'bool
QMemArray<type>::resize(uint) [with type = unsigned int]':
/usr/lib64/qt-3.3/include/qglcolormap.h:83:   instantiated from here
/usr/lib64/qt-3.3/include/qmemarray.h:73: warning: conversion to 'uint' from
'long unsigned int' may alter its value
make[2]: *** [ImportOPJ.lo] Error 1
make[2]: Leaving directory `/builddir/build/BUILD/LabPlot-1.5.1.6/src'
make[1]: 
*** [all-recursive] Error 1
Comment 8 Thibault North 2008-06-06 08:19:05 EDT
This error comes from changes in liborigin, which has changed a lot with the
last versions.
Maybe LabPlot should use a more recent one. That should be discussed upstream.
Comment 9 Alex Lancaster 2008-06-06 08:42:06 EDT
(In reply to comment #8)
> This error comes from changes in liborigin, which has changed a lot with the
> last versions.
> Maybe LabPlot should use a more recent one. That should be discussed upstream.

There is a new version of LabPlot out: 1.6.0.  However, I didn't upgrade to it
because it might have required porting the GCC 4.3 patch (assuming LabPlot 1.6.0
hasn't incorporated fixes for GCC 4.3).

Can you try compiling LabPlot 1.6.0 on rawhide?
Comment 10 Chitlesh GOORAH 2008-06-09 15:14:55 EDT
I'm working on it. This bug will be closed shortly along with the next release
1.6.0.1.
Comment 11 Alex Lancaster 2008-06-10 06:13:05 EDT
(In reply to comment #10)
> I'm working on it. This bug will be closed shortly along with the next release
> 1.6.0.1.

Thanks!  Any idea for the timeline for 1.6.0.1?  Packages that still FTBFS may
be removed from rawhide after Alpha is released.
Comment 12 Chitlesh GOORAH 2008-06-10 07:58:53 EDT
Tonight, or most probably before friday.

Note You need to log in before you can comment on or make changes to this bug.