Bug 449669 - Invalid glib2 headers cause compile errors
Invalid glib2 headers cause compile errors
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xscorch (Show other bugs)
10
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Marcin Garski
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
:
: 449651 465107 (view as bug list)
Depends On:
Blocks: 449651
  Show dependency treegraph
 
Reported: 2008-06-02 18:55 EDT by Marcin Garski
Modified: 2009-05-26 19:06 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.2.1-0.2.pre1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-26 19:06:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcin Garski 2008-06-02 18:55:46 EDT
Description of problem:
During rawhide rebuild xscorch fail to compile because of bad headers from
glib2-devel pacckage.

Version-Release number of selected component (if applicable):
glib2-devel-2.17.0-1.fc10.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Rebuild xscorch with installed glib2-devel-2.17.0-1.fc10.x86_64

Additional info:
Look at URL for rebuild log.
Comment 1 Matthias Clasen 2008-06-02 20:02:13 EDT
The problem is actually in the xscorch headers, in libj/libj.h


/* unused is a special attribute indicating a function argument is ignored
   within the function; this is useful for functions which MUST accept an
   argument because they escape, but do not actually access the argument. */
#ifndef unused 
#if __GNUC__ && LIBJ_C99_STANDARD
#define  unused                  __attribute__((unused))
#else /* Not C99 code */
#define  unused
#endif /* LIBJ_C99_STANDARD? */  
#endif /* unused undefined? */


doing that is obviously not a good idea. Removing this define makes the errors
in the glib headers go away. Of course, it then fails later on where the xscorch
sources use 'unused'...
Comment 2 Matt Domsch 2008-07-03 13:44:33 EDT
*** Bug 449651 has been marked as a duplicate of this bug. ***
Comment 3 Marcin Garski 2008-10-18 07:51:11 EDT
*** Bug 465107 has been marked as a duplicate of this bug. ***
Comment 4 Bug Zapper 2008-11-25 21:22:24 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Marcin Garski 2009-05-26 19:06:29 EDT
Fixed by updating to 0.2.1-pre1.

Note You need to log in before you can comment on or make changes to this bug.