Bug 449729 - Squid does not request user to authenticate
Squid does not request user to authenticate
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: squid (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Jiri Skala
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-03 03:46 EDT by Marek Greško
Modified: 2014-11-09 17:31 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-04 11:39:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Greško 2008-06-03 03:46:52 EDT
Description of problem:
When squid is configured to require authentication, it does not make browser to
prompt user for password. Probably it does not send some authentication header.
If you use client which forces authentication, it works.

Version-Release number of selected component (if applicable):
squid-3.0.STABLE2-3.fc9

How reproducible:
Always.

Steps to Reproduce:
1. Configure squid to require authentication.
2. Run www browser.
3. Try to browse on the web.
  
Actual results:
Proxy denies access.

Expected results:
Proxy requests client to authenticate.

Additional info:
Comment 1 Martin Nagy 2008-06-03 04:27:32 EDT
This looks like a duplicate of Bug #448342 which already has packages built and
waiting for enough karma to be pushed to stable, you can participate yourself if
this build fixes this for you:
https://admin.fedoraproject.org/updates/F9/FEDORA-2008-4500
Comment 3 Marek Greško 2008-06-20 09:29:55 EDT
I tried the above patch. It did not fix the problem.
Comment 4 Marek Greško 2008-07-04 10:13:46 EDT
Problem persists in squid-3.0.STABLE7-1.fc9. Tested with sasl_auth and ldap_auth.
Comment 5 Marek Greško 2008-07-04 11:39:18 EDT
I found the squid 3.0 does not allow proxy authentication when http_port is
setup to transparent. Request were not transparent, but in that case it is
needed to setup different port for transparent usage.

Note You need to log in before you can comment on or make changes to this bug.