Bug 449777 - /usr/bin/logger cannot be used when /usr is non-root partition
/usr/bin/logger cannot be used when /usr is non-root partition
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: util-linux (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Karel Zak
Ben Levenson
:
: 461266 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-03 10:41 EDT by Craig Magina
Modified: 2009-06-20 00:10 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.13-0.49.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 15:45:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Craig Magina 2008-06-03 10:41:40 EDT
Description of problem:
If the /usr partition is a separate partition from / then it cannot be used to
replace initlog in any init scripts that run before /usr gets mounted.

Version-Release number of selected component (if applicable):
util-linux-2.13-0.47.el5

How reproducible:
With the below setup, every time.

Steps to Reproduce:
1. Have /usr as a separate partition and use logger in an /etc/sysconfig/modules
script.
2.
3.
  
Actual results:
logger: command not found

Expected results:
The message gets logged out to the syslog.

Additional info:
Comment 1 Robert N. Evans 2008-06-13 09:54:09 EDT
This problem occurs when it is necessary to log a message from an init script. 
In RHEL4 we used initlog for this purpose.  However in RHEL5 the following
message prints out:
 WARNING: initlog is deprecated and will be removed in a future release

We take the deprecation seriously and attempted to be proactive about not using
initlog.  However due to this bug we do not have a good alternative to the
deprecated utility.
Comment 2 RHEL Product and Program Management 2008-07-22 05:40:14 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Jay Turner 2008-09-05 16:15:08 EDT
Just a note.  This fix is busted as it relocates logger from /usr/bin to /bin.  This will cause problems for anyone that is calling logger via absolute path, including the redhat-lsb package.  See bug 461266.
Comment 6 Karel Zak 2008-09-06 06:20:48 EDT
*** Bug 461266 has been marked as a duplicate of this bug. ***
Comment 7 Karel Zak 2008-09-06 06:22:25 EDT
(In reply to comment #5)
> Just a note.  This fix is busted as it relocates logger from /usr/bin to /bin. 
> This will cause problems for anyone that is calling logger via absolute path,
> including the redhat-lsb package.  See bug 461266. 

 Fixed. Errata updated. Thanks.
Comment 8 Jay Turner 2008-09-08 10:15:01 EDT
The /usr/bin/logger symlink fix is confirmed with 2.13-0.49.el5.
Comment 11 errata-xmlrpc 2009-01-20 15:45:33 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0070.html

Note You need to log in before you can comment on or make changes to this bug.