Bug 449808 - upgrade to 2.12
upgrade to 2.12
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gtk-sharp2 (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Xavier Lamien
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 471836
  Show dependency treegraph
 
Reported: 2008-06-03 14:10 EDT by Martin Jürgens
Modified: 2008-12-02 20:21 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-02 20:21:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Jürgens 2008-06-03 14:10:46 EDT
Description of problem:
The new F-Spot (0.4.4) has a dependency on gtk-sharp2 2.12. Would it be possible
to push it as an update to Fedora 9? Or is this a non-brainer?

Sorry for using bugzilla for this, did not find any bug contact..
Comment 1 Xavier Lamien 2008-06-03 16:35:44 EDT
sure.
devel branch is already up-to-date against gtk-sharp2.
Comment 2 Martin Jürgens 2008-06-03 17:27:16 EDT
what about having it in fedora 9 as an update? is it possible?
Comment 3 Vladimir Giszpenc 2008-06-27 10:29:54 EDT
I have a dependency on gtk-sharp-2 >= 2.10
The way the Fedora gtk-sharp-2 package is build, the things it provides are ONLY
2.12 or ONLY 2.10.

Is there any way you can define the support for other possibilities.  If you
look at the suse package for the same thing (gtk-sharp2), it provides 2.10, 2.8,
2.6 and 2.4.

Thanks,

Vlad

:> rpm -qp --provides gtk-sharp2-2.12.0-2.fc10.i386.rpm
libatksharpglue-2.so  
libgdksharpglue-2.so  
libgladesharpglue-2.so  
libglibsharpglue-2.so  
libgtksharpglue-2.so  
libpangosharpglue-2.so  
mono(atk-sharp) = 2.12.0.0
mono(gdk-sharp) = 2.12.0.0
mono(glade-sharp) = 2.12.0.0
mono(glib-sharp) = 2.12.0.0
mono(gtk-dotnet) = 2.12.0.0
mono(gtk-sharp) = 2.12.0.0
mono(pango-sharp) = 2.12.0.0
mono(policy.2.10.atk-sharp) = 0.0.0.0
mono(policy.2.10.gdk-sharp) = 0.0.0.0
mono(policy.2.10.glade-sharp) = 0.0.0.0
mono(policy.2.10.glib-sharp) = 0.0.0.0
mono(policy.2.10.gtk-dotnet) = 0.0.0.0
mono(policy.2.10.gtk-sharp) = 0.0.0.0
mono(policy.2.10.pango-sharp) = 0.0.0.0
mono(policy.2.4.atk-sharp) = 0.0.0.0
mono(policy.2.4.gdk-sharp) = 0.0.0.0
mono(policy.2.4.glade-sharp) = 0.0.0.0
mono(policy.2.4.glib-sharp) = 0.0.0.0
mono(policy.2.4.gtk-dotnet) = 0.0.0.0
mono(policy.2.4.gtk-sharp) = 0.0.0.0
mono(policy.2.4.pango-sharp) = 0.0.0.0
mono(policy.2.6.atk-sharp) = 0.0.0.0
mono(policy.2.6.gdk-sharp) = 0.0.0.0
mono(policy.2.6.glade-sharp) = 0.0.0.0
mono(policy.2.6.glib-sharp) = 0.0.0.0
mono(policy.2.6.gtk-dotnet) = 0.0.0.0
mono(policy.2.6.gtk-sharp) = 0.0.0.0
mono(policy.2.6.pango-sharp) = 0.0.0.0
mono(policy.2.8.atk-sharp) = 0.0.0.0
mono(policy.2.8.gdk-sharp) = 0.0.0.0
mono(policy.2.8.glade-sharp) = 0.0.0.0
mono(policy.2.8.glib-sharp) = 0.0.0.0
mono(policy.2.8.gtk-dotnet) = 0.0.0.0
mono(policy.2.8.gtk-sharp) = 0.0.0.0
mono(policy.2.8.pango-sharp) = 0.0.0.0
gtk-sharp2 = 2.12.0-2.fc10

;> rpm -qp --provides gtk-sharp2-2.12.0-0.suse103.novell.i586.rpm
libatksharpglue-2.so  
libgdksharpglue-2.so  
libgtksharpglue-2.so  
libpangosharpglue-2.so  
mono(atk-sharp) = 2.10.0.0
mono(atk-sharp) = 2.12.0.0
mono(atk-sharp) = 2.4.0.0
mono(atk-sharp) = 2.6.0.0
mono(atk-sharp) = 2.8.0.0
mono(gdk-sharp) = 2.10.0.0
mono(gdk-sharp) = 2.12.0.0
mono(gdk-sharp) = 2.4.0.0
mono(gdk-sharp) = 2.6.0.0
mono(gdk-sharp) = 2.8.0.0
mono(gtk-dotnet) = 2.10.0.0
mono(gtk-dotnet) = 2.12.0.0
mono(gtk-dotnet) = 2.4.0.0
mono(gtk-dotnet) = 2.6.0.0
mono(gtk-dotnet) = 2.8.0.0
mono(gtk-sharp) = 2.10.0.0
mono(gtk-sharp) = 2.12.0.0
mono(gtk-sharp) = 2.4.0.0
mono(gtk-sharp) = 2.6.0.0
mono(gtk-sharp) = 2.8.0.0
mono(pango-sharp) = 2.10.0.0
mono(pango-sharp) = 2.12.0.0
mono(pango-sharp) = 2.4.0.0
mono(pango-sharp) = 2.6.0.0
mono(pango-sharp) = 2.8.0.0
gtk-sharp2 = 2.12.0-0.suse103.novell
]2;bf@mono:...t/public/Armadillo]1;monobf@mono:/mnt/public/Armadillo> exit

Script done on Fri Jun 27 09:11:39 2008
Comment 4 Alex Lancaster 2008-11-17 01:49:10 EST
The dist-f9-override tagging of the new gtk-sharp2 has the unintended consequence of making gecko-sharp2 uninstallable and therefore prevents a rebuild of blam agains the new xulrunner, see: bug #471836.    I have requested that rel-eng remove the override: https://fedorahosted.org/rel-eng/ticket/1064 to allow the blam update to be built.

Then somebody should rebuild gecko-sharp2 against this new gtk-sharp2 2.12 and test the whole stack before pushing it to updates.
Comment 5 Fedora Update System 2008-12-02 20:21:07 EST
themonospot-0.7.1.1-1.fc9.1, muine-scrobbler-0.1.8-6.fc9, monotorrent-0.4-2.fc9.1, monosim-1.3.0.2-1.fc9.1, monodoc-1.9-2.fc9, monodevelop-1.0-7.fc9, mono-tools-1.9-5.fc9, lat-1.2.3-3.fc9.1, incollector-1.0-6.fc9.1, gbrainy-1.00-2.fc9.1, cowbell-0.3-0.svn34.4.2.fc9.1, cdcollect-0.6.0-5.fc9.1, bless-0.6.0-1.fc9.1, blam-1.8.5-3.fc9.1, gmime-2.2.21-2.fc9, gsf-sharp-0.8.1-8.fc9, tomboy-0.10.1-2.fc9.1, f-spot-0.4.3.1-2.fc9, muine-0.8.8-10.fc9, gnome-do-0.4.2.0-2.fc9, avahi-0.6.22-11.fc9, mono-addins-0.3.1-3.fc9, banshee-1.2.1-2.fc9.1, gnome-subtitles-0.8-3.fc9, evolution-sharp-0.16.1.1-2.fc9, gtksourceview-sharp-2.0.12-1.fc9, ipod-sharp-0.8.0-5.fc9, gnome-sharp-2.16.1-3.fc9, gecko-sharp2-0.12-7.fc9.1, beagle-0.3.8-6.fc9, gtk-sharp2-2.12.1-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.