Bug 471836 - Failed dependency for blam
Failed dependency for blam
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: blam (Show other bugs)
9
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Alex Lancaster
Fedora Extras Quality Assurance
:
Depends On: 449808 468055
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-16 23:10 EST by Bhupesh K. Pranami
Modified: 2008-12-02 20:21 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-02 20:21:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bhupesh K. Pranami 2008-11-16 23:10:43 EST
Description of problem:
Failed dependency in mozilla firefox update to version 3.0.4

Version-Release number of selected component (if applicable):
3.0.4

How reproducible:
update system

Actual results:

gecko-libs = 1.9.0.2 is needed by package blam-1.8.5-2.fc9.i386

Expected results:


Additional info:
Got failed dependency while updating API document viewer (devhelp-0.19.1-6.fc9), Firefox (firefox-3.0.4-1.fc9), Development files for gecko (xulrunner-devel-1.9.0.4-1.fc9), XUL runtime for gecko applications (xulrunner-1.9.0.4-1.fc9), A system documentation reader from the gnome project(yelp-2.22.1-5.fc9).
All from updates-newkey repository.
Failed to resolve gecko-libs = 1.9.0.2 for blam-1.8.5-2.fc9.i386
blam-1.8.5-2.fc9.i386 needs to be updated to use newer gecko-libs package.
Comment 1 Alex Lancaster 2008-11-17 01:35:07 EST
The problem is that blam won't rebuild against gecko-sharp2:

https://koji.fedoraproject.org/koji/getfile?taskID=935763&name=root.log

because of broken deps in F-9:

DEBUG util.py:250:  0:perl-XML-Parser-2.36-3.fc9.x86_64
DEBUG util.py:250:  0:mono-devel-1.9.1-2.fc9.x86_64
DEBUG util.py:250:  0:gnome-sharp-devel-2.16.1-2.fc9.x86_64
DEBUG util.py:250:  0:gecko-sharp2-devel-0.12-7.fc9.x86_64
DEBUG util.py:250:  0:gettext-0.17-4.fc9.x86_64
DEBUG util.py:250:  0:xulrunner-devel-unstable-1.9.0.4-1.fc9.x86_64
DEBUG util.py:250:  0:dbus-sharp-devel-0.63-9.fc9.x86_64
DEBUG util.py:250:  0:gtk-sharp2-devel-2.12.1-1.fc9.x86_64
DEBUG util.py:250:  0:intltool-0.37.1-1.fc9.x86_64
DEBUG util.py:250:  0:libgnomeui-devel-2.22.1-3.fc9.x86_64
DEBUG util.py:250:  0:desktop-file-utils-0.15-1.fc9.x86_64
DEBUG util.py:250:  0:gtk-sharp2-gapi-2.12.1-1.fc9.x86_64

[....]

DEBUG util.py:250:  Error: Missing Dependency: mono(gtk-sharp) = 2.10.0.0 is needed by package gecko-sharp2
DEBUG util.py:250:  Error: Missing Dependency: mono(glib-sharp) = 2.10.0.0 is needed by package gecko-sharp2

This is a bit of mess actually and it took me a while to figure it out.  It appears that gtk-sharp2 was rebuilt and has been tagged as a buildroot override:

https://koji.fedoraproject.org/koji/buildinfo?buildID=63643

but that means gecko-sharp2 (a BuildRequires for blam) in the buildroot won't install because it was built against the old version of gtk-sharp2.  

I think what needs to happen is that either the new gtk-sharp2 be pushed to updates, or the buildroot tagging needs to be undone.
Comment 2 Alex Lancaster 2008-11-17 01:43:26 EST
I think the most minimal change would be to remove the dist-f9-override tag from gtk-sharp2, so I requested rel-eng to do it here: https://fedorahosted.org/rel-eng/ticket/1064
Comment 3 Mamoru TASAKA 2008-11-17 10:00:26 EST
This issue is now being tracked on bug 468055.

Sadly, at least one package which are pushed against newer gtk-sharp2 are
pushed into stable on F-9, so we cannot revert to old gtk-sharp2 anymore.
Comment 4 Bhupesh K. Pranami 2008-11-17 18:23:35 EST
The issue has been resolved and I can update all the packages. If the rel-eng has overrode tag as suggested by alex, this might be the solution for the bug.
Comment 5 Alex Lancaster 2008-11-18 19:30:47 EST
(In reply to comment #4)
> The issue has been resolved and I can update all the packages. If the rel-eng
> has overrode tag as suggested by alex, this might be the solution for the bug.

I can't see any pending update for blam in bodhi, has an update been prepared for all the affected packages?  If so, could you provide a link to the bodhi update and please add this bug number, so it is closed automatically when pushed to stable?  Thanks.
Comment 7 Fedora Update System 2008-11-26 21:10:40 EST
themonospot-0.7.1.1-1.fc9.1, muine-scrobbler-0.1.8-6.fc9, monotorrent-0.4-2.fc9.1, monosim-1.3.0.2-1.fc9.1, monodoc-1.9-2.fc9, monodevelop-1.0-7.fc9, mono-tools-1.9-5.fc9, lat-1.2.3-3.fc9.1, incollector-1.0-6.fc9.1, gbrainy-1.00-2.fc9.1, cowbell-0.3-0.svn34.4.2.fc9.1, cdcollect-0.6.0-5.fc9.1, bless-0.6.0-1.fc9.1, blam-1.8.5-3.fc9.1, gmime-2.2.21-2.fc9, gsf-sharp-0.8.1-8.fc9, tomboy-0.10.1-2.fc9.1, f-spot-0.4.3.1-2.fc9, muine-0.8.8-10.fc9, gnome-do-0.4.2.0-2.fc9, avahi-0.6.22-11.fc9, mono-addins-0.3.1-3.fc9, banshee-1.2.1-2.fc9.1, gnome-subtitles-0.8-3.fc9, evolution-sharp-0.16.1.1-2.fc9, gtksourceview-sharp-2.0.12-1.fc9, ipod-sharp-0.8.0-5.fc9, gnome-sharp-2.16.1-3.fc9, gecko-sharp2-0.12-7.fc9.1, beagle-0.3.8-6.fc9, gtk-sharp2-2.12.1-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update themonospot muine-scrobbler monotorrent monosim monodoc monodevelop mono-tools lat incollector gbrainy cowbell cdcollect bless blam gmime gsf-sharp tomboy f-spot muine gnome-do avahi mono-addins banshee gnome-subtitles evolution-sharp gtksourceview-sharp ipod-sharp gnome-sharp gecko-sharp2 beagle gtk-sharp2'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-10455
Comment 8 Fedora Update System 2008-12-02 20:21:05 EST
themonospot-0.7.1.1-1.fc9.1, muine-scrobbler-0.1.8-6.fc9, monotorrent-0.4-2.fc9.1, monosim-1.3.0.2-1.fc9.1, monodoc-1.9-2.fc9, monodevelop-1.0-7.fc9, mono-tools-1.9-5.fc9, lat-1.2.3-3.fc9.1, incollector-1.0-6.fc9.1, gbrainy-1.00-2.fc9.1, cowbell-0.3-0.svn34.4.2.fc9.1, cdcollect-0.6.0-5.fc9.1, bless-0.6.0-1.fc9.1, blam-1.8.5-3.fc9.1, gmime-2.2.21-2.fc9, gsf-sharp-0.8.1-8.fc9, tomboy-0.10.1-2.fc9.1, f-spot-0.4.3.1-2.fc9, muine-0.8.8-10.fc9, gnome-do-0.4.2.0-2.fc9, avahi-0.6.22-11.fc9, mono-addins-0.3.1-3.fc9, banshee-1.2.1-2.fc9.1, gnome-subtitles-0.8-3.fc9, evolution-sharp-0.16.1.1-2.fc9, gtksourceview-sharp-2.0.12-1.fc9, ipod-sharp-0.8.0-5.fc9, gnome-sharp-2.16.1-3.fc9, gecko-sharp2-0.12-7.fc9.1, beagle-0.3.8-6.fc9, gtk-sharp2-2.12.1-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.