Bug 449887 - cvsweb does not work on fc9
cvsweb does not work on fc9
Status: CLOSED DUPLICATE of bug 447371
Product: Fedora
Classification: Fedora
Component: cvsweb (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Marek Mahut
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-04 01:44 EDT by pbartfai
Modified: 2008-06-21 14:16 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-21 14:16:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pbartfai 2008-06-04 01:44:40 EDT
cvsweb-3.0.6-3.fc6.noarch is installed from repository Everything. It does not 
work with SELinux. When I disabled SELinux it start working: the list of 
repositories generated. When click to a directory I get error message:

Error
Error: Failed to spawn GNU rlog 
on "/var/cvs/CVSROOT/config,v, /var/cvs/CVSROOT/commitinfo,v, /var/cvs/CVSROOT/t
aginfo,v, /var/cvs/CVSROOT/checkoutlist,v, /var/cvs/CVSROOT/notify,v, /var/cvs/C
VSROOT/editinfo,v, /var/cvs/CVSROOT/verifymsg,v, /var/cvs/CVSROOT/rcsinfo,v, /va
r/cvs/CVSROOT/cvsignore,v, /var/cvs/CVSROOT/loginfo,v, /var/cvs/CVSROOT/cvswrapp
ers,v, /var/cvs/CVSROOT/modules,v".

Did you set the @command_path in your configuration file correctly? 
(Currently: "/bin:/usr/bin").

I use the default cvsweb.conf file, command_path set correctly. The same 
package worked with Fedora 8.

I copied /var/www/cgi-bin/cvsweb.cgi to /var/www/perl and enabled mod_perl the 
starting page of cvsweb worked fine but when I clicked to a subdirectory I got 
blank page.
Comment 1 Lubomir Rintel 2008-06-21 14:16:58 EDT
Thanks for the report. The problem is due to bug #447371
The SELinux issue is tracked by bug #452384

*** This bug has been marked as a duplicate of 447371 ***

Note You need to log in before you can comment on or make changes to this bug.