This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 449950 - can't create bridge with bonded interface attached
can't create bridge with bonded interface attached
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
: 456861 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-04 09:31 EDT by David Juran
Modified: 2014-03-16 23:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-23 15:11:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for /etc/sysconfif/network-scripts/ifup-eth (2.03 KB, patch)
2008-06-04 09:31 EDT, David Juran
no flags Details | Diff

  None (edit)
Description David Juran 2008-06-04 09:31:39 EDT
Description of problem:
If an interface belongs to a bridge ifup will try to add it to the bridge
_before_ it checks if the interface is a bond (and takes the apropriate steps to
bring the bond up). So adding the interface to the bridge will fail.

Version-Release number of selected component (if applicable):
initscripts-8.76.2-1.x86_64

How reproducible:
Every time

Steps to Reproduce:

[root@red network-scripts]# cat ifcfg-eth0 
DEVICE=eth0
HWADDR=00:17:08:4c:7e:e2
ONBOOT=yes
NM_CONTROLLED=no
MASTER=bond0
SLAVE=yes

[root@red network-scripts]# cat ifcfg-eth1 
DEVICE=eth1
HWADDR=00:17:08:4c:7e:e1
ONBOOT=yes
NM_CONTROLLED=no
MASTER=bond0
SLAVE=yes

[root@red network-scripts]# cat ifcfg-bond0 
DEVICE=bond0
TYPE=bonding
BRIDGE=br0
ONBOOT=yes

[root@red network-scripts]# cat ifcfg-br0 
DEVICE=br0
BOOTPROTO=static
IPADDR=10.9.224.200
NETMASK=255.255.240.0
TYPE=bridge
ONBOOT=yes

service network start

Actual results:
can't add bond0 to bridge br0: Invalid argument

Expected results:
bond0 up and connected to br0

Additional info:
Bringing the bond up before adding it to the bridge seems to solve the problem.
Patch for /etc/sysconfig/network-scripts/ifup-eth attached.

The problem also exists in RHEL.
Comment 1 David Juran 2008-06-04 09:31:39 EDT
Created attachment 308341 [details]
patch for /etc/sysconfif/network-scripts/ifup-eth
Comment 2 Bill Nottingham 2008-09-23 15:06:28 EDT
*** Bug 456861 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.