Bug 449959 - java fails on sun java test app
java fails on sun java test app
Status: CLOSED DUPLICATE of bug 304021
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
9
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Lillian Angel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-04 10:12 EDT by David L.
Modified: 2008-06-19 11:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-19 11:16:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
java source for test app that fails (8.98 KB, application/x-compressed-tar)
2008-06-18 16:22 EDT, David L.
no flags Details

  None (edit)
Description David L. 2008-06-04 10:12:46 EDT
Description of problem: java fails on the test app at: 
www.java.com/en/download/installed.jsp


Version-Release number of selected component (if applicable):


How reproducible:
Every time.

Steps to Reproduce:
1. Go to www.java.com/en/download/installed.jsp
2. Attempt to verify jre installation
3.
  
Actual results:
Grey box instead of image that they say should appear.

Expected results:
dancing Duke logo
Comment 1 Lillian Angel 2008-06-04 10:25:23 EDT
Looks like there is a bug, I am getting this error:
java.lang.NumberFormatException: For input string: " "
       at
java.lang.NumberFormatException.forInputString(NumberFormatException.java:65)
       at java.lang.Integer.parseInt(Integer.java:470)
       at java.lang.Integer.<init>(Integer.java:636)
       at testvmDynamicJavaCom.init(testvmDynamicJavaCom.java:195)
       at sun.applet.AppletPanel.run(AppletPanel.java:436)
       at java.lang.Thread.run(Thread.java:636)

Hard to track down because we dont have the source for the applet. 
Comment 2 David L. 2008-06-04 12:48:32 EDT
java doesn't work with glance either (www.glance.net).  It says java isn't
installed even though it is when trying to connect as a client to someone's
glance session.  It also doesn't work with most applets at my company... I'll
try to see if I can get the source for them.
Comment 3 Lillian Angel 2008-06-04 16:11:56 EDT
If you can at least track down where the problem is happening within the code or
provide a stacktrace, it would be helpful.

Running the applet in firefox from command-line should give you a stacktrace.

"firefox -g http://applet..."
Comment 4 David L. 2008-06-04 23:31:43 EDT
Here is some of the output when I ran firefox -g with
one of the applets that works in Windows with the latest
java release but doesn't work in f9 with openjdk:

Exception in thread "main" java.lang.NullPointerException
	at sun.applet.PluginMain.start(PluginMain.java:211)
	at sun.applet.PluginMain.main(PluginMain.java:73)
GCJ PLUGIN: thread 0x933aff8: plugin_out_pipe_callback
GCJ PLUGIN: thread 0x933aff8: plugin_out_pipe_callback: appletviewer has stopped.
GCJ PLUGIN: thread 0x933aff8: plugin_out_pipe_callback return
GCJ PLUGIN: thread 0x933aff8: plugin_in_pipe_callback
GCJ PLUGIN: thread 0x933aff8: appletviewer has stopped.
GCJ PLUGIN: thread 0x933aff8: plugin_in_pipe_callback return
[Thread 0xb69feb90 (LWP 32713) exited]
[New Thread 0xb69feb90 (LWP 32744)]
(no debugging symbols found)
(no debugging symbols found)
[Thread 0xb69feb90 (LWP 32744) exited]
Comment 5 Lillian Angel 2008-06-05 10:12:43 EDT
This is a different problem from the sun applet

Failing here:

 else if (message.startsWith("width")) {
                int width =
                Integer.parseInt(message.substring("width".length() + 1));
Line 211: -->   int height = currentWindow.getHeight();
                currentWindow.updateAtts(width, height);
                currentWindow.setSize(width, height);
}


I am looking into it, thanks
Comment 6 David 2008-06-05 15:29:51 EDT
want me to file a second or third bug report for this problem plus the glance
problem?  I am a good java tester because I haven't gotten it to work a single
time.  ;)
Comment 7 Lillian Angel 2008-06-05 15:35:47 EDT
No, this is fine. It is still difficult for me to track down why this is
happening without the source, or at least being able to run the applet. If you
can find a similar applet, that I can run- then I can debug it. 

Unfortunately, the problem with the Sun applet lies within their code. Is there
an applet that fails similar to the glance one? or is there a way I can easily
reproduce this with glance?
Comment 8 Mark Wielaard 2008-06-10 06:18:21 EDT
With regard to the testvmDynamicJavaCom failure it seems this applet is wrong
(not having the source makes that slightly difficult to interpret). It seems to
try to get the system property "java.version" and then tries to find an
underscore "_" in it. But icedtea/openjdk doesn't have an underscore in their
version, it is just plain 1.6.0.
Comment 9 Mark Wielaard 2008-06-10 06:29:05 EDT
For the height/width failure also see ubuntu's bug tracker:
https://bugs.launchpad.net/ubuntu/+source/icedtea-gcjwebplugin/+bug/199732
Comment 10 Lillian Angel 2008-06-11 12:33:11 EDT
mjw: you are right, it has to do with the "_". I committed a fix to the repo for
this. It will be in the next release soon.

As for the NullPointerException, this is still not fixed.
Comment 11 David L. 2008-06-18 16:22:57 EDT
Created attachment 309788 [details]
java source for test app that fails

I had a colleague strip down one of his proprietary java apps that fails to a
small test app and attached a tar archive of it.
Comment 12 Lillian Angel 2008-06-19 11:12:06 EDT
Thank you for this test case. I will look into it asap.
Comment 13 Lillian Angel 2008-06-19 11:16:46 EDT
Ah, this applet uses javascript. Javascript support still has not been implemented.

*** This bug has been marked as a duplicate of 304021 ***

Note You need to log in before you can comment on or make changes to this bug.