Bug 449996 - libvirt clobbers manual changes to /etc/sysconfig/iptables
libvirt clobbers manual changes to /etc/sysconfig/iptables
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
9
All Linux
high Severity low
: ---
: ---
Assigned To: Mark McLoughlin
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-04 13:01 EDT by David Lutterkort
Modified: 2013-04-30 19:40 EDT (History)
3 users (show)

See Also:
Fixed In Version: libvirt-0.4.2-4.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-04 13:56:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Lutterkort 2008-06-04 13:01:05 EDT
Description of problem:

Because of its use of lokkit to change iptables configuration, libvirt clobbers
manual changes to /etc/sysconfig/iptables; this is particularly bad, since it
will clobber those changes even if lokkit/system-config-firewall have never been
used on the system.

Version-Release number of selected component (if applicable):

libvirt-0.4.2-3.fc9

The libvirt/lokkit integration issue is tracked as
https://bugzilla.redhat.com/show_bug.cgi?id=227011
Comment 1 Mark McLoughlin 2008-06-04 13:26:52 EDT
bug #443796 is where we originally enabled lokkit support

The issue is:

  - libvirt makes sure its iptables rules aren't lost when changes are made
    using s-c-fw, or when iptables is restarted, by using 
    lokkit --with-custom-rules

  - unfortunately (and this is what was unforseen), lokkit will clobber any
    manual changes a user has made to /etc/sysconfig/iptables

  - usually these manual changes would only be clobbered if the user used
    s-c-fw (or similar), but now they are clobber merely by installing libvirt

  - the original iptables patch proposed in bug #227011 wouldn't have had this
    problem

Clearly this is a regression - users who had manually set up iptables rules will
get their working setup busted by installing libvirt.

I'm going to go ahead and push an F-9 and rawhide update removing lokkit support.
Comment 2 Mark McLoughlin 2008-06-04 13:32:44 EDT
See also #447633 - lokkit support wasn't working with selinux enabled
Comment 3 Mark McLoughlin 2008-06-04 13:56:21 EDT
Fixed with:

* Wed Jun  4 2008 Mark McLoughlin <markmc@redhat.com> - 0.4.2-4.fc9
- Disable lokkit support again (#449996, #447633)
- Ensure PolicyKit is enabled (#446616)
Comment 4 Thomas Woerner 2008-06-04 14:08:30 EDT
Use "lokkit --disabled" and lokkit will not touch the firewall configuration
files anymore. This is and was the way lokkit behaves since some years.
Comment 5 Fedora Update System 2008-06-04 17:00:59 EDT
libvirt-0.4.2-4.fc9 has been submitted as an update for Fedora 9

Note You need to log in before you can comment on or make changes to this bug.