Bug 45011 - /sbin/setsysfont forces 43 line console to 25 lines
/sbin/setsysfont forces 43 line console to 25 lines
Status: CLOSED DUPLICATE of bug 26901
Product: Red Hat Linux
Classification: Retired
Component: console-tools (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-19 12:37 EDT by Robin Whittle
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-19 12:37:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Whittle 2001-06-19 12:37:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (Windows NT 5.0; U)

Description of problem:
During boot-up, if lilo's vga=8, then the text console is as it should be: 132x43.  At a certain point, the characters become larger 
and the lines reduce to 25 or so.  This happened with two separate systems, with both S3 and Trident PCI cards.

Commenting out the "# Load system font" section of /etc/rc.d/rc.sysinit solves the problem.  

After booting successfully with this commented out, simply running "setsysfont" changes the console to 25 lines again.

How reproducible:
Always

Steps to Reproduce:
1. Set "vga=8" (or whatever) in /etc/lilo.conf, run lilo and reboot.  Note it starts with 43 lines and goes to 25 lines at a certain point 
during boot up. 
2. Comment out the "# Load system font" section of /etc/rc.d/rc.sysinit and reboot.  Problem does not occur.
3.
	

Additional info:
Comment 1 Bill Nottingham 2001-06-19 16:04:03 EDT

*** This bug has been marked as a duplicate of 26901 ***

Note You need to log in before you can comment on or make changes to this bug.