Bug 450116 - [Enhancement Request] NetworkManager should not report the user is offline, unless the user really is offline
[Enhancement Request] NetworkManager should not report the user is offline, u...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-05 09:39 EDT by Bill C. Riemers
Modified: 2008-07-03 08:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-02 22:01:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill C. Riemers 2008-06-05 09:39:41 EDT
Description of problem:

Since NetworkManager is really intended for Wifi and VPN connections that may
only be available sometimes, it should not rely on a managed connection being
online to report the user is online.

Take for example someone with a VPN connection configured with NetworkManager,
and wired connections configured via the classical network interface.  Then even
if VPN is offline, the user can still be online. 

Properly, the NetworkManager should attempt to connect the name server, or some
other external service to verify the user really is offline.

Why you ask would someone want to use NetworkManager for only some connections?
  1. NetworkManager is enabled by default in Fedora 9.  Many users, even if they
     aren't using it, are not aware it is reporting bogus offline information
     unless they disable it.
  2. Bugs #450088 , #439103 , and #433968 limit the usefulness of NetworkManager
     for wired connections.
  3. If the user may already have networking setup the way they like it and not
     want to migrate existing connections to NetworkManager.
  4. The user may be using a network device not supported by NetworkManager.


Version-Release number of selected component (if applicable):


How reproducible:

100%


Steps to Reproduce:
1. Configure eth0 in /etc/sysconfig/network-scripts.
2. Run "ifup eth0".

  
Actual results:

NetworkManager will still report it is offline to firefox 3, packagekit, and
any other application which checks status with NetworkManager.

Expected results:

If I can connect to a non-local DNS server, or say the Fedora update mirror list
I am online.

Additional info:
Comment 1 Dan Williams 2008-06-05 10:57:06 EDT
NM will report that the user is offline if NM does not control the user's
primary network device.  If you have told NM to ignore the primary network
device by marking it as NM_CONTROLLED=no (either through system-config-network
or by adding that option to the ifcfg file) then NetworkManager cannot determine
the state of that device, precisely because you've told NM to ignore that
device.  Either let NM control the primary device, or turn NM off with chkconfig.
Comment 2 Bill C. Riemers 2008-06-05 11:06:04 EDT
NM should be able to run without controlling all devices.
Comment 3 Bill C. Riemers 2008-06-05 11:08:21 EDT
I consider this a bug, because NM is reporting false information.  But if it
makes you feel better, consider it an enhancement request.  If you wish I can
submit a patch.
Comment 4 Dan Williams 2008-07-02 22:01:41 EDT
If there's a connection metohd that NetworkManager does not support, we add
support to NetworkManager to control that connection method.  We don't hack
around it by adding _partial_ support for noticing that some interface is up and
maybe grabbing the IP address or routes off that interface when we can't even
control it.  It needs to get done the _right_ way, not in a compatibility hack.
 If NetworkManager is not able to control the primary network interface of the
machine, then NM should not be enabled on that machine.

Note You need to log in before you can comment on or make changes to this bug.