Bug 450191 - DMA mode disabled for DVD drive, reverts to PIO4
DMA mode disabled for DVD drive, reverts to PIO4
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Alan Cox
Fedora Extras Quality Assurance
: Reopened
: 450225 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-05 15:36 EDT by James
Modified: 2008-06-12 22:27 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.6.25.6-55.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-12 22:27:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output with the problem (25.08 KB, text/plain)
2008-06-05 15:36 EDT, James
no flags Details

  None (edit)
Description James 2008-06-05 15:36:05 EDT
Description of problem:
The kernel is disabling DMA for the DVD drive on my HP zx5030EA (ATI IXP-based)
notebook, making transfers very slow. I've never seen this problem in previous
releases of Fedora.

Version-Release number of selected component (if applicable):
kernel-2.6.25.4-29.fc9.i686

How reproducible:
Always.

Steps to Reproduce:
1. Boot.

Actual results:
The following is seen in dmesg:

ata1: PATA max UDMA/100 cmd 0x1f0 ctl 0x3f6 bmdma 0x8060 irq 14
ata2: PATA max UDMA/100 cmd 0x170 ctl 0x376 bmdma 0x8068 irq 15
ata1.00: ATA-6: IC25N060ATMR04-0, MO3OAD0A, max UDMA/100
ata1.00: 117210240 sectors, multi 16: LBA48 
ata1.00: configured for UDMA/100
ata2.00: ATAPI: HL-DT-STCD-RW/DVD DRIVE GCC-4241N, 0C29, max MWDMA2
ata2.00: simplex DMA is claimed by other device, disabling DMA
ata2.00: configured for PIO4

Very slow DVD drive.

Expected results:
Multi-word DMA available for the DVD drive.
Comment 1 James 2008-06-05 15:36:05 EDT
Created attachment 308479 [details]
dmesg output with the problem
Comment 2 Alan Cox 2008-06-05 16:48:41 EDT
Fixed upstream already.
Comment 3 James 2008-06-05 17:23:04 EDT
Any idea when the fix will filter its way down into F9/what should I look out
for on Koji?
Comment 4 Dave Jones 2008-06-05 17:27:25 EDT
alan, do you have the git hash or a pointer to the patch? we can throw this into
f9 as an update until .26 lands.
Comment 5 Chuck Ebbert 2008-06-05 20:28:55 EDT
Fixed in 2.6.25.4-44
Comment 6 Alan Cox 2008-06-06 05:11:49 EDT
(The real fix is mostly not to load pata_acpi in the wrong order)
Comment 7 Chuck Ebbert 2008-06-06 05:40:51 EDT
*** Bug 450225 has been marked as a duplicate of this bug. ***
Comment 8 Solomon Peachy 2008-06-07 08:40:41 EDT
Glad to hear a fix is in and will filter down the intertubes soon-ish. 
Meanwhile, Blacklisting pata_acpi seems to have done the trick for my laptop.
Comment 9 James 2008-06-07 13:38:25 EDT
Confirmed fixed in kernel-2.6.25.5-49.fc9, closing.
Comment 10 Chuck Ebbert 2008-06-09 23:15:22 EDT
Bug will be closed automatically when a new kernel gets released.
Comment 11 Fedora Update System 2008-06-11 21:38:36 EDT
kernel-2.6.25.6-55.fc9 has been submitted as an update for Fedora 9
Comment 12 Fedora Update System 2008-06-12 22:26:55 EDT
kernel-2.6.25.6-55.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.