Bug 450321 - OpenChrome, Rdesktop, and Editable screen causes Fedora to Crash.
OpenChrome, Rdesktop, and Editable screen causes Fedora to Crash.
Status: CLOSED DUPLICATE of bug 446489
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-openchrome (Show other bugs)
9
i386 Linux
low Severity low
: ---
: ---
Assigned To: Xavier Bachelot
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-06 13:14 EDT by Brianna
Modified: 2008-12-29 15:55 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-29 15:55:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brianna 2008-06-06 13:14:15 EDT
Description of problem:
Upgraded Fedora 8 to 9 via DVD with no problems. After the upgrade when I
rdesktop (rdesktop -f xxx.xx.xxx.xx) to any of my Windows 2003 Terminal Servers
and open any screen that is ready to edit text (etc: notepad, Word) it causes
the F9 box to hang.  Unfortunately when it hangs it does not log anything, but
through lots of trial and error I was able to narrow it down to the f9
OpenChrome drivers (currently trying the updates-testing version:
xorg-x11-drv-openchrome.i386 0:0.2.902-6.fc9 but it still exhibits the same
issues).  
If I "downgrade" to the standard VESA driver I am able to use rdesktop normally. 

One interesting thing is that it only dies if I open an editable screen.  For
example Word immediately crashes it however Excel does not unless I click in a cell.


Version-Release number of selected component (if applicable):
kernel:  2.6.25.3-18.fc9.i686
xorg-x11-drv-openchrome.i386 0:0.2.902-6.fc9 (Also have the -devel packages)

How reproducible:
Every Time

Steps to Reproduce:
1. Boot to Fedora 9 - Gnome
2. rdesktop -f xxx.xx.xxx.xx
3. Open any editable screen (MS Word) in the rdesktop session
4. Dies
  
Actual results:
Computer Hangs/Freezes

Expected results:
Being able to continue working

Additional info:
Smolt ID: pub_ac2e6c32-cf6c-469b-8346-00fbed762eec
Comment 1 Brianna 2008-06-06 13:20:51 EDT
Guess I should have included this:
rdesktop-1.6.0-1.fc9.i386

For what its worth: When I was running the same computer under F8 (with the
OpenChrome drivers) it worked just fine.
Comment 2 Xavier Bachelot 2008-06-08 19:02:37 EDT
can you get a backtrace from gdb, please ?
Comment 3 Brianna 2008-06-09 07:41:27 EDT
I installed the rdesktop-debuginfo & ran a bt on it.  Please let me know if you
are looking for something else (its my first time playing with gdb)

(gdb) bt
#0  0x00110416 in __kernel_vsyscall ()
#1  0x00ac56ad in ___newselect_nocancel () from /lib/libc.so.6
#2  0x08058c39 in ?? ()
#3  0x080608bf in ?? ()
#4  0x08060e88 in ?? ()
#5  0x08060ff8 in ?? ()
#6  0x080617c3 in ?? ()
#7  0x08061ffb in ?? ()
#8  0x08063b73 in ?? ()
#9  0x08064a89 in ?? ()
#10 0x0806559c in ?? ()
#11 0x0804db92 in ?? ()
#12 0x00a055d6 in __libc_start_main () from /lib/libc.so.6
#13 0x0804ba11 in ?? ()


-Brianna
Comment 4 Xavier Bachelot 2008-06-09 08:19:46 EDT
you're missing a lot of -debuginfo packages, at least you need
xorg-x11-drv-openchrome-debuginfo. gdb probably ask for a list of debuginfo
packages when it starts. Don't attach gdb to rdesktop, but rather to X.
Comment 5 Brianna 2008-06-09 13:09:55 EDT
Here is the "correct" backtrace :)

(gdb) cont
Continuing.
^C
Program received signal SIGINT, Interrupt.
(gdb) bt
#0  0x002328fd in viaFlushPCI ()
   from /usr/lib/xorg/modules/drivers//openchrome_drv.so
#1  0x00232af4 in ?? () from /usr/lib/xorg/modules/drivers//openchrome_drv.so
#2  0x0030031b in XAAWritePixmap (pScrn=0x9f9dc00, x=43, y=213, w=13, h=13,
    src=0xa5b59ec "", srcwidth=128, rop=7, planemask=4294967295, trans=-1,
    bpp=32, depth=24) at xaaImage.c:239
#3  0x002ef898 in XAADoImageWrite (pSrc=0xa5b59a0, pDst=0xa477b00,
    pGC=0xa478008, prgnDst=0xbf8797c0, pptSrc=0xa895628) at xaaCpyArea.c:218
#4  0x002eef32 in XAABitBlt (pSrcDrawable=0xa5b59a0, pDstDrawable=0xa477b00,
    pGC=0xa478008, srcx=7, srcy=0, width=13, height=13, dstx=38, dsty=195,
    doBitBlt=0x2ef760 <XAADoImageWrite>, bitPlane=0) at xaaBitBlt.c:203
#5  0x002f010a in XAACopyArea (pSrcDrawable=0xa5b59a0, pDstDrawable=0xa477b00,
    pGC=0xa478008, srcx=7, srcy=0, width=13, height=13, dstx=38, dsty=195)
    at xaaCpyArea.c:55
#6  0x003363da in cwCopyArea (pSrc=0xa5b59a0, pDst=0xa477b00, pGC=0xa478008,
    srcx=7, srcy=0, w=13, h=13, dstx=38, dsty=195) at cw_ops.c:201
#7  0x0817841b in damageCopyArea (pSrc=0xa5b59a0, pDst=0xa477b00,
    pGC=0xa478008, srcx=7, srcy=0, width=13, height=13, dstx=38, dsty=195)
    at damage.c:830
#8  0x08083d19 in ProcCopyArea (client=0xa199918) at dispatch.c:1581
#9  0x08085a3f in Dispatch () at dispatch.c:454
#10 0x0806b3bd in main (argc=4, argv=0xbf879a84, envp=Cannot access memory at
address 0xb7f73408
) at main.c:441
(gdb) 
Comment 6 Brianna 2008-06-10 07:48:51 EDT
Updated this morning to the openchrome driver 0.2.902-7.fc9 from the fedora
repos and still have the same problem.

-Brianna
Comment 7 Xavier Bachelot 2008-06-10 11:00:41 EDT
(In reply to comment #6)
> Updated this morning to the openchrome driver 0.2.902-7.fc9 from the fedora
> repos and still have the same problem.
> 
This update was not supposed to fix this bug.
Comment 8 Brianna 2008-06-12 14:31:34 EDT
I assumed as much but I wanted to make sure :)

-Brianna
Comment 9 Xavier Bachelot 2008-10-16 15:14:33 EDT
Can you please try adding the following line in the Device section of your xorg conf and see if it helps ?
Option "XaaNoImageWriteRect"
Comment 10 Brianna 2008-10-17 07:13:02 EDT
Wow!  That seems to have fixed it.  I'll do some more testing but I was able to actually open a word document and type without it crashing on me!
(btw... what does XaaNoImageWriteRect actually do?)

Thanks!!!
Comment 11 Xavier Bachelot 2008-12-29 15:55:41 EST

*** This bug has been marked as a duplicate of bug 446489 ***

Note You need to log in before you can comment on or make changes to this bug.