Bug 446489 - X hangs on Fedora 9 when driver set to openchrome
X hangs on Fedora 9 when driver set to openchrome
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-openchrome (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Xavier Bachelot
Fedora Extras Quality Assurance
:
: 450321 465199 469346 472420 473117 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-14 16:16 EDT by Peter Veres
Modified: 2009-10-22 08:56 EDT (History)
14 users (show)

See Also:
Fixed In Version: 0.2.903-5.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-09 19:05:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg Log (52.41 KB, text/plain)
2008-05-14 16:16 EDT, Peter Veres
no flags Details
xorg log with openchrome (64.50 KB, text/plain)
2008-05-14 16:17 EDT, Peter Veres
no flags Details
Log do X com drives open e vesa (12.74 KB, application/x-gzip)
2008-05-25 10:44 EDT, Ivan Paes José
no flags Details
Xorg.log XAA lockup (154.26 KB, text/plain)
2008-05-26 18:01 EDT, Vesa Ruokonen
no flags Details
Xorg.0.log showing crash inside Xorg with openchrome which hoses machine (50.00 KB, text/plain)
2009-01-05 23:31 EST, Jonathan Kamens
no flags Details

  None (edit)
Description Peter Veres 2008-05-14 16:16:28 EDT
Description of problem:
X hangs after startup when driver in xorg.conf set to "openchrome". Same with 
Anaconda installer, system stops respoding just after showing title screen. 
When starting just xinit, systems stops responding just after moving mouse 
cursor. If replace "openchrome" with "vesa", everything works fine.

Version-Release number of selected component (if applicable):

Steps to Reproduce:
1. set driver to openchrome, or just start graphical intaller
2. wait until X starts
3.X fails
Comment 1 Peter Veres 2008-05-14 16:16:28 EDT
Created attachment 305398 [details]
Xorg Log
Comment 2 Peter Veres 2008-05-14 16:17:11 EDT
Created attachment 305399 [details]
xorg log with openchrome
Comment 3 Kazutoshi Morioka 2008-05-15 04:12:14 EDT
I had same problem. My smolt profile is here:
http://www.smolts.org/client/show/pub_920668d9-1de6-4d85-92d6-e84d3dd246a1
This is i386 arch only.
Fedora 9 x86_64 arch works fine on the same PC.
Comment 4 Xavier Bachelot 2008-05-15 05:08:10 EDT
(In reply to comment #0)
ok, I'll try to port a fix from another branch of openchrome in the next days in
order to get rid off of the VBE calls, it might fix the pb. This is rather
heavy, so please give me a little time.
Comment 5 Xavier Bachelot 2008-05-15 05:11:10 EDT
(In reply to comment #3)
> I had same problem. My smolt profile is here:
> http://www.smolts.org/client/show/pub_920668d9-1de6-4d85-92d6-e84d3dd246a1
> This is i386 arch only.
> Fedora 9 x86_64 arch works fine on the same PC.

Not sure this is the same problem, could you please post your xorg log and conf ?
Comment 6 Ivan Paes José 2008-05-20 22:14:49 EDT
Dear,

I let the story that I am having the same problem that the friend Peter Veres
posted.
To start the installation in the anaconda recognizes the drive to start ox lock
the PC.
After installing text mode and modify the drive to vesa ok, no problem.
We already have some track or forecast?

Regards,

José Ivan Paes

 
Scholar of Librarianship - UFSC
Technician in Telecommunications

E-mail/MSN: paes.jose @ gmail.com
Skype: ivanpaesjose
Palhoça - Santa Catarina - Brazil

"... Criticism is easier to praise ..."

"A bit of science in turn from God. Very, brings us closer."
                                   Louis Pasteur.

NOTE: Sorry English is that was translated from Portuguese into English.
Comment 7 Xavier Bachelot 2008-05-24 11:19:50 EDT
(In reply to comment #6)
> After installing text mode and modify the drive to vesa ok, no problem.

What happens if you set the driver to openchrome ? Can you please post the xorg
log with openchrome ?
Comment 8 Peter Veres 2008-05-24 13:54:01 EDT
(In reply to comment #7)
> (In reply to comment #6)
> > After installing text mode and modify the drive to vesa ok, no problem.
> 
> What happens if you set the driver to openchrome ? Can you please post the 
xorg
> log with openchrome ?

The openchrome driver is the problem... If i set X to use the openchrome, X 
hangs just after start. I mean, it shows the background and then stop 
responding. In anaconda it shows Installer's title screen with Fedora title 
screwed up at the top of screen, that's all. Using vesa i was able at least use 
system "normally" - slow as hell but it did work, openchrome doesn't work at 
all. 

And sorry, no, i can't post  the xorg log because I had to reinstall back to 
Fedora 8 as Fedora 9 wasn't useable to me. Not only X with openchrome, but 
neither video playing(slow and noting did help), touchpad not working(click by 
tap - no chance to enable it, tried to set manually in xorg.conf, tried updated 
driver, nothing worked). And that new final released KDE4 isn't final for me, 
rather alpha or something a bit more.

I can't imagine new release of Fedora when xorg.conf will be disabled at all 
and only autodetection will work - as it seems it won't work.
Comment 9 Ivan Paes José 2008-05-25 10:44:14 EDT
Created attachment 306618 [details]
Log do X com drives open e vesa

When you select the drive openchrome is exactly what the friend Peter Veres
commented on post 8. Then the log of X, where X Xorg.0.log_vesa and with the
vesa driver and Xorg.0.log_open with the drive openchrome. I hope I have
helped.

Instaldos versions of software:

Kernel: 2.6.25.3-18.fc9.i686
xorg-x11-drv-openchrome-0.2.902-3.fc9.i386

Regards,

Ivan Paes
Comment 10 Vesa Ruokonen 2008-05-26 18:01:55 EDT
Created attachment 306710 [details]
Xorg.log XAA lockup

Here is hard lockup from 0.2.902-3.fc9. 
No lockups when EXA acceleration is activated or NoAccel "true".
Comment 11 Xavier Bachelot 2008-05-26 19:02:32 EDT
xorg-x11-drv-openchrome-0.2.902-5.fc9 might work better for you. Available from
Koji before it hits updates-testing. 
http://koji.fedoraproject.org/koji/taskinfo?taskID=629814
Comment 12 Jonathan Kamens 2008-05-26 23:42:23 EDT
I just installed xorg-x11-drv-openchrome-0.2.902-5.fc9.i386 and rebooted, and my
X server locks up when it starts.  When I kill the X server, my whole system
hangs (hard lock-up, magic SysRq key doesn't work).

I was also seeing hangs with the old openchrome driver, but not when the server
started up -- it hung when I tried to use rdesktop.

It does not appear that 0.2.902-5.fc9 fixes the problem.
Comment 13 Ivan Paes José 2008-05-27 00:05:16 EDT
	
Hello!

Once the tests installing the packages:

[root @ netuno paes] # rpm -aq | grep openchrome
xorg-x11-drv-openchrome-0.2.902-5.fc9.i386
xorg-x11-drv-openchrome-devel-0.2.902-5.fc9.i386
[root @ netuno paes] #

In my case to install this package holding went further, or to the setar drive
openchrome and make the restart of X is shown in animation cusor mouse and
tinker with it for a moment (+ - 2 seconds), the screen fund default and when
appear to the login screen with the users of the system is that all white screen
and lock the PC.
In the previous package could not move the mouse at any time and did not appear
any image sharp.

Regards,

Ivan Paes
Comment 14 Xavier Bachelot 2008-05-27 16:37:26 EDT
Does adding the following line to the Device section of the xorg.conf fix the
issue for everyone ?

Option "AccelMethod" "EXA"

If not, does Option "NoAccel" fix the issue ?
Comment 15 Ivan Paes José 2008-05-27 18:19:32 EDT
(In reply to comment #14)
> Does adding the following line to the Device section of the xorg.conf fix the
> issue for everyone ?
> 
> Option "AccelMethod" "EXA"
> 
> If not, does Option "NoAccel" fix the issue ?

	
Hello,

Xavier I did not understand exactly where they need to put that line. You can
put xorg.conf an example of where that line would be bold?

Thank you!

Ivan Paes
Comment 16 Xavier Bachelot 2008-05-27 18:39:01 EDT
(In reply to comment #15)
The Device section of your xorg.conf should look to something like that :
Section "Device"
        Identifier  "Videocard0"
        Driver      "openchrome"
        Option      "AccelMethod"  "EXA"
EndSection

if it still doesn't work, try with :
Section "Device"
        Identifier  "Videocard0"
        Driver      "openchrome"
        Option      "NoAccel"
EndSection
Comment 17 Ivan Paes José 2008-05-27 18:55:00 EDT
(In reply to comment #16)
> (In reply to comment #15)
> The Device section of your xorg.conf should look to something like that :
> Section "Device"
>         Identifier  "Videocard0"
>         Driver      "openchrome"
>         Option      "AccelMethod"  "EXA"
> EndSection
> 
> if it still doesn't work, try with :
> Section "Device"
>         Identifier  "Videocard0"
>         Driver      "openchrome"
>         Option      "NoAccel"
> EndSection

	
Ok,

When I am at work. Once we arrive at home I will make the tests and post the
results.

Thank you!
Comment 18 Emmanuel Seyman 2008-05-27 19:33:19 EDT
(In reply to comment #14)
> Does adding the following line to the Device section of the xorg.conf fix the
> issue for everyone ?
> 
> Option "AccelMethod" "EXA"

This works for me.

Comment 19 Ivan Paes José 2008-05-27 21:36:44 EDT
	
Hello,

After putting the line Option "AccelMethod" "EXA" and restarted the X interface
was ok, but the xorg is occupying much processing reaches peak of 90% leaving
the PC very slow.

  PID USER PR NI VIRT RES SHR S% CPU% MEM TIME + COMMAND
  2141 root 20 0 98516 21m 8168 S 48.6 4.9 0:53.09 Xorg

Correcting this problem of occupation of CPU is ok.

Thank you!

Ivan Paes
Comment 20 Diego Búrigo Zacarão 2008-05-28 08:41:29 EDT
I'm using:

Option    "NoAccel"   "True"

So, X starts to work with openchrome driver, but it still a bit slow, mainly
when you moving a window or scroll down/up a web page on firefox.

The option "AccelMethod" "EXA" doesn't change anything.

If I comment the "NoAccel" option I get the X instance very very slow and the
Xorg.0.log shows:

"[mi] EQ overflowing. The server is probably stuck in an infinite loop.
 [mi] mieqEnequeue: out-of-order valuator event; dropping."

Comment 21 Jonathan Kamens 2008-05-28 10:53:36 EDT
Extremely erratic behavior.  Sometimes the driver works with no options; 
sometimes it hangs.  Sometimes it works with EXA; sometimes it hangs.  
Sometimes it works with NoAccel; sometimes it hangs.  Sometimes when I kill the 
X server, my machine recovers; sometimes my machine locks up.  After the most 
recent lock-up and reboot, I was able to run the driver with no options, with 
EXA, and with NoAccel repeatedly with no hangs, despite the fact that it had 
just been hanging a few moments before.

I don't know what's up with all this, but clearly stability has not yet been 
achieved.
Comment 22 Diego Búrigo Zacarão 2008-06-11 10:34:00 EDT
Any news?
Comment 23 Xavier Bachelot 2008-06-11 11:10:42 EDT
(In reply to comment #19)
> After putting the line Option "AccelMethod" "EXA" and restarted the X interface
> was ok, but the xorg is occupying much processing reaches peak of 90% leaving
> the PC very slow.
> 
Ivan, try to add :
Option "MigrationHeuristic"  "greedy"

(In reply to comment #21)
> Extremely erratic behavior.  Sometimes the driver works with no options; 
> sometimes it hangs.  Sometimes it works with EXA; sometimes it hangs.  
> Sometimes it works with NoAccel; sometimes it hangs.  Sometimes when I kill the 
> X server, my machine recovers; sometimes my machine locks up.  After the most 
> recent lock-up and reboot, I was able to run the driver with no options, with 
> EXA, and with NoAccel repeatedly with no hangs, despite the fact that it had 
> just been hanging a few moments before.
> 
Jonathan, I'm not convinced all your troubles are related to openchrome. Is your
machine perfectly stable when using the vesa driver ? 

(In reply to comment #22)
> Any news?

Diego, I believe there are multiple problems mixed here. One problem is XAA
acceleration is broken for some people and switching to EXA mitigate the issue.
In your case, you have to completely disable the acceleration to get the driver
running. Unfortunately, you didn't provide neither your xorg conf nor your xorg
log, so I'm afraid there's not much I can do to diagnose or even categorise the
problem.


All, I'm still awaiting for upstream to provide a patch that will remove the
need of the VGA bios to do the modesetting, as I failed to produce it by myself.
This should greatly reduce the pain some laptop users are suffering with openchrome.
Comment 24 Jonathan Kamens 2008-06-11 11:15:27 EDT
"Is your machine perfectly stable when using the vesa driver ?"

Yes.
Comment 25 Ivan Paes José 2008-06-14 00:39:15 EDT
(In reply to comment #23)
> (In reply to comment #19)
> > After putting the line Option "AccelMethod" "EXA" and restarted the X interface
> > was ok, but the xorg is occupying much processing reaches peak of 90% leaving
> > the PC very slow.
> > 
> Ivan, try to add :
> Option "MigrationHeuristic"  "greedy"
> 
> (In reply to comment #21)
> > Extremely erratic behavior.  Sometimes the driver works with no options; 
> > sometimes it hangs.  Sometimes it works with EXA; sometimes it hangs.  
> > Sometimes it works with NoAccel; sometimes it hangs.  Sometimes when I kill the 
> > X server, my machine recovers; sometimes my machine locks up.  After the most 
> > recent lock-up and reboot, I was able to run the driver with no options, with 
> > EXA, and with NoAccel repeatedly with no hangs, despite the fact that it had 
> > just been hanging a few moments before.
> > 
> Jonathan, I'm not convinced all your troubles are related to openchrome. Is your
> machine perfectly stable when using the vesa driver ? 
> 
> (In reply to comment #22)
> > Any news?
> 
> Diego, I believe there are multiple problems mixed here. One problem is XAA
> acceleration is broken for some people and switching to EXA mitigate the issue.
> In your case, you have to completely disable the acceleration to get the driver
> running. Unfortunately, you didn't provide neither your xorg conf nor your xorg
> log, so I'm afraid there's not much I can do to diagnose or even categorise the
> problem.
> 
> 
> All, I'm still awaiting for upstream to provide a patch that will remove the
> need of the VGA bios to do the modesetting, as I failed to produce it by myself.
> This should greatly reduce the pain some laptop users are suffering with
openchrome.


	
Hello,

Once the test by placing putting Option "MigrationHeuristic" "greedy" getting sa
follows:

1 st test:

Section "Device"
         Identifier "Videocard0"
         Driver "openchrome"
         Option "NoAccel"
         Option "MigrationHeuristic" "greedy"
EndSection

NOTE: The X rises but remains very slow. The simple task of maximizing and
discard maximize the xorg occupies 94% of the CPU.


2 nd test

Section "Device"
         Identifier "Videocard0"
         Driver "openchrome"
         Option "AccelMethod" "EXA"
         Option "MigrationHeuristic" "greedy"
EndSection

NOTE: Not rises X on television reports that connection with X server fi and
lost in the last lines of / var/log/Xorg.0.log.old shows the following:

Backtrace:
0: X (xf86SigHandler +0 x79) [0x80d60c9]
1: [0x12e400]
2: / lib/libc.so.6 (memcpy +0 x46) [0x471f46]
3: [0xb425d000]
4: / usr / lib / xorg / modules / / libexa.so [0x7a5334]
5: / usr / lib / xorg / modules / / libexa.so (exaComposite +0 xc0f) [0x7a602f]
6: X [0x8175f76]
7: X (CompositePicture +0 x1c6) [0x815fc86]
8: X [0x810d7ff]
9: X [0x811f1e5]
10: X (miPointerUpdateSprite +0 x229) [0x8118aa9]
11: X [0x8118ba5]
12: X [0x8147e7d]
13: X [0x81691b1]
14: X [0x808cfb3]
15: X (ChangeWindowAttributes +0 xcc0) [0x8073730]
16: X (ProcChangeWindowAttributes +0 xc0) [0x8085550]
17: X (Dispatch +0 x34f) [0x8085a3f]
18: X (main +0 x47d) [0x806b3bd]
19: / lib/libc.so.6 (__libc_start_main +0 xe6) [0x4115d6]
20: X (FontFileCompleteXLFD +0 x22d) [0x806a7a1]

Server Fatal error:
Caught signal 11. Server aborting

(II) UnloadModule: "mouse"
(II) UnloadModule: "kbd"
(II) Macintosh mouse button emulation: Close
(II) UnloadModule: "evdev"
(II) UnloadModule: "synaptics"
(II) HID 062nd: 0001: Close
(II) UnloadModule: "evdev"
(II) CHROME (0): VIALeaveVT
(II) CHROME (0): ViaCursorStore
(II) CHROME (0): VIARestore
(II) CHROME (0): ViaLCDPower: On.
(II) CHROME (0): ViaDisablePrimaryFIFO


3 of test


Section "Device"
         Identifier "Videocard0"
         Driver "openchrome"
         Option "NoAccel" "True"
         Option "MigrationHeuristic" "greedy"
EndSection

NOTE: The X rises but remains very slow. The simple task of maximizing and
discard maximize the xorg occupies 94% of the CPU.


Packages installed on the machine:

[breads netuno @ ~] $ rpm-q | grep openchrome
xorg-x11-drv-openchrome-0.2.902-7.fc9.i386
[breads netuno @ ~] $ rpm-q | grep kernel
kernel-2.6.25.6-55.fc9.i686
[breads netuno @ ~] $

Regards,

Ivan Paes
Comment 26 Xavier Bachelot 2008-06-14 08:03:40 EDT
The MigratioHeuristic option only matters if you are using EXA. man openchrome
for details.
About the crash, try to add :
Option "ExaNoComposite"
in the Device section of xorg.conf.
Comment 27 Vesa Ruokonen 2008-06-14 08:05:25 EDT
Ivan's symptoms look familiar to me. Opencrome has worked here fine since I
switched to EXA with some extra parameters. No more crashes or cpu hogs.

Option "AccelMethod" "EXA"
Option "ExaNoComposite" "True"
Option "MigrationHeuristic" "greedy"
Option "ExaScratchSize" "8192"
Option "MaxDRIMem" "16384"

I believe some non-EXA problems are avoided with;
Option "SWCursor" "true"
Option "NoXVDMA" "true"

From some tests I also have still active this;
Section "Extensions"
        Option "Composite" "enable"
EndSection
Comment 28 Ivan Paes José 2008-06-14 14:29:41 EDT
(In reply to comment #27)
> Ivan's symptoms look familiar to me. Opencrome has worked here fine since I
> switched to EXA with some extra parameters. No more crashes or cpu hogs.
> 
> Option "AccelMethod" "EXA"
> Option "ExaNoComposite" "True"
> Option "MigrationHeuristic" "greedy"
> Option "ExaScratchSize" "8192"
> Option "MaxDRIMem" "16384"
> 
> I believe some non-EXA problems are avoided with;
> Option "SWCursor" "true"
> Option "NoXVDMA" "true"
> 
> From some tests I also have still active this;
> Section "Extensions"
>         Option "Composite" "enable"
> EndSection
> 

	
Hello,

With settings that Vesa Ruokonen returned and set the drive and restart the
openchrome X, xorg was ok, not giving the problem of high consumption of CPU. I
believe my problem was resolved.
So my xorg.conf was as follows:

Section "Device"
         Identifier "Videocard0"
         Driver "openchrome"
         Option "AccelMethod" "EXA"
         Option "ExaNoComposite" "True"
         Option "MigrationHeuristic" "greedy"
         Option "ExaScratchSize" "8192"
         Option "MaxDRIMem" "16384"
EndSection

Thanks to friends for help.

Regards,

Ivan Paes
Comment 29 Ivan Paes José 2008-06-16 18:59:56 EDT
Hello,

Only to appear, indicating that more staff utlizar managed to drive the openchrome.

Again Thank you!

Ivan Paes

"Thank you for the tip Paes, note 10!
until they finally managed to install the fedora on my note.
How can tell has not run desktop 3D, I am using KDE 4 and I'm amazed by it. "
Comment 30 Milan Kerslager 2008-06-27 10:01:17 EDT
The solution from comment #28 works for me. Without this, I've got serious
hangs. I have ASUS K8V-VM with onboard VGA:

01:00.0 VGA compatible controller: VIA Technologies, Inc. K8M890 [Chrome9]
Integrated Video (rev 11)

Numeric output: 01:00.0 0300: 1106:3230 (rev 11)

xorg-x11-drv-openchrome-0.2.902-7.fc9.i386
Comment 31 Srinivasa Sha S R 2008-07-29 00:15:03 EDT
I also tried comment #28. It stop hanging but system is very slow. So I returned
to VESA. Is there a more permanent solution.
Comment 32 Srinivasa Sha S R 2008-09-02 12:06:48 EDT
I added XaaNoImageWriteRect option to xorg.conf. now it is fine.

My xorg.conf is as follows:

Section "Device"
	Identifier  "Videocard0"
	Driver      "openchrome"
	Option	    "XaaNoImageWriteRect" "True"
EndSection
Comment 33 Srinivasa Sha S R 2008-12-19 08:40:52 EST
This bug continuous in fedora 10 also is there any progress in fixing this bug.
Comment 34 Xavier Bachelot 2008-12-19 17:07:51 EST
unfortunately, no real progress in fixing the bug. We tried to reproduce it on several hardware setup, but none of us succeed. I currently have both a KM400 and a VX800 running F10, but they are not impacted. I'll soon have a CLE266 under F10 too, but I don't expect it to be impacted either. What would help a lot would be to retrieve both the xorg log and the backtrace of a crash. If anyone CC'ed to this bug can get us that, it would be good.
Comment 35 Xavier Bachelot 2008-12-29 15:53:59 EST
*** Bug 473117 has been marked as a duplicate of this bug. ***
Comment 36 Xavier Bachelot 2008-12-29 15:54:21 EST
*** Bug 472420 has been marked as a duplicate of this bug. ***
Comment 37 Xavier Bachelot 2008-12-29 15:55:23 EST
*** Bug 465199 has been marked as a duplicate of this bug. ***
Comment 38 Xavier Bachelot 2008-12-29 15:55:41 EST
*** Bug 450321 has been marked as a duplicate of this bug. ***
Comment 39 Xavier Bachelot 2008-12-30 15:49:20 EST
*** Bug 469346 has been marked as a duplicate of this bug. ***
Comment 40 Fedora Update System 2008-12-30 16:35:16 EST
xorg-x11-drv-openchrome-0.2.903-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/xorg-x11-drv-openchrome-0.2.903-2.fc9
Comment 41 Fedora Update System 2008-12-30 16:35:24 EST
xorg-x11-drv-openchrome-0.2.903-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/xorg-x11-drv-openchrome-0.2.903-2.fc10
Comment 42 Fedora Update System 2009-01-05 19:21:44 EST
xorg-x11-drv-openchrome-0.2.903-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/xorg-x11-drv-openchrome-0.2.903-3.fc10
Comment 43 Jonathan Kamens 2009-01-05 23:31:04 EST
Created attachment 328249 [details]
Xorg.0.log showing crash inside Xorg with openchrome which hoses machine

xorg-x11-drv-openchrome-0.2.903-4.fc11.i386 continues to hang for me immediately and hose my system (stops pinging, although I am able to reboot with the Magic SysRq key) on a system updated today from rawhide.  I've got no xorg.conf, so I'm using whatever the auto-generated settings are.  I've tested it with three different kernels with the same results:

kernel-2.6.28-2.fc11.i686
kernel-2.6.29-0.7.rc0.git3.fc11.i686
kernel-2.6.29-0.9.rc0.git4.fc11.i686

I've attached my /var/log/Xorg.0.log, which shows a crash inside Xorg, from the hang.
Comment 44 Xavier Bachelot 2009-01-06 18:12:56 EST
(In reply to comment #43)
> Created an attachment (id=328249) [details]
> Xorg.0.log showing crash inside Xorg with openchrome which hoses machine
> 
This is a different bug that only happens with xserver 1.6. It's already been reported to xorg (https://bugs.freedesktop.org/show_bug.cgi?id=19337) and a patch against the deprecated via driver submitted (http://lists.freedesktop.org/archives/xorg/2008-December/041972.html).
Jon will have a patch for openchrome soon. Meanwhile can you please open a new bug ?
Comment 45 Fedora Update System 2009-01-07 04:32:38 EST
xorg-x11-drv-openchrome-0.2.903-3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xorg-x11-drv-openchrome'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-0210
Comment 46 Fedora Update System 2009-01-07 04:33:15 EST
xorg-x11-drv-openchrome-0.2.903-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update xorg-x11-drv-openchrome'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-0214
Comment 47 Fedora Update System 2009-01-07 04:37:20 EST
xorg-x11-drv-openchrome-0.2.903-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xorg-x11-drv-openchrome'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-0227
Comment 48 Fedora Update System 2009-02-24 15:54:16 EST
xorg-x11-drv-openchrome-0.2.903-5.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xorg-x11-drv-openchrome'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2009
Comment 49 Fedora Update System 2009-03-09 19:05:05 EDT
xorg-x11-drv-openchrome-0.2.903-5.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.