Bug 450343 - anaconda spends very long time in "Finishing upgrade process" with no user feedback
anaconda spends very long time in "Finishing upgrade process" with no user fe...
Status: CLOSED DUPLICATE of bug 208725
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-06 15:51 EDT by John Heidemann
Modified: 2008-07-15 16:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-15 16:59:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Heidemann 2008-06-06 15:51:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008043010 Fedora/3.0-0.60.beta5.fc9 Firefox/3.0b5

Description of problem:
In an upgrade from F8 to F9,
after upgrading >1000 packages with a nice install progress bar,
anaconda popup up a window that says "Finishing upgrade process.  This may take a while...".

This is the only feedback given for often 20 minutes (on reasonably fast hardware).
No feedback for 20 minutes makes users very antsy.

Suggestion: have a second status bar that shows progress.

(My guess is this phase is the equivalent of the "cleanup" part of yum update.  It really needs to show program-by-program status, just like for the install part.)

Version-Release number of selected component (if applicable):
(whatever shipped with F9)

How reproducible:
Always


Steps to Reproduce:
1. get an F8 system
2. boot the F9 installer and do "upgrade existing"
3. wait to get through packages upgraded with progress feedback
4. wait for "finishing upgrade process" without useful progress feedback.

Actual Results:
3. wait to get through packages upgraded with progress feedback
4. wait for "finishing upgrade process" without useful progress feedback.

Expected Results:
some kind of progress indication at step 4

Additional info:
Comment 1 Chris Lumens 2008-07-15 16:59:42 EDT

*** This bug has been marked as a duplicate of 208725 ***

Note You need to log in before you can comment on or make changes to this bug.