Bug 208725 - RFE: give visual feedback during long database update
RFE: give visual feedback during long database update
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
: FutureFeature
: 450343 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-30 18:34 EDT by John Reiser
Modified: 2010-11-04 21:56 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-16 15:32:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2006-09-30 18:34:13 EDT
Description of problem: Updating the rpm database at the end of Package Install
for an Upgrade takes a very long time, and there is no visual feedback that the
process is not hung or crashed.  For instance, when upgrading from FC5 to FC6Pre
on a PowerPC Apple Macintosh Mini (1.25GHz, 512MB RAM), the text mode install
screen had Package Install at 100% for over 15 minutes.  I though it was hung,
but using VT2 to do an strace of anaconda convinced me that it was making slow
progress updating the rpm database (at something like 1 package per second).


Version-Release number of selected component (if applicable):
anaconda-11.1.0.102-1

How reproducible:
[haven't tried]

Steps to Reproduce:
1. Use the rescue CD to upgrade from FC5 to FC6Pre.
2.
3.
  
Actual results:
Package Install apparently finishes (progress bar shows 100% after 2hr45min via
DSL for Basic + Software Development), then sits for over 15 minutes without
change or apparent progress, yet eventually completes.

Expected results:
Something that takes longer than 20 or 30 seconds should have a progress bar, as
an indication that progress is being made, and to allow the user to estimate
when it might complete.  In this case, there were about 900 packages, so a
progress bar of about 1/2 the screen width would have done nicely.

Additional info:
Comment 1 Red Hat Bugzilla 2007-08-21 01:27:15 EDT
User pnasrat@redhat.com's account has been closed
Comment 2 Jon Stanley 2008-04-23 16:28:47 EDT
Adding FutureFeature keyword to RFE's.
Comment 3 Chris Lumens 2008-07-15 16:59:43 EDT
*** Bug 450343 has been marked as a duplicate of this bug. ***
Comment 4 Chris Lumens 2008-07-16 13:37:55 EDT
This should be better in the next build of anaconda, though I haven't been able
to test it as thoroughly as I would like.
Comment 5 John Heidemann 2008-07-16 13:48:29 EDT
Wrt cornering the bug: I believe the long delay occurs only in upgrades, not in
fresh installs.
Comment 6 Kieran Clancy 2010-05-26 10:19:54 EDT
I am in the middle of an upgrade from F12 to F13 and the "Finishing upgrade process. This may take a little while." dialog has been showing for over an hour and counting, with no indication of actual progress (a bar flashing back and forwards only tells me that the install process hasn't locked up, but that's about all).

Surely this bug hasn't actually been fixed -- should it be reopened?
Comment 7 Chris Lumens 2010-05-26 10:25:46 EDT
bug 493249
Comment 8 Tony Foiani 2010-11-04 21:56:05 EDT
Still not fixed on F12 -> F14 "preupgrade".  This should be closed as a dupe of bug 493249, since that seems to have the most current traffic on it.

Note that there are quite a few bugs with this complaint, most closed as dupes of one or two core bugs:

bug 208725 (dups: bug 450343)
this bug [bug 452724] (dups: bug 474460, 
bug 493249 (dups: bug 532082, bug 597064

Note You need to log in before you can comment on or make changes to this bug.