This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 450364 - problems with rsync -X --link-dest
problems with rsync -X --link-dest
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rsync (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Simo Sorce
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-06 22:29 EDT by Bill C. Riemers
Modified: 2008-07-17 10:19 EDT (History)
0 users

See Also:
Fixed In Version: 3.0.3-0.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-17 10:19:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test case (7.93 KB, application/octet-stream)
2008-06-07 01:08 EDT, Bill C. Riemers
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Samba Project 5526 None None None Never

  None (edit)
Description Bill C. Riemers 2008-06-06 22:29:49 EDT
Description of problem:

I have a backup script I use to backup my file systems with incremental backups.
 The script works very well with Fedora 8, but it bombs completely with Fedora 9.

The errors from rsync are:

rsync: writefd_unbuffered failed to write 4 bytes [sender]: Broken pipe (32)
[receiver] internal abbrev error!
rsync error: error in rsync protocol data stream (code 12) at xattrs.c(565)
[receiver=3.0.2]
rsync: connection unexpectedly closed (1694 bytes received so far) [sender]
rsync error: error in rsync protocol data stream (code 12) at io.c(635)
[sender=3.0.2]


Version-Release number of selected component (if applicable):


How reproducible:

100% on my system.  I have not figured out reproduce steps which don't use my
external disk and file systems created with Fedora 8...   The following is the
command I execute:

Steps to Reproduce:
1. mkdir -p /media/backups
2. mount /dev/sdb1 /media/backups
3. mkdir -p /media/backups/hartnell.local/DellPrecision490/Fedora8/20080606.dir
4. mkdir -p /dev/shm/lvbackup/src
5. mount /dev/DellPrecision/Fedora8 /dev/sdm/lvbackup/src/. 
6. rsync -aXHSA --delete
--link-dest=/media/backups/hartnell.local/DellPrecision490/Fedora8/20080527.dir
/dev/shm/lvbackup/src/.
/media/backups/hartnell.local/DellPrecision490/Fedora8/20080606.dir/.
  
Actual results:

rsync: writefd_unbuffered failed to write 4 bytes [sender]: Broken pipe (32)
[receiver] internal abbrev error!
rsync error: error in rsync protocol data stream (code 12) at xattrs.c(565)
[receiver=3.0.2]
rsync: connection unexpectedly closed (1694 bytes received so far) [sender]
rsync error: error in rsync protocol data stream (code 12) at io.c(635)
[sender=3.0.2]

Expected results:

Successful backup.

Additional info:

The backup works without the -X option.  But then the seLinux attributes are not
backed-up, making the restore extremely difficult.
Comment 1 Bill C. Riemers 2008-06-06 22:31:27 EDT
See related bug #450360.
Comment 2 Bill C. Riemers 2008-06-07 01:08:06 EDT
Created attachment 308586 [details]
test case

I found a small enough subset of my directory tree to attach as a test case. 
Running the following commands will reproduce the bug:

1. tar xfj rsync-test.tar.bz2
2. cd rsync-test
3. ./test.sh
Comment 3 Bill C. Riemers 2008-06-10 12:40:47 EDT
I see there is now an upstream fix.  I am testing it now with my backup script.

Comment 4 Bill C. Riemers 2008-06-10 13:18:29 EDT
Looks like the upstream "fix" completely breaks the -X attribute.  Please
re-open the upstream bug.  I have already commented about the breakage in the
bug report, but I don't have sufficient privilege to re-open.
Comment 5 Simo Sorce 2008-06-30 10:17:09 EDT
bill can you check if 3.0.3 works for you ?
I am pushing it to testing but will dump it if the bug is still present
Comment 6 Fedora Update System 2008-06-30 10:17:32 EDT
rsync-3.0.3-0.fc9 has been submitted as an update for Fedora 9
Comment 7 Fedora Update System 2008-07-01 01:28:53 EDT
rsync-3.0.3-0.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rsync'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-5899
Comment 8 Bill C. Riemers 2008-07-01 09:06:31 EDT
I am on the road this week, so I can't try my backup and restore scripts.  But I
did run a few tests on my laptop.   It looks good to me.  :)
Comment 9 Simo Sorce 2008-07-01 09:35:16 EDT
Great, I will let bodhi close the bug, do not forget to add karma to the update :-)
Comment 10 Fedora Update System 2008-07-17 10:19:39 EDT
rsync-3.0.3-0.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.