Bug 450381 - Romanian locale needs 4 keyboard arrangements in the keyboard list
Romanian locale needs 4 keyboard arrangements in the keyboard list
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhpl (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 337271 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-07 05:53 EDT by Alexandru Szasz
Modified: 2008-06-10 09:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-09 11:47:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add the three missing keyboard arrangements (1.41 KB, patch)
2008-06-07 05:53 EDT, Alexandru Szasz
no flags Details | Diff

  None (edit)
Description Alexandru Szasz 2008-06-07 05:53:16 EDT
+++ This bug was initially created as a clone of Bug #450380 +++

Description of problem:

system-config-keyboard has only one arrangement in the keyboard list for the
Romanian language. We have two standardized arrangements and two obsolete
arrangements. The list should have these names in it:

Romanian
Romanian (Standard)
Romanian (Cedilla)
Romanian (Standard Cedilla)

These are the equivalent commands for setting the keyboards according to the list:

setxkbmap ro
setxkbmap ro std
setxkbmap ro cedilla
setxkbmap ro std_cedilla

Version-Release number of selected component (if applicable):

Fedora 9 and Fedora 10

How reproducible:


Steps to Reproduce:
1. Open system-config-keyboard
2. Scroll to Romanian
3.
  
Actual results:

There is only one entry for Romanian in the list, that sets the default keymap
defined by xkeyboard-config.

Expected results:

There should be 4 entries:

Romanian
Romanian (Standard)
Romanian (Cedilla)
Romanian (Standard Cedilla)

Additional info:
Comment 1 Alexandru Szasz 2008-06-07 05:53:16 EDT
Created attachment 308593 [details]
Patch to add the three missing keyboard arrangements
Comment 2 Răzvan Sandu 2008-06-07 08:08:18 EDT
Hello,

Congratulations for fixing this longstanding bug !

Just a single question/idea:

Should we keep these keyboard layout denominations consistent with those in
Windows Vista, in order to avoid confusion from the non-technical users ?

FYI: actually, there is even a fifth layout, less important: Martin Poehler's
"Romanian (Legacy)", that have z and y inverted. Actually, I don't think someone
still uses this. Please see on http://www.secarica.ro

Regards,
Răzvan
Comment 3 Alexandru Szasz 2008-06-07 09:52:12 EDT
(In reply to comment #2)
> Hello,
> 
> Congratulations for fixing this longstanding bug !
> 
> Just a single question/idea:
> 
> Should we keep these keyboard layout denominations consistent with those in
> Windows Vista, in order to avoid confusion from the non-technical users ?

I don't think legacy says anything to a romanian user (this was tested), so I
opt against keeping the names from Vista.

> 
> FYI: actually, there is even a fifth layout, less important: Martin Poehler's
> "Romanian (Legacy)", that have z and y inverted. Actually, I don't think someone
> still uses this. Please see on http://www.secarica.ro

Only two arrangements are standard, I event thought twice before including the
wrong cedilla ones.
Comment 4 Chris Lumens 2008-06-09 11:47:04 EDT
This will be fixed in the next build of rhpl.  Thanks for the patch.
Comment 5 Jay Turner 2008-06-10 09:14:08 EDT
*** Bug 337271 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.