Bug 337271 - No standardised layout for Romanian keyboard
No standardised layout for Romanian keyboard
Status: CLOSED DUPLICATE of bug 450381
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-keyboard (Show other bugs)
5.4
All Linux
low Severity urgent
: ---
: ---
Assigned To: Jay Turner
http://www.secarica.ro
:
: 329071 (view as bug list)
Depends On: 353721 448289
Blocks: 329071 440992
  Show dependency treegraph
 
Reported: 2007-10-18 03:09 EDT by Răzvan Sandu
Modified: 2015-01-07 19:16 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-10 09:14:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Primary layout for the Romanian keyboard (39.17 KB, image/png)
2007-10-18 03:16 EDT, Răzvan Sandu
no flags Details
Secondary layout for the Romanian keyboard (39.01 KB, image/png)
2007-10-18 03:18 EDT, Răzvan Sandu
no flags Details

  None (edit)
Description Răzvan Sandu 2007-10-18 03:09:05 EDT
Hello,

Description of problem:

The Red Hat Enterprise Linux (as well as Fedora) don't offer the two
standardised layouts for the Romanian keyboard (neither at installation, in
anaconda, nor afterwards, in System -> Administration -> Keyboard).

Romanian keyboard arrangements are subject to the Romanian National Standard SR
13992:2004.

The standard gives two arrangements for the Romanian keyboard (please see in the
attached pictures):
1. the "primary" arrangement;
2. the "secondary" arrangement;

For all new implementations, the *default* keyboard arrangement should be the
*secondary* one (since the "primary" was implemented mainly because
compatibility/historical reasons).

Romanian-specific characters are obtained by pressing AltRight+character -
adding Shift for the uppercase.

A correct implementation for the Romanian keyboard should use the
"comma-versions" of "s" and "t" (please see bug #329071), namely:

- "S with comma below" (Unicode 0218)
- "s with comma below" (Unicode 0219)
- "T with comma below" (Unicode 021A)
- "t with comma below" (Unicode 021B)

Steps to Reproduce:
1. Install a fresh copy of Red Hat Enterprise Linux or Fedora;
2. During installation, at keyboard choosing screen, please observe there are no
choices for "Romanian primary" or "Romanian secondary".
3. After installation, observe the same in System -> Administration -> Keyboard.
 
Actual results:
There are no implementations for the Romanian keyboard layout, as given in the
Romanian National Standard SR 13992:2004.


Expected results:
Such implementations should be available, starting from the installation phase.

To maintain denomination consistency with Windows implementations, the two
layouts should be called:
- "Romanian (Standard)" - the "primary"
- "Romanian (Programmers)" - the "secondary", default when choosing "Romanian"
as system language.

Additional info:
http://www.secarica.ro
http://diacritice.sourceforge.net


Many thanks,
Răzvan
Comment 1 Răzvan Sandu 2007-10-18 03:16:22 EDT
Created attachment 230741 [details]
Primary layout for the Romanian keyboard
Comment 2 Răzvan Sandu 2007-10-18 03:18:26 EDT
Created attachment 230751 [details]
Secondary layout for the Romanian keyboard

This should be the default layout when choosing "Romanian" as system language.
Comment 3 Alexandru Szasz 2007-10-18 10:50:56 EDT
I'll provide the arrangements soon. Please hold a bit.
Comment 4 Red Hat Bugzilla 2007-10-23 11:24:52 EDT
User pgraner@redhat.com's account has been closed
Comment 5 Alexandru Szasz 2007-10-23 11:57:40 EDT
This ticket has a fix proposal in bug 253892
Comment 6 Alexandru Szasz 2007-11-16 08:26:55 EST
For text mode, this was fixed in bug 253892.
For X, I'll address Xorg to change the default keymap as it exists, it's just
not default.
Comment 7 Răzvan Sandu 2008-05-01 08:30:10 EDT
Hello,


Please, was that solved/included in the latest upgrades ? Namely:

1. Do we have the two keyboard arrangements, as standardised in the Romanian
Standard SR 13992:2004, included in the system-config-keyboard list ?

2. Do the Unicode characters generated by keys correspond to the (correct)
comma-below characters and not the (incorrect) cedilla-below ones, in both text
mode and X mode ?


Regards,
Razvan
Comment 8 Alexandru Szasz 2008-05-01 16:11:42 EDT
Just fyi, if Fedora/Red Hat doesn't modify the Xorg packages, this issue is in
progress on xorg's bugzilla.
Comment 9 Răzvan Sandu 2008-05-08 02:10:54 EDT
The issue was recently corrected in bug #13277 at freedesktop.org.
Please see comments #82 and #83, with the appropriate patch:

http://bugs.freedesktop.org/show_bug.cgi?id=13277

Would you please include this in Red Hat/Fedora ASAP, since it affects
*thousands* of documents and webpages generated in Romanian language ?

Thanks a lot,
Răzvan


Comment 10 Răzvan Sandu 2008-05-13 02:46:00 EDT
Hello,

The patch at

http://bugs.freedesktop.org/show_bug.cgi?id=13277

was commited/applied. It it will soon show up in the upstream code, so please
include it into Red Hat / Fedora.

Regards,
Răzvan
Comment 11 Vitezslav Crhonek 2008-05-13 05:57:31 EDT
*** Bug 329071 has been marked as a duplicate of this bug. ***
Comment 12 Răzvan Sandu 2008-05-13 06:35:35 EDT
Hello,

Alex said that this is fixed in Fedora 9.

Can you please sketch a step-by-step procedure to find out if/how is that fixed ?

I'm running Fedora 9 Preview Release with all updates (upgraded from Fedora 8
via preupgrade) and I have three problems:


- the graphical utility for setting the keyboard language
(system-config-keyboard) is nowhere in the Gnome menus;

- if invoked manually from a terminal, system-config-keyboard let me choose
"Romanian" from the list, but that's all. There is no way to choose from the
five possible settings, namely:

    a. Primary Romanian layout with comma-below characters
    b. Secondary Romanian layout with comma-below characters (should be DEFAULT
for Romanian language)
    c. Primary Romanian layout with cedilla-below characters (compatibility mode
still necessary)
    d. Secondary Romanian layout with cedilla-below characters (compatibility
mode still necessary)
    e. Romanian Legacy/Martin Poehler (compatibility mode still necessary)


- using AltGr+key in applications to generate diacritics, I'm still inserting
cedilla-below characters (Thunderbird, mutt, OpenOffice.org, etc.).


How do you suggest to fix all this ?


Thanks a lot,
Răzvan
Comment 13 Alexandru Szasz 2008-05-13 06:56:03 EDT
For console mode, verify that:

file /etc/sysconfig/keyboard has the following content:

KEYBOARDTYPE="pc"
KEYTABLE="ro"


file /etc/sysconfig/i18n has the following content:

LANG="ro_RO.UTF-8"
SYSFONT="Lat2-Terminus16"

The only place where you can set the console keymap is the language dialog that
does not ofer a way to select alternative keymaps.

You can edit the file /etc/sysconfig/keyboard replacing "ro" with "ro_std" for
the primary romanian layout. Or run the command loadkeys
/lib/kbd/keymaps/i386/qwerty/ro_std.map.gz in a console, not in an X terminal.

I decided to stop providing the layouts that allow use of the wrong s and t with
cedilla instead of the correct s and t with comma. Reasons for this are:
- people use the console to create directories
- linux people use the console for linux, not for interacting with windows
- stop propagating wrong characters

For X mode, download this patch:
https://bugs.freedesktop.org/attachment.cgi?id=16354

Open a terminal, go to /usr/share/X11/xkb. Run patch -p0 downloaded_file_above.
Ignore any warnings.

After this, you will have the following arrangements:

setxkbmap ro - s and t with comma, secondary romanian layout
setxkbmap ro std - s and t with comma, primary romanian layout
setxkbmap ro cedilla - s and t with cedilla, secondary romanian layout
setxkbmap ro std_cedilla - s and t with cedilla, primary romanian layout.

You have to apply this patch manually, because it will take a while for xorg
people to release Xorg, to be tested, then included in Fedora, then tested, then
released.
Comment 14 Răzvan Sandu 2008-05-13 08:04:57 EDT
Alex, I agree 100% with your comments.

Only a few things to be more precise:

- we need a mechanism to be 100% sure that the Terminus font (or whatever font
is the default for Romanian) *is actually installed* when system is set to
Romanian. IMHO, this would be the job of the system-config-language utility.

- I 100% sustain your position of not using wrong characters (cedilla). However,
there are situations where you will need to insert the cedilla characters (for
example, you have an old document typed with cedillas and you don't want to
modify it (for whatever reason, say fidelity) );

- we absolutely need a graphical utility like system-config-keyboard to set this
Romanian keymap *and* their variants. One cannot expect a regular, non-technical
user to hack /etc/sysconfig by hand.

Point no. 3 above is what *this bug* is all about, in the first place.


Friendly regards,
Răzvan
Comment 15 Vitezslav Crhonek 2008-05-13 08:23:22 EDT
Terminus font is part of kbd package - when kbd is installed, Terminus font is
installed too.

Old keymap (ro_win.map.gz) has been removed from kbd package, if there will be
need to put it back - no problem. (I'm not sure, if it's removed from upstream
tarball too or it's done only in Fedora.)

Right keymap and font should be set during installation (if not, fill bug
against anaconda, but if I remember correctly, Alexandru did it in the past).
I'm not very familiar with X keyboard/font settings, but I assume this bug (or X
org bug) is going to solve it.
Comment 16 Răzvan Sandu 2008-05-13 08:49:27 EDT
Thank you, Viteslav !


IMHO, the critical things mentioned in comment #14 are points 1 and 3:


As I learn from you, 1 is resolved already (as long as Terminus is the default
font for Romanian).

For 3, the graphical utility system-config-keyboard should present the user the
option to set up not only the "Romanian" keyboard, but (at least) a. and b. in
comment #12. (c., d., e. are discouraged by Alexandru; the opportunity of their
presence is left to be discussed). But *please* insert a. and b. options in
system-config-keyboard's list, with b. being the *default* one.


Anaconda should do the same during install, if the system is set up to Romanian
during installation.


Thanks a lot,
Răzvan
Comment 17 Alexandru Szasz 2008-05-13 08:58:58 EDT
(In reply to comment #14)
> Alex, I agree 100% with your comments.
> 
> Only a few things to be more precise:
> 
> - we need a mechanism to be 100% sure that the Terminus font (or whatever font
> is the default for Romanian) *is actually installed* when system is set to
> Romanian. IMHO, this would be the job of the system-config-language utility.

As Vitezslav pointed, the font is always installed.

> 
> - I 100% sustain your position of not using wrong characters (cedilla). However,
> there are situations where you will need to insert the cedilla characters (for
> example, you have an old document typed with cedillas and you don't want to
> modify it (for whatever reason, say fidelity) );

The wrong cedillas are useless in console imho, worst, they will bring mayham if
you create directories/files with diacritics and/or use passwords with them;
it's important to make sure that in console mode we don't have 2 types of ș and ț.

In graphic mode, the cedilla arrangement is available for selection in Gnome,
KDE utilities. AFAIK Fedora or RHEL does not provide a utility to choose the
keyboard layout, probably because GNOME and KDE have such nice programs for this
anywat.

> 
> - we absolutely need a graphical utility like system-config-keyboard to set this
> Romanian keymap *and* their variants. One cannot expect a regular, non-technical
> user to hack /etc/sysconfig by hand.

Configuring the system is the job of a system administrator (you need root
privileges right?).

Configuring the GNOME or KDE or whatever desktop manager is used is the job of a
regular user. GNOME, KDE, XFCE, the most used desktop managers offer a way to
select a keyboard layout through a nice program or an applet.

I think system-config-keyboard hacks the xorg.conf file (graphic mode) and
system-config-language writes the /etc/sysconfig/keyboard file (console mode).

I also think that system-config-keyboard reads the keymaps from x files somewhere.

Vitezslav, am I correct ?


Comment 19 Răzvan Sandu 2008-06-07 04:37:24 EDT
Hello,

I'm just trying to resume here what I think it should be done for this bug:

- *have* a menu-based tool that changes the keyboard layout (be it the actual
system-config-keyboard or another tool provided by Gnome, KDE, XFCE, etc.);

- we should have such a tool available in *both X and text mode* (one
graphical-based, one ncurses-based, like system-config-keyboard and
system-config-keyboard-tui);

- for the Romanian language, this tool should present the user two menu options,
corresponding to the keyboard arrangements in the Romanian national standard:
"Romanian - primary" and "Romanian - secondary".

- both these arrangements should generate *comma-below* characters when pressing
keys s/S ans t/T with Romanian diacritics;

- *if* some user only chooses "Romanian" in system-config-language and does not
explicitly set the keyboard arrangement in system-config-keyboard, the "Romanian
- secondary" keyboard arrangement should be the default.


Regards,
Răzvan
Comment 20 Alexandru Szasz 2008-06-07 05:58:27 EDT
Răzvan, I just provided a patch to solve this for Fedora in bug 450381.
You can close this bug and clone the bug 450381 for Red Hat Enterprise.

The patch will put 4 keyboard arrangements in the list of system-config-keyboard
(the 2 standardized and the 2 obsolete with cedillas)
Comment 21 Răzvan Sandu 2008-06-07 10:41:31 EDT
Despite the fact I'm the reporter, it seems I'm not allowed to close this bug.

Jay, would you please close it as CLOSED DUPLICATE 450381 ?


Thanks,
Răzvan
Comment 22 Jay Turner 2008-06-10 09:14:07 EDT

*** This bug has been marked as a duplicate of 450381 ***

Note You need to log in before you can comment on or make changes to this bug.