This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 450396 - Romanian locale needs 4 keyboard arrangements in the keyboard list
Romanian locale needs 4 keyboard arrangements in the keyboard list
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhpl (Show other bugs)
5.4
All Linux
low Severity high
: rc
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-07 10:45 EDT by Răzvan Sandu
Modified: 2013-04-12 15:45 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-16 15:06:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Răzvan Sandu 2008-06-07 10:45:22 EDT
+++ This bug was initially created as a clone of Bug #450381 +++

+++ This bug was initially created as a clone of Bug #450380 +++

Description of problem:

system-config-keyboard has only one arrangement in the keyboard list for the
Romanian language. We have two standardized arrangements and two obsolete
arrangements. The list should have these names in it:

Romanian
Romanian (Standard)
Romanian (Cedilla)
Romanian (Standard Cedilla)

These are the equivalent commands for setting the keyboards according to the list:

setxkbmap ro
setxkbmap ro std
setxkbmap ro cedilla
setxkbmap ro std_cedilla

Version-Release number of selected component (if applicable):

Fedora 9 and Fedora 10

How reproducible:


Steps to Reproduce:
1. Open system-config-keyboard
2. Scroll to Romanian
3.
  
Actual results:

There is only one entry for Romanian in the list, that sets the default keymap
defined by xkeyboard-config.

Expected results:

There should be 4 entries:

Romanian
Romanian (Standard)
Romanian (Cedilla)
Romanian (Standard Cedilla)

Additional info:

-- Additional comment from alexxed@gmail.com on 2008-06-07 05:53 EST --
Created an attachment (id=308593)
Patch to add the three missing keyboard arrangements


-- Additional comment from razvan.sandu@mobexpert.ro on 2008-06-07 08:08 EST --
Hello,

Congratulations for fixing this longstanding bug !

Just a single question/idea:

Should we keep these keyboard layout denominations consistent with those in
Windows Vista, in order to avoid confusion from the non-technical users ?

FYI: actually, there is even a fifth layout, less important: Martin Poehler's
"Romanian (Legacy)", that have z and y inverted. Actually, I don't think someone
still uses this. Please see on http://www.secarica.ro

Regards,
Răzvan

-- Additional comment from alexxed@gmail.com on 2008-06-07 09:52 EST --
(In reply to comment #2)
> Hello,
> 
> Congratulations for fixing this longstanding bug !
> 
> Just a single question/idea:
> 
> Should we keep these keyboard layout denominations consistent with those in
> Windows Vista, in order to avoid confusion from the non-technical users ?

I don't think legacy says anything to a romanian user (this was tested), so I
opt against keeping the names from Vista.

> 
> FYI: actually, there is even a fifth layout, less important: Martin Poehler's
> "Romanian (Legacy)", that have z and y inverted. Actually, I don't think someone
> still uses this. Please see on http://www.secarica.ro

Only two arrangements are standard, I event thought twice before including the
wrong cedilla ones.
Comment 1 Răzvan Sandu 2008-10-03 03:07:40 EDT
Hello,


Please, is this much-needed patch scheduled to *officially* appear in Fedora 9, Fedora 10, RHEL5 and CentOS anytime soon ?

Currently, there is no *easy* way to write a document with correct Romanian characters in Fedora 9, even if one has the correct fonts installed (those with comma below for Romanian-specific characters).

We arrived in the strange point where one can do this on Windows XP (using Cristian Secara's driver at http://www.secarica.ro and Microsoft's additions to European Union fonts), but is hard to do it on Linux...


Thanks a lot,
Răzvan
Comment 2 Răzvan Sandu 2008-10-03 03:13:24 EDT
Also, how can we make sure that, if one chooses Romanian as the system language (in system-config-language), the *default* keyboard arrangement becomes "secondary layout" + "comma below"  ?

Thanks again,
Răzvan
Comment 3 Hans de Goede 2008-10-03 03:17:03 EDT
(In reply to comment #1)
> Hello,
> 
> 
> Please, is this much-needed patch scheduled to *officially* appear in Fedora 9,
> Fedora 10, RHEL5 and CentOS anytime soon ?
> 
> Currently, there is no *easy* way to write a document with correct Romanian
> characters in Fedora 9, even if one has the correct fonts installed (those with
> comma below for Romanian-specific characters).
> 
> We arrived in the strange point where one can do this on Windows XP (using
> Cristian Secara's driver at http://www.secarica.ro and Microsoft's additions to
> European Union fonts), but is hard to do it on Linux...
> 

This should be fixed in Fedora-10 (see bug 450381), have you tried it in F-10 beta? If not please try ASAP and let us know about any problems there, then we can try to fix it for F-10.

As for fixing this in RHEL, I'm afraid it won't make 5.3 but I think its a pretty safe fix to backport from F-10 (once confirmed fixed there) for RHEL-5.4

What do the other anaconda team members think?
Comment 4 Hans de Goede 2008-10-03 03:18:06 EDT
(In reply to comment #2)
> Also, how can we make sure that, if one chooses Romanian as the system language
> (in system-config-language), the *default* keyboard arrangement becomes
> "secondary layout" + "comma below"  ?
> 

I dunno, but that is a separate issue please file a new bug for tracking that.
Comment 5 Alexandru Szasz 2008-10-03 03:54:54 EDT
Hi, 

I'm the translation coordinator for Romanian Fedora. I can confirm that this was fixed in rawhide a while ago and it still works.
Comment 6 Hans de Goede 2008-10-03 04:02:03 EDT
I'll pick this up and try to get it on the list for RHEL-5.4, please ping me when 5.3 is released (otherwise I will probably forget and this may fall through the cracks).
Comment 7 Denise Dumas 2008-10-03 09:48:36 EDT
Setting 5.4 to ? so this shows up in the tracking list
Comment 8 Răzvan Sandu 2008-12-16 18:40:11 EST
Hello,

I am able to confirm that all necessary keyboard arangements for Romanian language are already present in Fedora 10, so the good starting point for solving this bug in RHEL would be to inherit the new code from there and test/refine it.

For correct Romanian support in RHEL, there are other conditions to meet, too: please see bug #472176 and bug #466117 . Mainly, proper UTF-8 fonts, support in configuration utilities (system-config-...), support in anaconda.


Regards,
Răzvan
Comment 9 RHEL Product and Program Management 2009-03-26 13:08:13 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 10 Dag Wieers 2009-05-01 06:04:01 EDT
The impact of this bug on the Romanian market was recently explained in detail at:

    http://dag.wieers.com/blog/are-there-too-few-people-who-understand-desktop-linux#comment-1779
Comment 11 Răzvan Sandu 2009-05-16 05:39:45 EDT
Hello,


Here's a practical case where Red Hat Enterprise Linux / CentOS 5.3 cannot be used by Romanian users, due to this missing feature (please also see bug 472176).

In my company, I have to install a few workstatations for a group of fellow developers. Since a few Windows-only applications are needed, RHEL/CentOS would be the perfect environment to run Windows in virtualization (with Red Hat's NATIVE virtualization, not VMWare or Sun's VirtualBox solutions).

The hardware is just more powerfull PCs, not other class of machines: 64-bit Intel based, 4 GB RAM, 500 GB HDD.

The idea is to move on the host Linux as much as desktop functionality as possible - such as browsing, e-mail, office suite, etc. - while leaving inside the  virtualized box ONLY the Windows-only programs. When we will have complete Linux solutions, Windows in virtualization will be completely dropped.

But, for the moment, the Linux dom0 cannot be used as a workstation in Romanian language, because users are unable to create CORRECT Romanian e-mails and documents.

No published workaround seems to be present, so we must wait next releases, until correct Romanian language support is backported from Fedora to RHEL/CentOS.

Fedora 11 would be another logical choice for the workstations, but it cannot be used since it has no support for virtualization (dom0).

Another solution is to run the desktop applications - Thunderbird, OpenOffice.org - in a Fedora 11 virtualized on CentOS, but this should be too much overhead. *Two* virtualised machines just to run a pretty regular office workstation ?


Best regards,
Răzvan
Comment 15 RHEL Product and Program Management 2009-11-06 14:06:23 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Note You need to log in before you can comment on or make changes to this bug.