Bug 450401 - hard freeze activating wlan rt2500 after kernel upgrade to 2.6.25.4-10.fc8
hard freeze activating wlan rt2500 after kernel upgrade to 2.6.25.4-10.fc8
Status: CLOSED DUPLICATE of bug 451422
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i686 Linux
low Severity high
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
: 452350 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-07 14:49 EDT by Dennis Bruno
Modified: 2008-08-26 11:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-26 11:37:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
excerpt of var/log/messages containing wlan activation attempts (7.47 KB, text/plain)
2008-06-15 11:24 EDT, Dennis Bruno
no flags Details
dmesg with kernel errors after inserting rt2500 card (23.87 KB, text/plain)
2008-06-21 13:35 EDT, Bob Hockney
no flags Details
log of failed association (4.76 KB, text/plain)
2008-07-07 13:04 EDT, Bob Hockney
no flags Details

  None (edit)
Description Dennis Bruno 2008-06-07 14:49:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.14) Gecko/20080416 Fedora/2.0.0.14-1.fc8 Firefox/2.0.0.14

Description of problem:
Upgraded to new kernel (2.6.25.4-10) from 2.6.24.7-92 via PUP.  Upon reboot, computer freezes when trying to activate wlan Linksys wireless 54gV4 PCI wlan card (RT2500 driver).  Works fine under prior kernel.  No messages in log, no kernel panic,just hard freeze when trying to activate card.

Version-Release number of selected component (if applicable):
kernel-2.6.25.4-10.fc8

How reproducible:
Always


Steps to Reproduce:
1.boot kernel 2.6.25.4-10.fc8
2.try to activate wlan card eithe automatically in Network Manager, or manually
3.computer hard freezes

Actual Results:
computer hard freezes, can only power down and reboot.  works fine under prior kernel.

Expected Results:
wlan card should have activated.

Additional info:
None.  Nothing is written to log
Comment 1 Roberto Ragusa 2008-06-08 15:34:39 EDT
This has been happening to me on older fc8 kernels too.

And it also happens on fc9 (2.6.25.4-30.fc9.i586).
My hardware is a PCMCIA rt2500 card (Edimax), which was usable with
the old ralink driver.
When I plug in the board, the driver is loaded and the system locks up
immediately or after a few seconds (memory corruption).

A stack trace of mine is available here:
  http://www.kerneloops.org/raw.php?rawid=22175

Finger pointed to locking, interrupts, sleeping in the rt2500 driver.
Comment 2 David W. Legg 2008-06-11 11:35:20 EDT
I too get this with a Ralink RT2500 PCMCIA card with the latest Fedora 9 kernel
(to date).  Can look up more info later if you wish.  The previous Fedora 9
kernel works fine, but the latest one crashed a second after you plug the card in.
The kerneloops service has reported the incident.  As I say, ask if you want
more info.
Comment 3 Eric Tanguy 2008-06-11 17:04:33 EDT
I have the same problem. In fact at boot up with the wlan card acitivated at
boot the system try to enable wlan0 for an infinte time. If i disable wlan0 at
boot and i try to activate wlan0 from grome i obtain a hard freeze. 
Comment 4 John W. Linville 2008-06-12 08:24:28 EDT
Please try -39.fc9 or later:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=50951

Those contain this fix: "rt2x00: Use atomic interface iteration in irq 
context".  Do the later kernels resolve the issue for you?
Comment 5 Eric Tanguy 2008-06-14 03:34:03 EDT
I tried kernel-2.6.25.6-24.fc8 which is an updates-testing and contain this fix.
No more hard freeze but impossible to associate to the access point.
Comment 6 Mostafa Afgani 2008-06-15 07:38:38 EDT
Yes, I can also verify that rt2500pci from kernel-2.6.25.6-24.fc8 does not
associate with the AP.
Comment 7 Dennis Bruno 2008-06-15 11:24:40 EDT
Created attachment 309399 [details]
excerpt of var/log/messages containing wlan activation attempts
Comment 8 Dennis Bruno 2008-06-15 11:29:17 EDT
Addendum to comment #7 (sorry for multiple posts).  Tried kernel
2.6.25.6-55.fc9.  Hard freeze now gone, but cannot associate with AP either. 
Messages in above attachment.  AP is WPA2-PSK.  Original passphrase stored in
keychain, but after first attempt, NetworkManager prompts me to input, but
activation fails anyway, and I get prompted again (until I cancel).
Comment 9 Bob Hockney 2008-06-21 13:35:04 EDT
Created attachment 309979 [details]
dmesg with kernel errors after inserting rt2500 card

I get kernel error messages but no hard freeze with the rt2500.  With testing
kernel no errors but can't associate with AP.  Another card with a differnt
chipset works fine.
Comment 10 John W. Linville 2008-06-24 08:28:28 EDT
*** Bug 452350 has been marked as a duplicate of this bug. ***
Comment 11 Mostafa Afgani 2008-07-04 13:50:42 EDT
Association still times out with kernel-2.6.25.9-40.fc8
Comment 12 Paul van Maaren 2008-07-06 06:34:48 EDT
Kernel 2.6.25.6-27.fc8 fixed the hard freeze for me and works like expected, but
with kernel 2.6.25.9-40.fc8 I cannot associate using wpa_supplicant.
Comment 13 John W. Linville 2008-07-07 10:14:12 EDT
You might wisht to try -46.fc8:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=54856

Does that help with wpa_supplicant?
Comment 14 Bob Hockney 2008-07-07 13:04:21 EDT
Created attachment 311195 [details]
log of failed association

still unable to associate with -46 kernel
Comment 15 Paul van Maaren 2008-07-07 17:59:43 EDT
For me too, still unable to associate with -46.fc8 kernel

Comment 16 Mostafa Afgani 2008-07-09 04:04:55 EDT
Same story with both -47.fc8 and -48.fc8.
Comment 17 Eric Tanguy 2008-07-15 11:50:10 EDT
Same with kernel-2.6.25.11-54.fc8
This bug is opened since 5 weeks. It's quite a long time ...
Comment 18 Mostafa Afgani 2008-08-25 18:53:27 EDT
Just tried 2.6.26.3-5.fc8 from Koji. Still doesn't work .. (i.e. authentication with AP times out).
Comment 19 John W. Linville 2008-08-26 09:17:29 EDT
Hmmm...well "AP times out" sounds different than "hard freeze".  Perhaps the problem you are seeing now is the same as bug 451422?
Comment 20 Eric Tanguy 2008-08-26 10:07:15 EDT
John, problems of association and times out are part of this bug since a long time see for example comment 5.
Comment 21 Mostafa Afgani 2008-08-26 11:14:47 EDT
Hi John, I suppose it might be same as bug 451422 but the end result is still the same. I've had to stick with a 2.6.24 series kernel for at least two months now ..
Comment 22 John W. Linville 2008-08-26 11:37:38 EDT
Please use bug 451422 for the association problems.  I'm sorry I didn't notice the change back in June.

*** This bug has been marked as a duplicate of bug 451422 ***

Note You need to log in before you can comment on or make changes to this bug.