This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 450450 - Please patch audacity to support PulseAudio
Please patch audacity to support PulseAudio
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: audacity (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Gérard Milmeister
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-08 12:15 EDT by George Notaras
Modified: 2009-03-06 07:40 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-06 07:40:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George Notaras 2008-06-08 12:15:35 EDT
Description of problem:
Although audacity reports signal in its output level meters, no actual sound
comes out from the speakers. Moreover, the available devices in the Playback
device list are significantly less than expected.

Version-Release number of selected component (if applicable):
1.3.2-21.fc9

How reproducible:
Always

Steps to Reproduce:
1.open audacity
2.load a wav file
3.press play
  
Actual results:
no sound from speakers

Expected results:
should hear sound from speakers

Additional info:

Workaround:
As a workaround you can override pulseaudio by invoking audacity in the
following way:

  pasuspender audacity
Comment 1 Michael Schwendt 2008-06-08 12:57:03 EDT
There is no special support for PulseAudio in Audacity (which
uses the PortAudio library internally). It is normal to disable
PulseAudio when running Audacity, so it gets direct access to
ALSA.

Note, however, the newer Audacity in the updates-testing
repository: "yum --enablerepo=updates-testing update audacity"
https://admin.fedoraproject.org/updates/F9/FEDORA-2008-3999
Comment 2 George Notaras 2008-06-08 13:19:45 EDT
As far as pulseaudio is concerned, audacity from updates-testing works fine.
Also, it generally runs without any other issues here. Thank you.
Comment 3 Kevin Kofler 2008-11-16 02:57:57 EST
Uh no, this doesn't support PulseAudio, PortAudio (which is what Audacity uses) doesn't support this at the moment.
Comment 5 Kevin Kofler 2008-12-11 03:50:01 EST
As Audacity uses a private fork of the PortAudio library, please apply the following patch which also went into the system portaudio:
https://bugzilla.redhat.com/attachment.cgi?id=326162

See https://bugzilla.redhat.com/show_bug.cgi?id=445644 for the discussion.
Comment 6 Kevin Kofler 2008-12-11 03:51:06 EST
See also https://bugzilla.rpmfusion.org/show_bug.cgi?id=242 against audacity-freeworld.
Comment 7 Michael Schwendt 2008-12-11 07:41:17 EST
What's the portaudio upstream status for that patch? Once merged, it'll be only a matter of time until Audacity devs pick up the changes.
Comment 8 Kevin Kofler 2008-12-11 07:44:40 EST
Unfortunately, upstream appears not to care at all, I have yet to receive a reply from upstream. :-(

IMHO this is something definitely worth carrying a patch in Fedora, having Audacity not work with the default sound system in Fedora is really bad! Also keep in mind that our portaudio package is already carrying that patch.
Comment 9 Michael Schwendt 2009-03-06 07:40:20 EST
Closing due to comment 2 and because the patch is in Rawhide and F-10 updates-testing.

Note You need to log in before you can comment on or make changes to this bug.