Bug 450638 - Cannot download debuginfo packages
Cannot download debuginfo packages
Status: CLOSED DUPLICATE of bug 216258
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
510
All Linux
high Severity medium
: ---
: ---
Assigned To: Shannon Hughes
Brandon Perkins
http://$SATELLITE_SERVER/network/soft...
:
Depends On:
Blocks: 471260
  Show dependency treegraph
 
Reported: 2008-06-09 22:46 EDT by Satoru SATOH
Modified: 2009-09-01 17:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-01 17:39:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Satoru SATOH 2008-06-09 22:46:32 EDT
+++ This bug was initially created as a clone of Bug #238089 +++

How Reproducible:

Steps to Reproduce:
1. Go to http://rhn.redhat.com/network/software/packages/details.pxt and login
2. Click [kernel-smp-debuginfo...] to download debuginfo RPM
3.

Actual Results:
Cannot donwload it.


Expected Results:


Additional Information:
FTP URL looks wrong.

Actual: ftp://ftp.redhat.com/pub/redhat/linux/enterprise/3/en/os/i686/Debuginfo/...
Expected:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/3/en/os/i386/Debuginfo/...

-- Additional comment from ssato@redhat.com on 2008-06-09 04:34 EST --
This problem is still there in the latest RHN web site (Mon Jun  9 17:19:26 JST
2008).


Examples: The following links found at RHN web site are missing.

ftp://ftp.redhat.com/pub/redhat/linux/enterprise/4.6.z/en/os/i686/Debuginfo/kernel-smp-debuginfo-2.6.9-67.0.15.EL.i686.rpm
linked from RHN web:
https://rhn.redhat.com/network/software/packages/details.pxt?pid=440211

ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5.2.z/en/os/i686/Debuginfo/kernel-debuginfo-2.6.18-92.1.1.el5.i686.rpm
linked from RHN web:
https://rhn.redhat.com/network/software/packages/details.pxt?pid=446861


The problem consists of two main parts, I guess.

(1) There is no FTP directory for EUS version at all;
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/4.6.z/ does not exist.
(ftp://ftp.redhat.com/pub/redhat/linux/enterprise/4/ does exist.)

(2) The arch subdir 'i686' does not exist;
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/4/en/os/i386/Debuginfo/ exists
but .../i686/Debuginfo/ does not. Even the kernel package is built for i686, the
arch subdir must be i386/, I think.
Comment 2 James M. Leddy 2009-09-01 17:39:33 EDT
I hope you don't mind, I'm marking duplicate.

*** This bug has been marked as a duplicate of bug 216258 ***

Note You need to log in before you can comment on or make changes to this bug.